summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-04 02:06:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-04 02:06:46 +0000
commitabf06cfbcfd206709592a8055d14a5a737f1b5d2 (patch)
tree5b31497ef181ef36077cfca08f9188449baa0b87
parentStable on alpha wrt Bug #115045. (diff)
downloadgentoo-2-abf06cfbcfd206709592a8055d14a5a737f1b5d2.tar.gz
gentoo-2-abf06cfbcfd206709592a8055d14a5a737f1b5d2.tar.bz2
gentoo-2-abf06cfbcfd206709592a8055d14a5a737f1b5d2.zip
Improve xinerama handling #145917 by Diego Pettenò.
(Portage version: 2.1.1_rc1-r2)
-rw-r--r--media-libs/libsdl/ChangeLog6
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.11-xinerama-head-0.patch22
-rw-r--r--media-libs/libsdl/libsdl-1.2.11.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index c3694bb01d93..9139f7dd3a26 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.105 2006/06/27 07:05:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.106 2006/09/04 02:06:45 vapier Exp $
+
+ 04 Sep 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/libsdl-1.2.11-xinerama-head-0.patch, libsdl-1.2.11.ebuild:
+ Improve xinerama handling #145917 by Diego Pettenò.
*libsdl-1.2.11 (27 Jun 2006)
diff --git a/media-libs/libsdl/files/libsdl-1.2.11-xinerama-head-0.patch b/media-libs/libsdl/files/libsdl-1.2.11-xinerama-head-0.patch
new file mode 100644
index 000000000000..56c8af1a6a4b
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.11-xinerama-head-0.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/145917
+
+--- SDL-1.2.11/src/video/x11/SDL_x11modes.c
++++ SDL-1.2.11/src/video/x11/SDL_x11modes.c
+@@ -509,7 +509,7 @@ int X11_GetVideoModes(_THIS)
+ /* Query Xinerama extention */
+ if ( CheckXinerama(this, &xinerama_major, &xinerama_minor) ) {
+ /* Find out which screen is the desired one */
+- int desired = 0;
++ int desired = -1;
+ int screens;
+ int w, h;
+ SDL_NAME(XineramaScreenInfo) *xinerama;
+@@ -630,7 +630,7 @@ int X11_GetVideoModes(_THIS)
+ /* XVidMode */
+ if ( !use_xrandr &&
+ #if SDL_VIDEO_DRIVER_X11_XINERAMA
+- (!use_xinerama || xinerama_info.screen_number == 0) &&
++ (!use_xinerama || xinerama_info.screen_number == -1) &&
+ #endif
+ CheckVidMode(this, &vm_major, &vm_minor) &&
+ SDL_NAME(XF86VidModeGetAllModeLines)(SDL_Display, SDL_Screen,&nmodes,&modes) )
diff --git a/media-libs/libsdl/libsdl-1.2.11.ebuild b/media-libs/libsdl/libsdl-1.2.11.ebuild
index 787d226f8add..66c082db98fd 100644
--- a/media-libs/libsdl/libsdl-1.2.11.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.11.ebuild,v 1.3 2006/08/06 17:03:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.11.ebuild,v 1.4 2006/09/04 02:06:45 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils libtool
@@ -77,6 +77,7 @@ src_unpack() {
epatch "${FILESDIR}"/libsdl-1.2.10-libcaca.patch #40224
epatch "${FILESDIR}"/libsdl-1.2.10-sdl-config.patch
+ epatch "${FILESDIR}"/libsdl-1.2.11-xinerama-head-0.patch #145917
# add yasm-compatible defines to nasm code (hopefully we
# can get this killed soonish)