summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-13 06:21:04 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-13 06:21:04 +0000
commitac424490569a8f2adf4de56ea88cd8fe87129966 (patch)
treeaba33487f9a6c88f71a23481ace0130a221220a3
parentfix inheritance (diff)
downloadgentoo-2-ac424490569a8f2adf4de56ea88cd8fe87129966.tar.gz
gentoo-2-ac424490569a8f2adf4de56ea88cd8fe87129966.tar.bz2
gentoo-2-ac424490569a8f2adf4de56ea88cd8fe87129966.zip
fix inheritance
-rw-r--r--app-text/info2html/info2html-1.4.ebuild12
-rw-r--r--sys-libs/pam/pam-0.77.ebuild48
-rw-r--r--x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild62
-rw-r--r--x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild10
4 files changed, 63 insertions, 69 deletions
diff --git a/app-text/info2html/info2html-1.4.ebuild b/app-text/info2html/info2html-1.4.ebuild
index 94248377d42b..b3cb9b54a49d 100644
--- a/app-text/info2html/info2html-1.4.ebuild
+++ b/app-text/info2html/info2html-1.4.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/info2html/info2html-1.4.ebuild,v 1.1 2003/09/28 01:05:46 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/info2html/info2html-1.4.ebuild,v 1.2 2003/11/13 06:16:13 vapier Exp $
+
+inherit eutils webapp-apache
+webapp-detect || NO_HTTPD=1
DESCRIPTION="Converts GNU .info files to HTML"
HOMEPAGE="http://info2html.sourceforge.net/"
SRC_URI="mirror://sourceforge/info2html/${P}.tgz"
+
LICENSE="freedist"
SLOT="0"
KEYWORDS="alpha arm hppa mips sparc x86"
-DEPEND="dev-lang/perl"
-inherit eutils
-inherit webapp-apache
-
-webapp-detect || NO_HTTPD=1
+DEPEND="dev-lang/perl"
src_unpack() {
unpack ${A}
diff --git a/sys-libs/pam/pam-0.77.ebuild b/sys-libs/pam/pam-0.77.ebuild
index 33b5cb082a22..d2e3cc3a59c9 100644
--- a/sys-libs/pam/pam-0.77.ebuild
+++ b/sys-libs/pam/pam-0.77.ebuild
@@ -1,29 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.2 2003/11/10 18:23:13 azarah Exp $
-
-# Note that we link to static versions of glib (pam_console.so)
-# and pwdb (pam_pwdb.so) ...
-
-DESCRIPTION="Pluggable Authentication Modules"
-HOMEPAGE="http://www.kernel.org/pub/linux/libs/pam/"
-
-IUSE="berkdb pwdb"
-
-PATCH_LEVEL="1.0"
-BDB_VER="4.1.25"
-PAM_REDHAT_VER="0.77-4"
-
-S="${WORKDIR}/Linux-PAM-${PV}"
-S2="${WORKDIR}/pam-${PVR}-patches"
-SRC_URI="http://www.kernel.org/pub/linux/libs/pam/pre/library/Linux-PAM-${PV}.tar.gz
- mirror://gentoo/${P}-patches-${PATCH_LEVEL}.tar.bz2
- berkdb? ( http://www.sleepycat.com/update/snapshot/db-${BDB_VER}.tar.gz )"
-
-LICENSE="PAM"
-#KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~ia64"
-KEYWORDS="-*"
-SLOT="0"
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.77.ebuild,v 1.3 2003/11/13 06:18:03 vapier Exp $
DEPEND="dev-lang/perl
>=sys-libs/cracklib-2.7-r8
@@ -53,6 +30,28 @@ RDEPEND=">=sys-libs/cracklib-2.7-r8
#inherit needs to be after DEPEND definition to protect RDEPEND
inherit gcc eutils flag-o-matic
+# Note that we link to static versions of glib (pam_console.so)
+# and pwdb (pam_pwdb.so) ...
+
+HOMEPAGE="http://www.kernel.org/pub/linux/libs/pam/"
+DESCRIPTION="Pluggable Authentication Modules"
+
+PATCH_LEVEL="1.0"
+BDB_VER="4.1.25"
+PAM_REDHAT_VER="0.77-4"
+
+S="${WORKDIR}/Linux-PAM-${PV}"
+S2="${WORKDIR}/pam-${PVR}-patches"
+SRC_URI="http://www.kernel.org/pub/linux/libs/pam/pre/library/Linux-PAM-${PV}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_LEVEL}.tar.bz2
+ berkdb? ( http://www.sleepycat.com/update/snapshot/db-${BDB_VER}.tar.gz )"
+
+LICENSE="PAM"
+#KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~ia64"
+KEYWORDS="-*"
+SLOT="0"
+IUSE="berkdb pwdb"
+
apply_pam_patches() {
local x=
local patch=
@@ -277,4 +276,3 @@ src_install() {
fi
done
}
-
diff --git a/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild b/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild
index f2c81af0c1f1..a5097a9da291 100644
--- a/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild
+++ b/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild,v 1.3 2003/11/12 15:35:36 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/mandrake-artwork/mandrake-artwork-0.9.3.ebuild,v 1.4 2003/11/13 06:21:04 vapier Exp $
+
+inherit eutils
-IUSE="kde"
MDK_EXTRAVERSION="1mdk"
DESCRIPTION="Mandrake's Galaxy theme for GTK1, GTK2, Metacity and KDE"
HOMEPAGE="http://www.mandrakelinux.com"
SRC_URI="mirror://gentoo/galaxy-${PV}-${MDK_EXTRAVERSION}.src.rpm"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc ~alpha"
-
-inherit eutils
+IUSE="kde"
# Needed to build...
DEPEND="app-arch/rpm2targz
@@ -22,38 +23,35 @@ DEPEND="app-arch/rpm2targz
kde? ( >=kde-base/kdebase-3.1* )"
src_unpack() {
- cd ${WORKDIR}
- rpm2targz ${DISTDIR}/${A}
- tar xz --no-same-owner -f galaxy-${PV}-${MDK_EXTRAVERSION}.src.tar.gz
- tar xj --no-same-owner -f galaxy-${PV}.tar.bz2
+ rpm2targz ${DISTDIR}/${A}
+ tar xz --no-same-owner -f galaxy-${PV}-${MDK_EXTRAVERSION}.src.tar.gz
+ tar xj --no-same-owner -f galaxy-${PV}.tar.bz2
}
src_compile() {
- cd ${WORKDIR}/galaxy-${PV}
- #make distclean
-
- if use kde; then
- KDE_PLACE_TO_INSTALL=$(echo $KDEDIR | cut -d/ -f4)
- mv thememdk/mandrake_client/Makefile.in thememdk/mandrake_client/Makefile.in.orig
- cat thememdk/mandrake_client/Makefile.in.orig | sed s:\$\{libdir\}\/kwin.la:/usr/kde/$KDE_PLACE_TO_INSTALL/lib/kwin.la:g > thememdk/mandrake_client/Makefile.in
- rm thememdk/mandrake_client/Makefile.in.orig
- econf --with-qt-dir=/usr/qt/3
- else
- sed -si s/KDE_CHECK_FINAL// configure.in
- sed -si s/AC_PATH_KDE// configure.in
- autoconf
- sed -si s/thememdk// Makefile.am
- sed -si s/thememdk// Makefile.in
- automake
- fi
- econf || die
- emake || die
+ cd ${WORKDIR}/galaxy-${PV}
+ #make distclean
+
+ if use kde; then
+ KDE_PLACE_TO_INSTALL=$(echo $KDEDIR | cut -d/ -f4)
+ mv thememdk/mandrake_client/Makefile.in thememdk/mandrake_client/Makefile.in.orig
+ cat thememdk/mandrake_client/Makefile.in.orig | sed s:\$\{libdir\}\/kwin.la:/usr/kde/$KDE_PLACE_TO_INSTALL/lib/kwin.la:g > thememdk/mandrake_client/Makefile.in
+ rm thememdk/mandrake_client/Makefile.in.orig
+ econf --with-qt-dir=/usr/qt/3
+ else
+ sed -si s/KDE_CHECK_FINAL// configure.in
+ sed -si s/AC_PATH_KDE// configure.in
+ autoconf
+ sed -si s/thememdk// Makefile.am
+ sed -si s/thememdk// Makefile.in
+ automake
+ fi
+ econf || die
+ emake || die
}
src_install () {
- cd ${WORKDIR}/galaxy-${PV}
- einstall || die
-
- cd ${WORKDIR}/galaxy-${PV}
- dodoc AUTHORS COPYING README ChangeLog
+ cd ${WORKDIR}/galaxy-${PV}
+ einstall || die
+ dodoc AUTHORS COPYING README ChangeLog
}
diff --git a/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild b/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
index 9c9cd44c8030..4cc831eb1794 100644
--- a/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
+++ b/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild,v 1.2 2003/11/12 09:04:28 tad Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/redhat-artwork/redhat-artwork-0.88.ebuild,v 1.3 2003/11/13 06:19:12 vapier Exp $
+
+inherit eutils rpm
RH_EXTRAVERSION="1"
DESCRIPTION="RedHat's Bluecurve theme for GTK1, GTK2, KDE3, GDM, Metacity and Nautilus"
HOMEPAGE="http://www.redhat.com"
SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/${P}-${RH_EXTRAVERSION}.src.rpm"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc"
@@ -27,10 +30,6 @@ DEPEND="sys-devel/autoconf
# OR gdm, we don't want any run-time dependencies...
RDEPEND=""
-inherit eutils rpm
-
-S="${WORKDIR}/${P}"
-
# We need to change some RedHat-specific stuff to Gentoo-style...
_replace() {
FROM=$1
@@ -179,4 +178,3 @@ src_install () {
cd ${S}
dodoc AUTHORS NEWS README ChangeLog
}
-