summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2008-02-29 22:10:53 +0000
committerAndrej Kacian <ticho@gentoo.org>2008-02-29 22:10:53 +0000
commitad01dacc90cca6d8c9a9d5074a6831370d333ad7 (patch)
tree2e85d7f898b1a7a744642c16afaf84111e545c4a
parentbump to 1.5.12 and remove old versions. 1.5.12 includes 24.8 pixel addressing. (diff)
downloadgentoo-2-ad01dacc90cca6d8c9a9d5074a6831370d333ad7.tar.gz
gentoo-2-ad01dacc90cca6d8c9a9d5074a6831370d333ad7.tar.bz2
gentoo-2-ad01dacc90cca6d8c9a9d5074a6831370d333ad7.zip
Version bump.
(Portage version: 2.1.4.4)
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/getmail-4.8.0.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index f564b2fcbf09..aa6529296f92 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.157 2008/02/13 21:56:13 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.158 2008/02/29 22:10:53 ticho Exp $
+
+*getmail-4.8.0 (29 Feb 2008)
+
+ 29 Feb 2008; Andrej Kacian <ticho@gentoo.org> +getmail-4.8.0.ebuild:
+ Version bump.
*getmail-4.7.8 (13 Feb 2008)
diff --git a/net-mail/getmail/getmail-4.8.0.ebuild b/net-mail/getmail/getmail-4.8.0.ebuild
new file mode 100644
index 000000000000..982d76029754
--- /dev/null
+++ b/net-mail/getmail/getmail-4.8.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.8.0.ebuild,v 1.1 2008/02/29 22:10:53 ticho Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # getmail.spec is missing due to upstream packaging mistake
+ sed -i -e '/getmail.spec/d' setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv "${D}"/usr/bin/getmail "${D}"/usr/bin/getmail4
+ mv "${D}"/usr/bin/getmail_maildir "${D}"/usr/bin/getmail_maildir4
+ mv "${D}"/usr/bin/getmail_mbox "${D}"/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ rm "${D}"/usr/share/doc/${P}/COPYING
+ if [ ${P} != ${PF} ]; then
+ mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}"/usr/share/doc/${PF}/*.css "${D}"/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}