summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-13 21:27:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-13 21:27:15 +0000
commitb0485fc899c85167f0f1c76d3dab6cc25424fed3 (patch)
tree51b78c8e36c4e8a6404944ca6990f5dff7dc0dce
parentDon't die if .config is not present, bug #296578. (diff)
downloadgentoo-2-b0485fc899c85167f0f1c76d3dab6cc25424fed3.tar.gz
gentoo-2-b0485fc899c85167f0f1c76d3dab6cc25424fed3.tar.bz2
gentoo-2-b0485fc899c85167f0f1c76d3dab6cc25424fed3.zip
Version bump.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
-rw-r--r--app-misc/tracker/ChangeLog8
-rw-r--r--app-misc/tracker/metadata.xml1
-rw-r--r--app-misc/tracker/tracker-0.7.10.ebuild26
-rw-r--r--app-misc/tracker/tracker-0.7.11.ebuild150
-rw-r--r--app-misc/tracker/tracker-9999.ebuild37
5 files changed, 193 insertions, 29 deletions
diff --git a/app-misc/tracker/ChangeLog b/app-misc/tracker/ChangeLog
index 77bdb7d0671e..22ca62f43857 100644
--- a/app-misc/tracker/ChangeLog
+++ b/app-misc/tracker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/tracker
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/ChangeLog,v 1.54 2009/12/10 23:15:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/ChangeLog,v 1.55 2009/12/13 21:27:14 eva Exp $
+
+*tracker-0.7.11 (13 Dec 2009)
+
+ 13 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org> tracker-0.7.10.ebuild,
+ +tracker-0.7.11.ebuild, tracker-9999.ebuild, metadata.xml:
+ Version bump.
*tracker-0.7.10 (10 Dec 2009)
diff --git a/app-misc/tracker/metadata.xml b/app-misc/tracker/metadata.xml
index bd52c5bfe804..1a74886c2280 100644
--- a/app-misc/tracker/metadata.xml
+++ b/app-misc/tracker/metadata.xml
@@ -12,6 +12,7 @@
<flag name="kmail">Build kmail data miner</flag>
<flag name="laptop">Make tracker power management aware</flag>
<flag name="playlist">Add support for playlists</flag>
+ <flag name="wv2">Build MS-Word .doc support.</flag>
<flag name="xmp">Adds support for XMP metadata extraction</flag>
</use>
</pkgmetadata>
diff --git a/app-misc/tracker/tracker-0.7.10.ebuild b/app-misc/tracker/tracker-0.7.10.ebuild
index afd9130a5581..48bb4d3f0747 100644
--- a/app-misc/tracker/tracker-0.7.10.ebuild
+++ b/app-misc/tracker/tracker-0.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.7.10.ebuild,v 1.1 2009/12/10 23:15:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.7.10.ebuild,v 1.2 2009/12/13 21:27:14 eva Exp $
EAPI="2"
G2CONF_DEBUG="no"
@@ -73,23 +73,25 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog NEWS README"
-function notify_inotify() {
- ewarn
- ewarn "You should enable the INOTIFY support in your kernel."
- ewarn "Check the 'Inotify support for userland' under the 'File systems'"
- ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
- ewarn
- die 'missing CONFIG_INOTIFY'
-}
-
function inotify_enabled() {
- linux_chkconfig_present INOTIFY_USER
+ if linux_chkconfig_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ echo
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ echo
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
}
pkg_setup() {
linux-info_pkg_setup
- inotify_enabled || notify_inotify
+ inotify_enabled
if use gstreamer ; then
G2CONF="${G2CONF}
diff --git a/app-misc/tracker/tracker-0.7.11.ebuild b/app-misc/tracker/tracker-0.7.11.ebuild
new file mode 100644
index 000000000000..26c71ab2f502
--- /dev/null
+++ b/app-misc/tracker/tracker-0.7.11.ebuild
@@ -0,0 +1,150 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-0.7.11.ebuild,v 1.1 2009/12/13 21:27:15 eva Exp $
+
+EAPI="2"
+G2CONF_DEBUG="no"
+
+inherit gnome2 linux-info
+
+DESCRIPTION="A tagging metadata database, search tool and indexer"
+HOMEPAGE="http://www.tracker-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# USE="doc" is managed by eclass.
+IUSE="applet deskbar doc eds exif gsf gstreamer gtk hal iptc +jpeg kmail laptop mp3 pdf playlist test +tiff +vorbis wv2 xine +xml xmp"
+
+# Automagic, gconf, uuid, enca and probably more
+# TODO: quill and streamanalyzer support
+RDEPEND="
+ >=app-i18n/enca-1.9
+ >=dev-db/sqlite-3.6.16[threadsafe]
+ >=dev-libs/dbus-glib-0.78
+ >=dev-libs/glib-2.16.0
+ >=gnome-base/gconf-2
+ >=media-gfx/imagemagick-5.2.1[png,jpeg=]
+ >=media-libs/libpng-1.2
+ >=x11-libs/pango-1
+ sys-apps/util-linux
+
+ applet? (
+ >=x11-libs/libnotify-0.4.3
+ gnome-base/gnome-panel
+ >=x11-libs/gtk+-2.16 )
+ deskbar? ( >=gnome-extra/deskbar-applet-2.19 )
+ eds? (
+ >=mail-client/evolution-2.25.5
+ >=gnome-extra/evolution-data-server-2.25.5 )
+ exif? ( >=media-libs/libexif-0.6 )
+ iptc? ( media-libs/libiptcdata )
+ jpeg? ( media-libs/jpeg )
+ gsf? ( >=gnome-extra/libgsf-1.13 )
+ gstreamer? ( >=media-libs/gstreamer-0.10.12 )
+ !gstreamer? ( !xine? ( || ( media-video/totem media-video/mplayer ) ) )
+ gtk? ( >=x11-libs/gtk+-2.16.0 )
+ laptop? (
+ hal? ( >=sys-apps/hal-0.5 )
+ !hal? ( >=sys-apps/devicekit-power-007 ) )
+ mp3? ( >=media-libs/id3lib-3.8.3 )
+ pdf? (
+ >=x11-libs/cairo-1
+ >=virtual/poppler-glib-0.5[cairo]
+ >=virtual/poppler-utils-0.5
+ >=x11-libs/gtk+-2.12 )
+ playlist? ( dev-libs/totem-pl-parser )
+ tiff? ( media-libs/tiff )
+ vorbis? ( >=media-libs/libvorbis-0.22 )
+ wv2? ( >=app-text/wv2-0.3.1 )
+ xine? ( >=media-libs/xine-lib-1 )
+ xml? ( >=dev-libs/libxml2-2.6 )
+ xmp? ( >=media-libs/exempi-2.1 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.14
+ >=dev-util/pkgconfig-0.20
+ applet? (
+ dev-lang/vala
+ >=dev-libs/libgee-0.3 )
+ gtk? (
+ dev-lang/vala
+ >=dev-libs/libgee-0.3 )
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+# test? ( gcov )
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+function inotify_enabled() {
+ if linux_chkconfig_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ echo
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ echo
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ inotify_enabled
+
+ if use gstreamer ; then
+ G2CONF="${G2CONF}
+ --enable-video-extractor=gstreamer
+ --enable-gstreamer-tagreadbin"
+ # --enable-gstreamer-helix (real media)
+ elif use xine ; then
+ G2CONF="${G2CONF} --enable-video-extractor=xine"
+ else
+ G2CONF="${G2CONF} --enable-video-extractor=external"
+ fi
+
+ # hal and dk-p are used for AC power detection
+ if use laptop; then
+ G2CONF="${G2CONF} $(use_enable hal) $(use_enable !hal devkit-power)"
+ else
+ G2CONF="${G2CONF} --disable-hal --disable-devkit-power"
+ fi
+
+ G2CONF="${G2CONF}
+ --disable-unac
+ --disable-functional-tests
+ $(use_enable applet tracker-status-icon)
+ $(use_enable applet tracker-search-bar)
+ $(use_enable deskbar deskbar-applet)
+ $(use_enable eds evolution-miner)
+ $(use_enable exif libexif)
+ $(use_enable gsf libgsf)
+ $(use_enable gtk libtrackergtk)
+ $(use_enable gtk tracker-explorer)
+ $(use_enable gtk tracker-preferences)
+ $(use_enable gtk tracker-search-tool)
+ $(use_enable iptc libiptcdata)
+ $(use_enable jpeg libjpeg)
+ $(use_enable kmail kmail-miner)
+ $(use_enable mp3 id3lib)
+ $(use_enable pdf poppler-glib)
+ $(use_enable playlist)
+ $(use_enable test unit-tests)
+ $(use_enable tiff libtiff)
+ $(use_enable vorbis libvorbis)
+ $(use_enable wv2 libwv2)
+ $(use_enable xml libxml2)
+ $(use_enable xmp exempi)"
+ # FIXME: Missing files to run functional tests
+ # $(use_enable test functional-tests)
+ # FIXME: useless without quill (extract mp3 albumart...)
+ # $(use_enable gtk gdkpixbuf)
+}
+
+src_test() {
+ export XDG_CONFIG_HOME="${T}"
+ emake check || die "tests failed"
+}
diff --git a/app-misc/tracker/tracker-9999.ebuild b/app-misc/tracker/tracker-9999.ebuild
index 5ec340886f2a..d24440d63565 100644
--- a/app-misc/tracker/tracker-9999.ebuild
+++ b/app-misc/tracker/tracker-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-9999.ebuild,v 1.5 2009/12/10 23:15:03 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/tracker/tracker-9999.ebuild,v 1.6 2009/12/13 21:27:15 eva Exp $
EAPI="2"
G2CONF_DEBUG="no"
@@ -15,7 +15,8 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="applet deskbar doc eds exif gsf gstreamer gtk hal iptc +jpeg kmail laptop mp3 pdf playlist test +tiff xine +xml xmp +vorbis"
+# USE="doc" is managed by eclass.
+IUSE="applet deskbar doc eds exif gsf gstreamer gtk hal iptc +jpeg kmail laptop mp3 pdf playlist test +tiff +vorbis wv2 xine +xml xmp"
# Automagic, gconf, uuid, enca and probably more
# TODO: quill and streamanalyzer support
@@ -57,6 +58,7 @@ RDEPEND="
playlist? ( dev-libs/totem-pl-parser )
tiff? ( media-libs/tiff )
vorbis? ( >=media-libs/libvorbis-0.22 )
+ wv2? ( >=app-text/wv2-0.3.1 )
xine? ( >=media-libs/xine-lib-1 )
xml? ( >=dev-libs/libxml2-2.6 )
xmp? ( >=media-libs/exempi-2.1 )"
@@ -71,28 +73,30 @@ DEPEND="${RDEPEND}
dev-lang/vala
>=dev-libs/libgee-0.3 )
dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1.8 )"
+ >=dev-util/gtk-doc-1.8"
# test? ( gcov )
DOCS="AUTHORS ChangeLog NEWS README"
-function notify_inotify() {
- ewarn
- ewarn "You should enable the INOTIFY support in your kernel."
- ewarn "Check the 'Inotify support for userland' under the 'File systems'"
- ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
- ewarn
- die 'missing CONFIG_INOTIFY'
-}
-
function inotify_enabled() {
- linux_chkconfig_present INOTIFY_USER
+ if linux_chkconfig_exists; then
+ if ! linux_chkconfig_present INOTIFY_USER; then
+ echo
+ ewarn "You should enable the INOTIFY support in your kernel."
+ ewarn "Check the 'Inotify support for userland' under the 'File systems'"
+ ewarn "option. It is marked as CONFIG_INOTIFY_USER in the config"
+ echo
+ die 'missing CONFIG_INOTIFY'
+ fi
+ else
+ einfo "Could not check for INOTIFY support in your kernel."
+ fi
}
pkg_setup() {
linux-info_pkg_setup
- inotify_enabled || notify_inotify
+ inotify_enabled
if use gstreamer ; then
G2CONF="${G2CONF}
@@ -133,9 +137,10 @@ pkg_setup() {
$(use_enable playlist)
$(use_enable test unit-tests)
$(use_enable tiff libtiff)
+ $(use_enable vorbis libvorbis)
+ $(use_enable wv2 libwv2)
$(use_enable xml libxml2)
- $(use_enable xmp exempi)
- $(use_enable vorbis libvorbis)"
+ $(use_enable xmp exempi)"
# FIXME: Missing files to run functional tests
# $(use_enable test functional-tests)
# FIXME: useless without quill (extract mp3 albumart...)