summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-07 09:06:55 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-07 09:06:55 +0000
commitb10c275ae72ec956856ecbffa7ef1824ec2f6464 (patch)
tree8b927f220c6d1f39cf916f5dd538b9d7932a5047
parentFix building (linking) with USE="-X". (diff)
downloadgentoo-2-b10c275ae72ec956856ecbffa7ef1824ec2f6464.tar.gz
gentoo-2-b10c275ae72ec956856ecbffa7ef1824ec2f6464.tar.bz2
gentoo-2-b10c275ae72ec956856ecbffa7ef1824ec2f6464.zip
Respect LDFLAGS. Bug #339871
(Portage version: 2.1.8.3/cvs/Linux x86_64)
-rw-r--r--games-strategy/xconq/ChangeLog5
-rw-r--r--games-strategy/xconq/xconq-7.4.1.ebuild21
2 files changed, 15 insertions, 11 deletions
diff --git a/games-strategy/xconq/ChangeLog b/games-strategy/xconq/ChangeLog
index 44076dff0fbe..a0aff60cb988 100644
--- a/games-strategy/xconq/ChangeLog
+++ b/games-strategy/xconq/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/xconq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.15 2010/09/25 12:12:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.16 2010/10/07 09:06:55 tupone Exp $
+
+ 07 Oct 2010; Alfredo Tupone <tupone@gentoo.org> xconq-7.4.1.ebuild:
+ Respect LDFLAGS. Bug #339871 by flameeyes@gentoo.org
25 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> xconq-7.4.1.ebuild,
+files/xconq-make-382.patch:
diff --git a/games-strategy/xconq/xconq-7.4.1.ebuild b/games-strategy/xconq/xconq-7.4.1.ebuild
index 3dfd1b23925f..12aa4ddb711a 100644
--- a/games-strategy/xconq/xconq-7.4.1.ebuild
+++ b/games-strategy/xconq/xconq-7.4.1.ebuild
@@ -1,6 +1,7 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.14 2010/09/25 12:12:28 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.15 2010/10/07 09:06:55 tupone Exp $
+EAPI="2"
inherit eutils games
@@ -19,21 +20,21 @@ DEPEND="x11-libs/libXmu
dev-lang/tk
dev-lang/tcl"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch \
- "${FILESDIR}"/${PN}-gcc-3.4.patch \
- "${FILESDIR}"/${PN}-tkconq.patch \
- "${FILESDIR}"/${PN}-make-382.patch
-}
+PATCHES=( "${FILESDIR}"/${PN}-gcc-3.4.patch
+ "${FILESDIR}"/${PN}-tkconq.patch
+ "${FILESDIR}"/${PN}-make-382.patch
+ )
-src_compile() {
+src_configure() {
egamesconf \
--enable-alternate-scoresdir="${GAMES_STATEDIR}"/${PN} \
|| die
+}
+
+src_compile() {
emake \
CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
datadir="${GAMES_DATADIR}"/${PN} \
|| die "emake failed"
}