summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-07-06 20:32:31 +0000
committerMike Gilbert <floppym@gentoo.org>2013-07-06 20:32:31 +0000
commitb141e1787a2c1ddf29e2b6d7ae3cc8ec93c8e55d (patch)
treecb82a791d0892c44a500ce6f3f9ed9436ae3b93e
parentAdded systemd unit file (by Pacho Ramos <pacho@gentoo.org>) (diff)
downloadgentoo-2-b141e1787a2c1ddf29e2b6d7ae3cc8ec93c8e55d.tar.gz
gentoo-2-b141e1787a2c1ddf29e2b6d7ae3cc8ec93c8e55d.tar.bz2
gentoo-2-b141e1787a2c1ddf29e2b6d7ae3cc8ec93c8e55d.zip
Version bump.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
-rw-r--r--dev-python/beautifulsoup/ChangeLog7
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-4.2.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/beautifulsoup/ChangeLog b/dev-python/beautifulsoup/ChangeLog
index cff390a869e9..6e9090eed018 100644
--- a/dev-python/beautifulsoup/ChangeLog
+++ b/dev-python/beautifulsoup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/beautifulsoup
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.94 2013/05/22 22:05:14 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/ChangeLog,v 1.95 2013/07/06 20:32:31 floppym Exp $
+
+*beautifulsoup-4.2.1 (06 Jul 2013)
+
+ 06 Jul 2013; Mike Gilbert <floppym@gentoo.org> +beautifulsoup-4.2.1.ebuild:
+ Version bump.
22 May 2013; Mike Gilbert <floppym@gentoo.org>
beautifulsoup-3.1.0.1-r2.ebuild:
diff --git a/dev-python/beautifulsoup/beautifulsoup-4.2.1.ebuild b/dev-python/beautifulsoup/beautifulsoup-4.2.1.ebuild
new file mode 100644
index 000000000000..20a3e046fab3
--- /dev/null
+++ b/dev-python/beautifulsoup/beautifulsoup-4.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-4.2.1.ebuild,v 1.1 2013/07/06 20:32:31 floppym Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Provides pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/
+ http://pypi.python.org/pypi/beautifulsoup4"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+# new html5 awaits keywording of html5lib in Bug 471002
+IUSE="doc test"
+# pending Bug 471002; html5? ( dev-python/html5lib[$(python_gen_usedep 'python{2_6,2_7}' pypy2_0)] )
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/lxml[$(python_gen_usedep 'python{2_6,2_7}' 'python3*')] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ fi
+}
+
+python_test() {
+ nosetests -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=doc/build/html/.
+ distutils-r1_python_install_all
+}