summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-25 13:02:08 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-25 13:02:08 +0000
commitb4fac7ae0232b661ba114d293e5415324b245c99 (patch)
treed8277963119a3484bedbd5b9e5a11e71ffe621ba
parentVersion bump to 3.3.6, wrt bug #488944 (diff)
downloadgentoo-2-b4fac7ae0232b661ba114d293e5415324b245c99.tar.gz
gentoo-2-b4fac7ae0232b661ba114d293e5415324b245c99.tar.bz2
gentoo-2-b4fac7ae0232b661ba114d293e5415324b245c99.zip
Fixed write error when using top with pipes (#485952)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
-rw-r--r--sys-process/procps/ChangeLog8
-rw-r--r--sys-process/procps/procps-3.3.8-r1.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 876834e4e0b8..bd3f22c0242c 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.97 2013/08/03 07:33:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.98 2013/10/25 13:02:08 polynomial-c Exp $
+
+*procps-3.3.8-r1 (25 Oct 2013)
+
+ 25 Oct 2013; Lars Wendler <polynomial-c@gentoo.org> +procps-3.3.8-r1.ebuild:
+ Fixed write error when using top with pipes. Thanks to Florian Knodt for
+ reporting this in bug #485952.
03 Aug 2013; Agostino Sarubbo <ago@gentoo.org> procps-3.3.6.ebuild:
Stable for sparc, wrt bug #468266
diff --git a/sys-process/procps/procps-3.3.8-r1.ebuild b/sys-process/procps/procps-3.3.8-r1.ebuild
new file mode 100644
index 000000000000..3aa1f1602477
--- /dev/null
+++ b/sys-process/procps/procps-3.3.8-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.8-r1.ebuild,v 1.1 2013/10/25 13:02:08 polynomial-c Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="standard informational utilities and process-handling tools"
+# http://packages.debian.org/sid/procps
+HOMEPAGE="http://procps.sourceforge.net/ http://gitorious.org/procps"
+# SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.xz"
+FEDORA_HASH="aecbeeda2ab308f8d09dddcb4cb9a572"
+SRC_URI="http://pkgs.fedoraproject.org/repo/pkgs/${PN}-ng/${PN}-ng-${PV}.tar.xz/${FEDORA_HASH}/${PN}-ng-${PV}.tar.xz
+ https://gitorious.org/${PN}/${PN}/commit/ce5e995921e770bfcda25e42fe090aeccdbf1291.patch -> ${P}-respect_epipe_in_fileutils.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="+ncurses nls static-libs unicode"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.7-r7[unicode?] )"
+DEPEND="${RDEPEND}
+ ncurses? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/${PN}-ng-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-kill-neg-pid.patch \
+ "${DISTDIR}"/${P}-respect_epipe_in_fileutils.patch
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}" \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_with ncurses) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode watch8bit)
+}
+
+src_install() {
+ default
+# dodoc sysctl.conf
+
+ # The configure script is completely whacked in the head
+ mv "${ED}"/lib* "${ED}"/usr/ || die
+ gen_usr_ldscript -a procps
+ prune_libtool_files
+}