summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2007-09-11 16:38:07 +0000
committerJeroen Roovers <jer@gentoo.org>2007-09-11 16:38:07 +0000
commitb5ca0aa4f69ba7bfc96cc0d67b641341c418035f (patch)
tree6dbc5d6d0561039fdced8d4e96597b9163ccb390
parentLinux 2.6.23-rc6. (diff)
downloadgentoo-2-b5ca0aa4f69ba7bfc96cc0d67b641341c418035f.tar.gz
gentoo-2-b5ca0aa4f69ba7bfc96cc0d67b641341c418035f.tar.bz2
gentoo-2-b5ca0aa4f69ba7bfc96cc0d67b641341c418035f.zip
Turn sed script into patch (bug #180807).
(Portage version: 2.1.2.12)
-rw-r--r--dev-perl/PDL/ChangeLog6
-rw-r--r--dev-perl/PDL/PDL-2.4.3-r1.ebuild7
-rw-r--r--dev-perl/PDL/files/PDL-2.4.3-PIC.patch11
3 files changed, 19 insertions, 5 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index dbd07d35d0ea..40e738b9bab1 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/PDL
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.74 2007/09/11 03:09:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.75 2007/09/11 16:38:06 jer Exp $
+
+ 11 Sep 2007; Jeroen Roovers <jer@gentoo.org> +files/PDL-2.4.3-PIC.patch,
+ PDL-2.4.3-r1.ebuild:
+ Turn sed script into patch (bug #180807).
11 Sep 2007; Jeroen Roovers <jer@gentoo.org> PDL-2.4.3-r1.ebuild:
Fix bug #180807. Stable for HPPA too.
diff --git a/dev-perl/PDL/PDL-2.4.3-r1.ebuild b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
index 533a87f0a38b..607747e9fad6 100644
--- a/dev-perl/PDL/PDL-2.4.3-r1.ebuild
+++ b/dev-perl/PDL/PDL-2.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.3-r1.ebuild,v 1.11 2007/09/11 03:09:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.4.3-r1.ebuild,v 1.12 2007/09/11 16:38:06 jer Exp $
inherit perl-module eutils multilib
@@ -44,9 +44,8 @@ src_unpack() {
${S}/perldl.conf
fi
- # Unconditional -fPIC for the lib (#55238)
- sed -i -e "s/mycompiler -c /mycompiler -fPIC -c /" \
- ${S}/Lib/Slatec/Makefile.PL || die "sed failed"
+ # Unconditional -fPIC for the lib (#55238, #180807)
+ epatch "${FILESDIR}/${P}-PIC.patch"
}
src_install() {
diff --git a/dev-perl/PDL/files/PDL-2.4.3-PIC.patch b/dev-perl/PDL/files/PDL-2.4.3-PIC.patch
new file mode 100644
index 000000000000..ee6db253e4c2
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.3-PIC.patch
@@ -0,0 +1,11 @@
+--- Lib/Slatec/Makefile.PL 2007-09-11 18:30:14.000000000 +0200
++++ Lib/Slatec/Makefile.PL 2007-09-11 18:28:55.000000000 +0200
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ $mycompiler -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }