summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-02-19 05:18:26 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-02-19 05:18:26 +0000
commitbccfc173a139905c6cc4f0ed20be4e679a5b3f68 (patch)
treeb8d1022a85c745c572477673931581a07024a26d
parentAdd support for java-pkg-2_pkg_preinst. (diff)
downloadgentoo-2-bccfc173a139905c6cc4f0ed20be4e679a5b3f68.tar.gz
gentoo-2-bccfc173a139905c6cc4f0ed20be4e679a5b3f68.tar.bz2
gentoo-2-bccfc173a139905c6cc4f0ed20be4e679a5b3f68.zip
Add support for java-pkg-opt-2_pkg_preinst.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
-rw-r--r--dev-libs/dbxml/ChangeLog7
-rw-r--r--dev-libs/dbxml/dbxml-2.4.13.2.ebuild9
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-libs/dbxml/ChangeLog b/dev-libs/dbxml/ChangeLog
index fe14d58435a4..7a1035b3b0a9 100644
--- a/dev-libs/dbxml/ChangeLog
+++ b/dev-libs/dbxml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/dbxml
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/ChangeLog,v 1.2 2008/07/14 11:40:39 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/ChangeLog,v 1.3 2009/02/19 05:18:26 serkan Exp $
+
+ 19 Feb 2009; Serkan Kaba <serkan@gentoo.org> dbxml-2.4.13.2.ebuild:
+ Add support for java-pkg-opt-2_pkg_preinst.
14 Jul 2008; Diego Pettenò <flameeyes@gentoo.org> dbxml-2.4.13.2.ebuild:
Fix the name of the package, it's sys-libs/db not dev-libs/db, the error
diff --git a/dev-libs/dbxml/dbxml-2.4.13.2.ebuild b/dev-libs/dbxml/dbxml-2.4.13.2.ebuild
index 5778fdadbd32..9dc8d0cee24b 100644
--- a/dev-libs/dbxml/dbxml-2.4.13.2.ebuild
+++ b/dev-libs/dbxml/dbxml-2.4.13.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/dbxml-2.4.13.2.ebuild,v 1.2 2008/07/14 11:40:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dbxml/dbxml-2.4.13.2.ebuild,v 1.3 2009/02/19 05:18:26 serkan Exp $
EAPI="1"
@@ -173,6 +173,11 @@ src_install() {
}
+pkg_preinst() {
+ perl-module_pkg_preinst
+ java-pkg-2_pkg_preinst
+}
+
pkg_postinst() {
if use python ; then
python_version