summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-07 09:46:16 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-07 09:46:16 +0000
commitc36117d4db4f3d757a13a8f32bf97159ba16cff5 (patch)
treeb6c777d5b516a93c0e52d0732c8ef1f200fe76a0
parentarm/hppa/ia64/sh stable (diff)
downloadgentoo-2-c36117d4db4f3d757a13a8f32bf97159ba16cff5.tar.gz
gentoo-2-c36117d4db4f3d757a13a8f32bf97159ba16cff5.tar.bz2
gentoo-2-c36117d4db4f3d757a13a8f32bf97159ba16cff5.zip
Version bump #132531 by Håvard Wall.
(Portage version: 2.1_pre10-r3)
-rw-r--r--dev-libs/DirectFB/ChangeLog7
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.25.1.ebuild122
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.25.13
3 files changed, 131 insertions, 1 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index acf3cf55338c..18ea1e1b198f 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.51 2006/04/16 04:52:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.52 2006/05/07 09:46:16 vapier Exp $
+
+*DirectFB-0.9.25.1 (07 May 2006)
+
+ 07 May 2006; Mike Frysinger <vapier@gentoo.org> +DirectFB-0.9.25.1.ebuild:
+ Version bump #132531 by Håvard Wall.
16 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+files/DirectFB-0.9.24-CFLAGS.patch, DirectFB-0.9.24.ebuild:
diff --git a/dev-libs/DirectFB/DirectFB-0.9.25.1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.25.1.ebuild
new file mode 100644
index 000000000000..48d68e519d49
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.25.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.25.1.ebuild,v 1.1 2006/05/07 09:46:16 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
+IUSE_INPUT_DRIVERS="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch permount ps2mouse serialmouse sonypijofdial wm97xx"
+
+DESCRIPTION="Thin library on top of the Linux framebuffer devices"
+HOMEPAGE="http://www.directfb.org/"
+SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~sh -sparc ~x86"
+IUSE="debug fbcon fusion gif jpeg mmx mpeg png sdl sse static sysfs truetype v4l v4l2 zlib"
+
+DEPEND="sdl? ( media-libs/libsdl )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ mpeg? ( media-libs/libmpeg3 )
+ sysfs? ( sys-fs/sysfsutils )
+ zlib? ( sys-libs/zlib )
+ truetype? ( >=media-libs/freetype-2.0.1 )"
+
+pkg_setup() {
+ if [[ -z ${VIDEO_CARDS} ]] ; then
+ ewarn "All video drivers will be built since you did not specify"
+ ewarn "via the VIDEO_CARDS variable what video card you use."
+ einfo "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
+ echo
+ fi
+ if [[ -z ${INPUT_DRIVERS} ]] ; then
+ ewarn "All input drivers will be built since you did not specify"
+ ewarn "via the INPUT_DRIVERS variable which input drivers to use."
+ einfo "DirectFB supports: ${IUSE_INPUT_DRIVERS} all none"
+ echo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
+}
+
+src_compile() {
+ # force disable wm97xx #36924
+# export ac_cv_header_linux_wm97xx_h=no
+ # force disable of sis315 #77391
+# export ac_cv_header_linux_sisfb_h=no
+
+ local vidcards card input inputdrivers
+ for card in ${VIDEO_CARDS} ; do
+ has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
+ done
+ [[ -z ${vidcards} ]] \
+ && vidcards="all" \
+ || vidcards=${vidcards:1}
+ for input in ${INPUT_DRIVERS} ; do
+ has ${input} ${IUSE_INPUT_DRIVERS} && inputdrivers="${inputdrivers},${input}"
+ done
+ [[ -z ${inputdrivers} ]] \
+ && inputdrivers="all" \
+ || inputdrivers=${inputdrivers:1}
+
+ local sdlconf="--disable-sdl"
+ if use sdl ; then
+ # since SDL can link against DirectFB and trigger a
+ # dependency loop, only link against SDL if it isn't
+ # broken #61592
+ echo 'int main(){}' > sdl-test.c
+ $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
+ && sdlconf="--enable-sdl" \
+ || ewarn "Disabling SDL since libSDL.so is broken"
+ fi
+
+ use mpeg && export CPPFLAGS="${CPPFLAGS} -I/usr/include/libmpeg3"
+ econf \
+ $(use_enable fbcon fbdev) \
+ $(use_enable mmx) \
+ $(use_enable sse) \
+ $(use_enable mpeg libmpeg3) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable gif) \
+ $(use_enable truetype freetype) \
+ $(use_enable fusion multi) \
+ $(use_enable debug) \
+ $(use_enable static) \
+ $(use_enable sysfs) \
+ $(use_enable zlib) \
+ $(use_enable v4l video4linux) \
+ $(use_enable v4l2 video4linux2) \
+ ${sdlconf} \
+ --with-gfxdrivers="${vidcards}" \
+ --with-inputdrivers="${inputdrivers}" \
+ --disable-vnc \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
+ dohtml -r docs/html/*
+}
+
+pkg_postinst() {
+ ewarn "Each DirectFB update in the 0.9.xx series"
+ ewarn "breaks DirectFB related applications."
+ ewarn "Please run \"revdep-rebuild\" which can be"
+ ewarn "found by emerging the package 'gentoolkit'."
+ ewarn
+ ewarn "If you have an ALPS touchpad, then you might"
+ ewarn "get your mouse unexpectedly set in absolute"
+ ewarn "mode in all DirectFB applications."
+ ewarn "This can be fixed by removing linuxinput from"
+ ewarn "INPUT_DRIVERS."
+}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.25.1 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.25.1
new file mode 100644
index 000000000000..2c9170a6d041
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.25.1
@@ -0,0 +1,3 @@
+MD5 b6d4ecf9cd3787bd2728af9110ed53cf DirectFB-0.9.25.1.tar.gz 2064010
+RMD160 558e3eabc41635c054314d8a4c8365d648ec588d DirectFB-0.9.25.1.tar.gz 2064010
+SHA256 aa1e9710ca18633ffcb74a0383fdfa39aba63e873ec9fa2ba4b7589ed2e5c56b DirectFB-0.9.25.1.tar.gz 2064010