summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-16 02:24:49 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-16 02:24:49 +0000
commitd53f901335445ef595fcd0863d1eeed74883926d (patch)
tree5ce0641ac64452531ed209b3ee1797619df5d895
parentMarking xdelta-1.1.3-r3 ppc and ppc64 for bug 206009 (diff)
downloadgentoo-2-d53f901335445ef595fcd0863d1eeed74883926d.tar.gz
gentoo-2-d53f901335445ef595fcd0863d1eeed74883926d.tar.bz2
gentoo-2-d53f901335445ef595fcd0863d1eeed74883926d.zip
Fix building with newer versions of speex #205893 by Chi-Thanh Christopher Nguyen.
(Portage version: 2.1.4)
-rw-r--r--net-voip/linphone/ChangeLog7
-rw-r--r--net-voip/linphone/files/linphone-2.0.1-speexdsp.patch122
-rw-r--r--net-voip/linphone/linphone-2.0.1-r1.ebuild3
3 files changed, 130 insertions, 2 deletions
diff --git a/net-voip/linphone/ChangeLog b/net-voip/linphone/ChangeLog
index 86d774555efa..a1ab4eedfd88 100644
--- a/net-voip/linphone/ChangeLog
+++ b/net-voip/linphone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-voip/linphone
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.6 2008/01/14 14:03:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/ChangeLog,v 1.7 2008/01/16 02:24:48 vapier Exp $
+
+ 16 Jan 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/linphone-2.0.1-speexdsp.patch, linphone-2.0.1-r1.ebuild:
+ Fix building with newer versions of speex #205893 by Chi-Thanh Christopher
+ Nguyen.
*linphone-2.0.1-r1 (14 Jan 2008)
diff --git a/net-voip/linphone/files/linphone-2.0.1-speexdsp.patch b/net-voip/linphone/files/linphone-2.0.1-speexdsp.patch
new file mode 100644
index 000000000000..c0bd4156c1fa
--- /dev/null
+++ b/net-voip/linphone/files/linphone-2.0.1-speexdsp.patch
@@ -0,0 +1,122 @@
+http://bugs.gentoo.org/205893
+
+--- linphone-2.0.1/mediastreamer2/configure
++++ linphone-2.0.1/mediastreamer2/configure
+@@ -21907,6 +21915,117 @@
+ build_speex=yes
+ fi
+
++pkg_failed=no
++{ echo "$as_me:$LINENO: checking for SPEEXDSP" >&5
++echo $ECHO_N "checking for SPEEXDSP... $ECHO_C" >&6; }
++
++if test -n "$PKG_CONFIG"; then
++ if test -n "$SPEEXDSP_CFLAGS"; then
++ pkg_cv_SPEEXDSP_CFLAGS="$SPEEXDSP_CFLAGS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"speexdsp >= 1.2beta3\"") >&5
++ ($PKG_CONFIG --exists --print-errors "speexdsp >= 1.2beta3") 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; then
++ pkg_cv_SPEEXDSP_CFLAGS=`$PKG_CONFIG --cflags "speexdsp >= 1.2beta3" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++if test -n "$PKG_CONFIG"; then
++ if test -n "$SPEEXDSP_LIBS"; then
++ pkg_cv_SPEEXDSP_LIBS="$SPEEXDSP_LIBS"
++ else
++ if test -n "$PKG_CONFIG" && \
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"speexdsp >= 1.2beta3\"") >&5
++ ($PKG_CONFIG --exists --print-errors "speexdsp >= 1.2beta3") 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; then
++ pkg_cv_SPEEXDSP_LIBS=`$PKG_CONFIG --libs "speexdsp >= 1.2beta3" 2>/dev/null`
++else
++ pkg_failed=yes
++fi
++ fi
++else
++ pkg_failed=untried
++fi
++
++
++
++if test $pkg_failed = yes; then
++
++if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
++ _pkg_short_errors_supported=yes
++else
++ _pkg_short_errors_supported=no
++fi
++ if test $_pkg_short_errors_supported = yes; then
++ SPEEXDSP_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "speexdsp >= 1.2beta3"`
++ else
++ SPEEXDSP_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "speexdsp >= 1.2beta3"`
++ fi
++ # Put the nasty error message in config.log where it belongs
++ echo "$SPEEXDSP_PKG_ERRORS" >&5
++
++ { { echo "$as_me:$LINENO: error: Package requirements (speexdsp >= 1.2beta3) were not met:
++
++$SPEEXDSP_PKG_ERRORS
++
++Consider adjusting the PKG_CONFIG_PATH environment variable if you
++installed software in a non-standard prefix.
++
++Alternatively, you may set the environment variables SPEEXDSP_CFLAGS
++and SPEEXDSP_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++" >&5
++echo "$as_me: error: Package requirements (speexdsp >= 1.2beta3) were not met:
++
++$SPEEXDSP_PKG_ERRORS
++
++Consider adjusting the PKG_CONFIG_PATH environment variable if you
++installed software in a non-standard prefix.
++
++Alternatively, you may set the environment variables SPEEXDSP_CFLAGS
++and SPEEXDSP_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++" >&2;}
++ { (exit 1); exit 1; }; }
++elif test $pkg_failed = untried; then
++ { { echo "$as_me:$LINENO: error: The pkg-config script could not be found or is too old. Make sure it
++is in your PATH or set the PKG_CONFIG environment variable to the full
++path to pkg-config.
++
++Alternatively, you may set the environment variables SPEEXDSP_CFLAGS
++and SPEEXDSP_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.
++See \`config.log' for more details." >&5
++echo "$as_me: error: The pkg-config script could not be found or is too old. Make sure it
++is in your PATH or set the PKG_CONFIG environment variable to the full
++path to pkg-config.
++
++Alternatively, you may set the environment variables SPEEXDSP_CFLAGS
++and SPEEXDSP_LIBS to avoid the need to call pkg-config.
++See the pkg-config man page for more details.
++
++To get pkg-config, see <http://pkg-config.freedesktop.org/>.
++See \`config.log' for more details." >&2;}
++ { (exit 1); exit 1; }; }
++else
++ SPEEXDSP_CFLAGS=$pkg_cv_SPEEXDSP_CFLAGS
++ SPEEXDSP_LIBS=$pkg_cv_SPEEXDSP_LIBS
++ { echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6; }
++ SPEEX_LIBS="$SPEEX_LIBS $SPEEXDSP_LIBS"
++fi
++
+
+
+
diff --git a/net-voip/linphone/linphone-2.0.1-r1.ebuild b/net-voip/linphone/linphone-2.0.1-r1.ebuild
index 04d80b4a470b..ee2c57199e81 100644
--- a/net-voip/linphone/linphone-2.0.1-r1.ebuild
+++ b/net-voip/linphone/linphone-2.0.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-2.0.1-r1.ebuild,v 1.1 2008/01/14 14:03:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/linphone/linphone-2.0.1-r1.ebuild,v 1.2 2008/01/16 02:24:48 vapier Exp $
# Note: video support in linphone relies on swscaler being disabled
# in ffmpeg. this is because the video code in linphone is old
@@ -51,6 +51,7 @@ src_unpack() {
epatch "${FILESDIR}"/linphone-1.6.0-call.patch
epatch "${FILESDIR}"/linphone-1.99.0-core-amd64.patch
epatch "${FILESDIR}"/linphone-2.0.1-configure-gsm.patch
+ epatch "${FILESDIR}"/linphone-2.0.1-speexdsp.patch #205893
epatch "${FILESDIR}"/linphone-2.0.1-mediastreamer-deps.patch
}