summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-24 14:02:57 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-24 14:02:57 +0000
commitdd318e7cd51a696bde33b1e91dc2fd39cf235336 (patch)
tree34e0972bcc74a36d475f164f1c77daa4f31b35ce
parentStable for HPPA (bug #476364). (diff)
downloadgentoo-2-dd318e7cd51a696bde33b1e91dc2fd39cf235336.tar.gz
gentoo-2-dd318e7cd51a696bde33b1e91dc2fd39cf235336.tar.bz2
gentoo-2-dd318e7cd51a696bde33b1e91dc2fd39cf235336.zip
net-fs/autofs: Backport fix for ldap without sasl, #489128
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
-rw-r--r--net-fs/autofs/ChangeLog8
-rw-r--r--net-fs/autofs/autofs-5.0.8-r1.ebuild (renamed from net-fs/autofs/autofs-5.0.8.ebuild)3
-rw-r--r--net-fs/autofs/files/autofs-5.0.8-ldap-wo-sasl.patch27
3 files changed, 36 insertions, 2 deletions
diff --git a/net-fs/autofs/ChangeLog b/net-fs/autofs/ChangeLog
index ae3582befce3..f66d81db1941 100644
--- a/net-fs/autofs/ChangeLog
+++ b/net-fs/autofs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-fs/autofs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.169 2013/10/23 04:02:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/ChangeLog,v 1.170 2013/10/24 14:02:56 jlec Exp $
+
+*autofs-5.0.8-r1 (24 Oct 2013)
+
+ 24 Oct 2013; Justin Lecher <jlec@gentoo.org> -autofs-5.0.8.ebuild,
+ +autofs-5.0.8-r1.ebuild, +files/autofs-5.0.8-ldap-wo-sasl.patch:
+ Backport fix for ldap without sasl, #489128
23 Oct 2013; Patrick Lauer <patrick@gentoo.org> autofs-5.0.8.ebuild:
Whitespace
diff --git a/net-fs/autofs/autofs-5.0.8.ebuild b/net-fs/autofs/autofs-5.0.8-r1.ebuild
index 3bdb0d63b849..901969882517 100644
--- a/net-fs/autofs/autofs-5.0.8.ebuild
+++ b/net-fs/autofs/autofs-5.0.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.8.ebuild,v 1.2 2013/10/23 04:02:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/autofs-5.0.8-r1.ebuild,v 1.1 2013/10/24 14:02:56 jlec Exp $
EAPI=5
@@ -53,6 +53,7 @@ src_prepare() {
EPATCH_SUFFIX="patch" \
epatch "${WORKDIR}"/patches
fi
+ epatch "${FILESDIR}"/${P}-ldap-wo-sasl.patch
sed -i -e "s:/usr/bin/kill:/bin/kill:" samples/autofs.service.in || die #bug #479492
autotools-utils_src_prepare
}
diff --git a/net-fs/autofs/files/autofs-5.0.8-ldap-wo-sasl.patch b/net-fs/autofs/files/autofs-5.0.8-ldap-wo-sasl.patch
new file mode 100644
index 000000000000..a64ed7e8157f
--- /dev/null
+++ b/net-fs/autofs/files/autofs-5.0.8-ldap-wo-sasl.patch
@@ -0,0 +1,27 @@
+diff --git a/modules/lookup_ldap.c b/modules/lookup_ldap.c
+index 2ab1e8c..04b1da7 100644
+--- a/modules/lookup_ldap.c
++++ b/modules/lookup_ldap.c
+@@ -846,20 +846,20 @@ int get_property(unsigned logopt, xmlNodePtr node, const char *prop, char **valu
+ return 0;
+ }
+
+-#ifdef WITH_SASL
+ /*
+ * For plain text, login and digest-md5 authentication types, we need
+ * user and password credentials.
+ */
+ int authtype_requires_creds(const char *authtype)
+ {
++#ifdef WITH_SASL
+ if (!strncmp(authtype, "PLAIN", strlen("PLAIN")) ||
+ !strncmp(authtype, "DIGEST-MD5", strlen("DIGEST-MD5")) ||
+ !strncmp(authtype, "LOGIN", strlen("LOGIN")))
+ return 1;
++#endif
+ return 0;
+ }
+-#endif
+
+ /*
+ * Returns: