summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-03-30 13:16:29 +0000
committerHans de Graaff <graaff@gentoo.org>2013-03-30 13:16:29 +0000
commite4851f0fadbd0e64168a5798a5d7f82cbafe17ee (patch)
tree189087ddfc8b2f0be796a20efa04c13c776bc77c
parentVersion bump for security bug 462452. (diff)
downloadgentoo-2-e4851f0fadbd0e64168a5798a5d7f82cbafe17ee.tar.gz
gentoo-2-e4851f0fadbd0e64168a5798a5d7f82cbafe17ee.tar.bz2
gentoo-2-e4851f0fadbd0e64168a5798a5d7f82cbafe17ee.zip
Version bump for security bug 462452.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.1.12.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index 115afe240f00..27c06d429628 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.55 2013/03/27 13:40:59 moult Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.56 2013/03/30 13:16:29 graaff Exp $
+
+*activemodel-3.1.12 (30 Mar 2013)
+
+ 30 Mar 2013; Hans de Graaff <graaff@gentoo.org> +activemodel-3.1.12.ebuild:
+ Version bump for security bug 462452.
27 Mar 2013; Dion Moult <moult@gentoo.org> -activemodel-3.0.20.ebuild:
Remove dev-ruby/activemodel:3.0 due to lack of upstream support
diff --git a/dev-ruby/activemodel/activemodel-3.1.12.ebuild b/dev-ruby/activemodel/activemodel-3.1.12.ebuild
new file mode 100644
index 000000000000..a7de4b618e1e
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.1.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.1.12.ebuild,v 1.1 2013/03/30 13:16:29 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="3.1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-3.0.0
+ >=dev-ruby/i18n-0.6.0:0.6
+ >=dev-ruby/bcrypt-ruby-3.0.0"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}