summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-01 08:04:07 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-01 08:04:07 +0000
commite68324744183d497b21b498d18c3e2753bce97fa (patch)
tree0f689a67063e69f2082cbabf3c7e3083452d8e44
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-e68324744183d497b21b498d18c3e2753bce97fa.tar.gz
gentoo-2-e68324744183d497b21b498d18c3e2753bce97fa.tar.bz2
gentoo-2-e68324744183d497b21b498d18c3e2753bce97fa.zip
Respect LDFLAGS. Bug #337273
(Portage version: 2.1.8.3/cvs/Linux i686)
-rw-r--r--games-util/glbsp/ChangeLog8
-rw-r--r--games-util/glbsp/files/glbsp-2.20-ldflags.patch22
-rw-r--r--games-util/glbsp/glbsp-2.20.ebuild11
3 files changed, 33 insertions, 8 deletions
diff --git a/games-util/glbsp/ChangeLog b/games-util/glbsp/ChangeLog
index 790215392358..fb3755a4aa72 100644
--- a/games-util/glbsp/ChangeLog
+++ b/games-util/glbsp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/glbsp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/ChangeLog,v 1.9 2009/11/26 20:55:44 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/ChangeLog,v 1.10 2010/10/01 08:04:07 tupone Exp $
+
+ 01 Oct 2010; Tupone Alfredo <tupone@gentoo.org> glbsp-2.20.ebuild,
+ +files/glbsp-2.20-ldflags.patch:
+ Respect LDFLAGS. Bug #337273 by flameeyes@gentoo.org
26 Nov 2009; Markus Meier <maekke@gentoo.org> glbsp-2.20.ebuild:
x86 stable, bug #294541
diff --git a/games-util/glbsp/files/glbsp-2.20-ldflags.patch b/games-util/glbsp/files/glbsp-2.20-ldflags.patch
new file mode 100644
index 000000000000..e175cc7b136a
--- /dev/null
+++ b/games-util/glbsp/files/glbsp-2.20-ldflags.patch
@@ -0,0 +1,22 @@
+--- Makefile.old 2010-10-01 09:57:28.000000000 +0200
++++ Makefile 2010-10-01 09:57:52.000000000 +0200
+@@ -36,7 +36,7 @@
+ rm -f $(MAIN)/gb_debug.txt $(SYSDIR)/gb_debug.txt
+
+ $(PROGNAME): $(OBJS)
+- $(CC) $(CFLAGS) $(OBJS) -o $(PROGNAME) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(OBJS) -o $(PROGNAME) $(LIBS)
+
+ bin: all
+ strip --strip-unneeded $(PROGNAME)
+--- GUI_unx.mak.old 2010-10-01 10:00:08.000000000 +0200
++++ GUI_unx.mak 2010-10-01 10:00:40.000000000 +0200
+@@ -61,7 +61,7 @@
+ rm -f $(PROGNAME) $(SYSDIR)/*.o $(SYSDIR)/core
+
+ $(PROGNAME): $(OBJS)
+- $(CXX) $(CFLAGS) $(OBJS) -o $(PROGNAME) $(LDFLAGS) $(LIBS)
++ $(CXX) $(LDFLAGS) $(CFLAGS) $(OBJS) -o $(PROGNAME) $(LDFLAGS) $(LIBS)
+
+ bin: all
+ strip --strip-unneeded $(PROGNAME)
diff --git a/games-util/glbsp/glbsp-2.20.ebuild b/games-util/glbsp/glbsp-2.20.ebuild
index 636c42052f78..42390044bced 100644
--- a/games-util/glbsp/glbsp-2.20.ebuild
+++ b/games-util/glbsp/glbsp-2.20.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/glbsp-2.20.ebuild,v 1.4 2009/11/26 20:55:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/glbsp/glbsp-2.20.ebuild,v 1.5 2010/10/01 08:04:07 tupone Exp $
-EAPI=1
+EAPI="2"
inherit eutils toolchain-funcs versionator
@@ -18,9 +18,7 @@ IUSE="fltk"
DEPEND="fltk? ( x11-libs/fltk:1.1 )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e "/^CC=/s:=.*:=$(tc-getCC):" \
-e "/^CXX=/s:=.*:=$(tc-getCXX):" \
@@ -29,6 +27,7 @@ src_unpack() {
-e "s:-O2:${CFLAGS}:" \
GUI_unx.mak Plugin_unx.mak Makefile \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
}
src_compile() {