summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-07 18:47:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-07 18:47:53 +0000
commiteee23843e809bb1fd51029d70b8d0a701f0c3939 (patch)
tree1f58cbab912a1099a34a2f6db6bed88f4267ccc6
parentStable on sparc wrt #176297 (diff)
downloadgentoo-2-eee23843e809bb1fd51029d70b8d0a701f0c3939.tar.gz
gentoo-2-eee23843e809bb1fd51029d70b8d0a701f0c3939.tar.bz2
gentoo-2-eee23843e809bb1fd51029d70b8d0a701f0c3939.zip
version bump
(Portage version: 2.1.2.11)
-rw-r--r--games-emulation/hatari/ChangeLog7
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.953
-rw-r--r--games-emulation/hatari/hatari-0.95.ebuild53
3 files changed, 62 insertions, 1 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index fe56169c559b..87e29fc3d8b5 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.15 2007/03/12 13:58:33 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.16 2007/08/07 18:47:53 mr_bones_ Exp $
+
+*hatari-0.95 (07 Aug 2007)
+
+ 07 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org> +hatari-0.95.ebuild:
+ version bump
12 Mar 2007; Marius Mauch <genone@gentoo.org> hatari-0.45.ebuild,
hatari-0.80.ebuild, hatari-0.90.ebuild:
diff --git a/games-emulation/hatari/files/digest-hatari-0.95 b/games-emulation/hatari/files/digest-hatari-0.95
new file mode 100644
index 000000000000..0f7f68dbf4f4
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.95
@@ -0,0 +1,3 @@
+MD5 5f1ca3f29e74654bf12e8afd42bb7d0a hatari-0.95.tar.gz 809336
+RMD160 ef60ec0bb934549b629803c526e083166fe23a68 hatari-0.95.tar.gz 809336
+SHA256 9307321f9945117ce59f20f71ad7bdd26f96431b2aa203645967ebaf6c616237 hatari-0.95.tar.gz 809336
diff --git a/games-emulation/hatari/hatari-0.95.ebuild b/games-emulation/hatari/hatari-0.95.ebuild
new file mode 100644
index 000000000000..5fa1f8e7e842
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.95.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.95.ebuild,v 1.1 2007/08/07 18:47:53 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ sys-libs/readline
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ games-emulation/emutos"
+
+src_compile() {
+ egamesconf || die
+ # broken deps in the makefiles - bug #164068
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src/uae-cpu all || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ elog "has been installed in $(games_get_libdir) with a .img extension (there"
+ elog "are several from which to choose)."
+ elog
+ elog "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ elog " http://www.atari.st/"
+ elog
+ elog "The first time you run hatari, you should configure it to find the"
+ elog "TOS you prefer to use. Be sure to save your settings."
+ echo
+}