summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:47:02 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-05-12 12:47:02 +0000
commitf30cad6bb7212819ebd1c6e1a762a08feb8cd3bc (patch)
treebf60bf75b1ba8d9cf40dd02c32d87ea1c3378d7c
parentSparc stable --- Bug #221731 --- appears to be fine. (diff)
downloadgentoo-2-f30cad6bb7212819ebd1c6e1a762a08feb8cd3bc.tar.gz
gentoo-2-f30cad6bb7212819ebd1c6e1a762a08feb8cd3bc.tar.bz2
gentoo-2-f30cad6bb7212819ebd1c6e1a762a08feb8cd3bc.zip
version bump for bug 218708
(Portage version: 2.1.4.4)
-rw-r--r--mail-client/claws-mail-perl/ChangeLog8
-rw-r--r--mail-client/claws-mail-perl/claws-mail-perl-0.9.13.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/mail-client/claws-mail-perl/ChangeLog b/mail-client/claws-mail-perl/ChangeLog
index 2b158c3d00b9..b73451b2293d 100644
--- a/mail-client/claws-mail-perl/ChangeLog
+++ b/mail-client/claws-mail-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/claws-mail-perl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.16 2008/02/13 20:57:53 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/ChangeLog,v 1.17 2008/05/12 12:47:02 opfer Exp $
+
+*claws-mail-perl-0.9.13 (12 May 2008)
+
+ 12 May 2008; Christian Faulhammer <opfer@gentoo.org>
+ +claws-mail-perl-0.9.13.ebuild:
+ version bump for bug 218708
13 Feb 2008; Andrej Kacian <ticho@gentoo.org>
claws-mail-perl-0.9.10.ebuild, claws-mail-perl-0.9.11.ebuild,
diff --git a/mail-client/claws-mail-perl/claws-mail-perl-0.9.13.ebuild b/mail-client/claws-mail-perl/claws-mail-perl-0.9.13.ebuild
new file mode 100644
index 000000000000..a9306eeb736e
--- /dev/null
+++ b/mail-client/claws-mail-perl/claws-mail-perl-0.9.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-perl/claws-mail-perl-0.9.13.ebuild,v 1.1 2008/05/12 12:47:02 opfer Exp $
+
+MY_P="${PN#claws-mail-}_plugin-${PV}"
+
+DESCRIPTION="Plugin to use perl to write filtering rules"
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.4.0
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die
+ emake || die
+
+ pod2man --section=1 --release=${PV} --name=cm_perl cm_perl.pod > cm_perl.1
+
+ cd tools
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doman cm_perl.1
+
+ cd tools
+ exeinto /usr/lib/claws-mail/tools
+ doexe *.pl
+
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ echo
+ elog "The documentation for this plugin is contained in a manpage."
+ elog "You can access it with 'man cm_perl'"
+ echo
+}