summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-01 06:27:13 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-01 06:27:13 +0000
commitf58856538ab85b00d725b3569ed60bdd4ed556a5 (patch)
tree72ceb0d9eb33d511dc26ec9b7ba4a31d3b1fdd76
parentAdded dependencies (diff)
downloadgentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.tar.gz
gentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.tar.bz2
gentoo-2-f58856538ab85b00d725b3569ed60bdd4ed556a5.zip
Added dependencies
-rw-r--r--dev-java/fesi/fesi-1.ebuild4
-rw-r--r--dev-java/jndi/jndi-1.2.1-r1.ebuild6
-rw-r--r--dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild4
-rw-r--r--dev-java/xt/xt-1.ebuild6
-rw-r--r--dev-libs/swig/swig-1.3_alpha4.ebuild10
-rw-r--r--dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild5
-rw-r--r--dev-perl/PDL/PDL-2.1.1.ebuild8
-rw-r--r--dev-perl/URI/URI-1.09.ebuild4
-rw-r--r--dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild5
-rw-r--r--dev-perl/XML-DOM/XML-DOM-1.25.ebuild4
-rw-r--r--dev-perl/XML-DT/XML-DT-0.14.ebuild5
-rw-r--r--dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild4
-rw-r--r--dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild5
-rw-r--r--dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild6
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.48.ebuild7
-rw-r--r--dev-perl/libxml-perl/libxml-perl-0.07.ebuild4
-rw-r--r--dev-perl/perl-tk/perl-tk800-022.ebuild5
-rw-r--r--net-nds/openldap/openldap-1.2.11-r1.ebuild8
-rw-r--r--net-print/cups/cups-1.1.3.ebuild6
-rw-r--r--x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild8
20 files changed, 90 insertions, 24 deletions
diff --git a/dev-java/fesi/fesi-1.ebuild b/dev-java/fesi/fesi-1.ebuild
index 50b0bc03b9e3..7261e6514208 100644
--- a/dev-java/fesi/fesi-1.ebuild
+++ b/dev-java/fesi/fesi-1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-1.ebuild,v 1.2 2000/10/05 00:12:58 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fesi/fesi-1.ebuild,v 1.3 2000/11/01 06:27:07 achim Exp $
P=fesi
A="fesikit.zip"
@@ -9,6 +9,8 @@ S=${WORKDIR}/${P}
DESCRIPTION="JavaScript Interpreter writte in Java"
SRC_URI="http://home.worldcom.ch/jmlugrin/fesi/fesikit.zip"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
# jar -xf ${DISTDIR}/fesisrc.zip
jar -xf ${DISTDIR}/fesikit.zip
diff --git a/dev-java/jndi/jndi-1.2.1-r1.ebuild b/dev-java/jndi/jndi-1.2.1-r1.ebuild
index b595c4d5906b..c4067907801f 100644
--- a/dev-java/jndi/jndi-1.2.1-r1.ebuild
+++ b/dev-java/jndi/jndi-1.2.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jndi/jndi-1.2.1-r1.ebuild,v 1.2 2000/08/16 04:37:56 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jndi/jndi-1.2.1-r1.ebuild,v 1.3 2000/11/01 06:27:08 achim Exp $
P=jndi-1.2.1
A=jndi1_2_1.zip
@@ -10,12 +10,14 @@ DESCRIPTION="Java Naming and Directory Interface"
SRC_URI="ftp://"${A}
HOMEPAGE="http://java.sun.com/products/jndi/"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
#Please download the sources from sun
src_unpack() {
mkdir ${S}
cd ${S}
- unzip ${DISTDIR}/${A}
+ jar -xf ${DISTDIR}/${A}
}
src_compile() {
diff --git a/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild b/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
index c430bcdb2683..2fe3842ff320 100644
--- a/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
+++ b/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild,v 1.1 2000/08/16 14:31:08 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/mysql-jdbc/mysql-jdbc-1.2.3-r1.ebuild,v 1.2 2000/11/01 06:27:08 achim Exp $
P=mysql-jdbc-1.2c
A=mm.mysql.jdbc-1.2c.tar.gz
@@ -10,6 +10,8 @@ DESCRIPTION="JDBC Driver for MySQL"
SRC_URI="http://www.mysql.com/Downloads/Contrib/"${A}
HOMEPAGE="http://www.mysql.com/"
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
unpack ${A}
}
diff --git a/dev-java/xt/xt-1.ebuild b/dev-java/xt/xt-1.ebuild
index a057ee0d1ec9..51c03c2c7920 100644
--- a/dev-java/xt/xt-1.ebuild
+++ b/dev-java/xt/xt-1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xt/xt-1.ebuild,v 1.1 2000/08/16 18:55:59 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xt/xt-1.ebuild,v 1.2 2000/11/01 06:27:08 achim Exp $
P=xt
A=${P}.zip
@@ -9,10 +9,12 @@ S=${WORKDIR}/${P}
DESCRIPTION="Java Implementation of XSL-Transformations"
SRC_URI="ftp://ftp.jclark.com/pub/xml/"${A}
+DEPEND=">=dev-lang/jdk-1.2.2"
+
src_unpack() {
mkdir ${S}
cd ${S}
- unzip ${DISTDIR}/${A}
+ jar -xf ${DISTDIR}/${A}
}
src_compile() {
diff --git a/dev-libs/swig/swig-1.3_alpha4.ebuild b/dev-libs/swig/swig-1.3_alpha4.ebuild
index e001b413caa9..7662b9caf6f4 100644
--- a/dev-libs/swig/swig-1.3_alpha4.ebuild
+++ b/dev-libs/swig/swig-1.3_alpha4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/swig/swig-1.3_alpha4.ebuild,v 1.1 2000/09/18 21:07:53 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/swig/swig-1.3_alpha4.ebuild,v 1.2 2000/11/01 06:27:09 achim Exp $
P=swig1.3a4
A=${P}.tar.gz
@@ -10,6 +10,12 @@ DESCRIPTION="Simplified wrapper and interface generator"
SRC_URI="http://download.sourceforge.net/swig/${A}"
HOMEPAGE="http://www.swig.org"
+DEPEND=">=sys-devel/gcc-2.95.2
+ >=sys-libs/glibc-2.1.3
+ || ( >=sys-devel/python-basic-1.5.2 >=dev-lang/python-1.5.2 )
+ >=dev-lang/jdk-1.2.2
+ >=dev-lang/tcl-tk-8.1.1
+ >=dev-util/guile-1.4"
src_compile() {
@@ -17,7 +23,7 @@ src_compile() {
unset CXXFLAGS
unset CFLAGS
try ./configure --prefix=/usr --host=${CHOST} \
- --with-doc=html
+ --with-doc=html --with-tcllib=/usr/lib/tcl8.1
try make
}
diff --git a/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild b/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild
index 018c85a87f73..270a1ad8bfd7 100644
--- a/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild
+++ b/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild,v 1.1 2000/10/14 11:26:50 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Parser/HTML-Parser-3.13.ebuild,v 1.2 2000/11/01 06:27:09 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,6 +10,9 @@ DESCRIPTION="A HTML parser Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/HTML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/HTML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=sys-libs/glibc-2.1.3
+ >=dev-perl/HTML-Tagset-3.02"
src_compile() {
diff --git a/dev-perl/PDL/PDL-2.1.1.ebuild b/dev-perl/PDL/PDL-2.1.1.ebuild
index ffad1407fb5d..401263634e9d 100644
--- a/dev-perl/PDL/PDL-2.1.1.ebuild
+++ b/dev-perl/PDL/PDL-2.1.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.1.1.ebuild,v 1.3 2000/10/23 11:27:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.1.1.ebuild,v 1.4 2000/11/01 06:27:09 achim Exp $
P=PDL-2.1.1
A=${P}.tar.gz
@@ -10,6 +10,12 @@ DESCRIPTION="PDL Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1
+ >=dev-perl/ExtUtils-F77-1.13"
+
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/dev-perl/URI/URI-1.09.ebuild b/dev-perl/URI/URI-1.09.ebuild
index 89013737d334..29d36195c94e 100644
--- a/dev-perl/URI/URI-1.09.ebuild
+++ b/dev-perl/URI/URI-1.09.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/URI/URI-1.09.ebuild,v 1.1 2000/10/05 00:12:59 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/URI/URI-1.09.ebuild,v 1.2 2000/11/01 06:27:09 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,6 +10,8 @@ DESCRIPTION="A URI Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/URI/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/URI/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/MIME-Base64-2.11"
src_compile() {
diff --git a/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild b/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild
index 97aaf859ca0c..dc640342abc4 100644
--- a/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild
+++ b/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild,v 1.3 2000/09/15 20:08:50 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Catalog/XML-Catalog-0.01.ebuild,v 1.4 2000/11/01 06:27:10 achim Exp $
P=XML-Catalog-0.01
A=${P}.tar.gz
@@ -11,6 +11,9 @@ DESCRIPTION="Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-module/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29
+ >=dev-perl/libwww-perl-5.48"
src_compile() {
diff --git a/dev-perl/XML-DOM/XML-DOM-1.25.ebuild b/dev-perl/XML-DOM/XML-DOM-1.25.ebuild
index 7824d672d483..5a49ce29322e 100644
--- a/dev-perl/XML-DOM/XML-DOM-1.25.ebuild
+++ b/dev-perl/XML-DOM/XML-DOM-1.25.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-DOM/XML-DOM-1.25.ebuild,v 1.3 2000/10/05 00:13:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-DOM/XML-DOM-1.25.ebuild,v 1.4 2000/11/01 06:27:10 achim Exp $
P=XML-DOM-1.25
A=${P}.tar.gz
@@ -11,6 +11,8 @@ DESCRIPTION="A Perl module for an DOM Level 1 compliant interface"
SRC_URI="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29"
src_compile() {
diff --git a/dev-perl/XML-DT/XML-DT-0.14.ebuild b/dev-perl/XML-DT/XML-DT-0.14.ebuild
index 808d7547cc7a..c265d661b130 100644
--- a/dev-perl/XML-DT/XML-DT-0.14.ebuild
+++ b/dev-perl/XML-DT/XML-DT-0.14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-DT/XML-DT-0.14.ebuild,v 1.3 2000/09/15 20:08:50 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-DT/XML-DT-0.14.ebuild,v 1.4 2000/11/01 06:27:10 achim Exp $
P=XML-DT-0.14
A=${P}.tar.gz
@@ -11,6 +11,9 @@ DESCRIPTION="A perl XML down translate module"
SRC_URI="http://cpan.valueclick.com/modules/by-module/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29"
+
src_unpack() {
unpack $A
cd ${S}
diff --git a/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild b/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild
index a429e7dc27c4..c41140ec25e0 100644
--- a/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild
+++ b/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild,v 1.2 2000/09/15 20:08:50 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Encoding/XML-Encoding-1.01.ebuild,v 1.3 2000/11/01 06:27:11 achim Exp $
P=XML-Encoding-1.01
A=${P}.tar.gz
@@ -11,6 +11,8 @@ DESCRIPTION="Perl Module that parses encoding map XML files"
SRC_URI="http://cpan.valueclick.com/modules/by-module/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29"
src_compile() {
diff --git a/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild b/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild
index 4c9db2e6d450..a70eddd14f89 100644
--- a/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild
+++ b/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild,v 1.1 2000/09/20 17:16:52 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-Sablot/XML-Sablot-0.44.ebuild,v 1.2 2000/11/01 06:27:11 achim Exp $
P=XML-Sablotron-0.44
A=${P}.tar.gz
@@ -11,6 +11,9 @@ DESCRIPTION="Perl Module for Sablotron"
SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${A}"
HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/xml-sab.act"
+DEPEND=">=sys-devel/perl-5
+ >=sys-libs/glibc-2.1.3
+ >=app-text/sablotron-0.44"
src_compile() {
diff --git a/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild b/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild
index 6d68edef34ba..3dddf894ad70 100644
--- a/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild
+++ b/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild,v 1.2 2000/09/15 20:08:51 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/XML-XSLT/XML-XSLT-0.24.ebuild,v 1.3 2000/11/01 06:27:12 achim Exp $
P=XML-XSLT-0.24
A=${P}.tar.gz
@@ -11,6 +11,10 @@ DESCRIPTION="A Perl module to parse XSL Transformational sheets"
SRC_URI="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/11_String_Lang_Text_Proc/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29
+ >=dev-perl/XML-DOM-1.25
+ >=dev-perl/libwww-perl-5.48"
src_compile() {
diff --git a/dev-perl/libwww-perl/libwww-perl-5.48.ebuild b/dev-perl/libwww-perl/libwww-perl-5.48.ebuild
index f3cca38d1f10..6ca2b7755381 100644
--- a/dev-perl/libwww-perl/libwww-perl-5.48.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-5.48.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.48.ebuild,v 1.2 2000/09/15 20:08:51 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.48.ebuild,v 1.3 2000/11/01 06:27:12 achim Exp $
P=libwww-perl-5.48
A=${P}.tar.gz
@@ -11,6 +11,11 @@ DESCRIPTION="A collection of Perl Modules for the WWW"
SRC_URI="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/WWW/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-category/15_World_Wide_Web_HTML_HTTP_CGI/WWW/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/libnet-1.0703
+ >=dev-perl/HTML-Parser-3.13
+ >=dev-perl/URI-1.0.9
+ >=dev-perl/Digest-MD5-2.12"
src_compile() {
diff --git a/dev-perl/libxml-perl/libxml-perl-0.07.ebuild b/dev-perl/libxml-perl/libxml-perl-0.07.ebuild
index e67881267c88..3ac9d1da7379 100644
--- a/dev-perl/libxml-perl/libxml-perl-0.07.ebuild
+++ b/dev-perl/libxml-perl/libxml-perl-0.07.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libxml-perl/libxml-perl-0.07.ebuild,v 1.2 2000/09/15 20:08:51 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libxml-perl/libxml-perl-0.07.ebuild,v 1.3 2000/11/01 06:27:12 achim Exp $
P=libxml-perl-0.07
A=${P}.tar.gz
@@ -11,6 +11,8 @@ DESCRIPTION="Collection of Perl modules for working with XML"
SRC_URI="http://cpan.valueclick.com/modules/by-module/XML/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/XML/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=dev-perl/XML-Parser-2.29"
src_compile() {
diff --git a/dev-perl/perl-tk/perl-tk800-022.ebuild b/dev-perl/perl-tk/perl-tk800-022.ebuild
index d18195c0314c..678f220bfa48 100644
--- a/dev-perl/perl-tk/perl-tk800-022.ebuild
+++ b/dev-perl/perl-tk/perl-tk800-022.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/perl-tk800-022.ebuild,v 1.2 2000/09/15 20:08:52 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/perl-tk800-022.ebuild,v 1.3 2000/11/01 06:27:12 achim Exp $
P=Tk800.022
A=${P}.tar.gz
@@ -10,6 +10,9 @@ DESCRIPTION="A Perl Module for Tk"
SRC_URI="http://cpan.valueclick.com/modules/by-module/Tk/${A}"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/Tk/${P}.readme"
+DEPEND=">=sys-devel/perl-5
+ >=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
src_compile() {
diff --git a/net-nds/openldap/openldap-1.2.11-r1.ebuild b/net-nds/openldap/openldap-1.2.11-r1.ebuild
index 28e9dd7dc9ae..d44df6c60d10 100644
--- a/net-nds/openldap/openldap-1.2.11-r1.ebuild
+++ b/net-nds/openldap/openldap-1.2.11-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r1.ebuild,v 1.5 2000/10/23 11:27:16 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.11-r1.ebuild,v 1.6 2000/11/01 06:27:12 achim Exp $
P=openldap-1.2.11
A=${P}.tgz
@@ -10,6 +10,12 @@ DESCRIPTION="LDAP suite of application and development tools"
SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/"${A}
HOMEPAGE="http://www.OpenLDAP.org/"
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-apps/tcp-wrappers-7.6
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/gpm-1.19.3
+ >=sys-libs/ncurses-5.1"
+
src_compile() {
cd ${S}
./configure --host=${CHOST} --enable-wrappers --enable-passwd \
diff --git a/net-print/cups/cups-1.1.3.ebuild b/net-print/cups/cups-1.1.3.ebuild
index 62672d908519..637ddc67395c 100644
--- a/net-print/cups/cups-1.1.3.ebuild
+++ b/net-print/cups/cups-1.1.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.3.ebuild,v 1.2 2000/10/29 20:37:00 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.1.3.ebuild,v 1.3 2000/11/01 06:27:12 achim Exp $
A=${P}-source.tar.bz2
S=${WORKDIR}/${P}
@@ -9,6 +9,10 @@ DESCRIPTION="The Common Unix Printing System"
SRC_URI="ftp://ftp.easysw.com/pub/cups/${PV}/${A}"
HOMEPAGE="http://www.cups.org"
+DEPEND=">=sys-devel/gcc-2.95.2
+ >=sys-libs/glibc-2.1.3
+ >=sys-libs/pam-0.72
+ >=media-libs/libpng-1.0.7"
src_compile() {
diff --git a/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild b/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
index c3e9932dcacc..e5c0e22fb6ce 100644
--- a/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
+++ b/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild,v 1.1 2000/09/20 18:05:09 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkDPS/gtkDPS-0.3.3.ebuild,v 1.2 2000/11/01 06:27:13 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,7 +9,11 @@ DESCRIPTION="Set of functions, objects and widgets to use DPS easily with GTK"
SRC_URI="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/dist/${A}"
HOMEPAGE="http://www.aist-nara.ac.jp/~masata-y/gtkDPS/"
-
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3
+ >=x11-libs/gtk+-1.2.8
+ >=app-text/dgs-0.5.9.1"
+
src_compile() {
cd ${S}