summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2012-09-05 19:08:19 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2012-09-05 19:08:19 +0000
commitf729d8f61a7504c81ea015c8d39f27c3da159e49 (patch)
tree3a15b14acd736ca522f90f8650d3b22cc9a46464
parentRedundant copy of BSD license (diff)
downloadgentoo-2-f729d8f61a7504c81ea015c8d39f27c3da159e49.tar.gz
gentoo-2-f729d8f61a7504c81ea015c8d39f27c3da159e49.tar.bz2
gentoo-2-f729d8f61a7504c81ea015c8d39f27c3da159e49.zip
initial import for net-mail/dbmail-3.x fixes bug #251063
(Portage version: 2.1.11.12/cvs/Linux x86_64)
-rw-r--r--dev-db/libzdb/ChangeLog8
-rw-r--r--dev-db/libzdb/libzdb-2.10.3.ebuild92
-rw-r--r--dev-db/libzdb/metadata.xml11
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-db/libzdb/ChangeLog b/dev-db/libzdb/ChangeLog
new file mode 100644
index 000000000000..c6375342a1d8
--- /dev/null
+++ b/dev-db/libzdb/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-db/libzdb
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.1 2012/09/05 19:08:19 lordvan Exp $
+
+ 05 Sep 2012; <lordvan@gentoo.org> libzdb-2.10.3.ebuild, metadata.xml:
+ using parts from ebuild from bug #251063 by Johan Bergström
+ <bugs@bergstroem.nu>
+
diff --git a/dev-db/libzdb/libzdb-2.10.3.ebuild b/dev-db/libzdb/libzdb-2.10.3.ebuild
new file mode 100644
index 000000000000..6e2e80b3eae4
--- /dev/null
+++ b/dev-db/libzdb/libzdb-2.10.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.3.ebuild,v 1.1 2012/09/05 19:08:19 lordvan Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="http://www.tildeslash.com/libzdb/"
+SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc mysql postgres +sqlite +sqliteunlock ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( >=dev-db/sqlite-3 )
+ sqliteunlock? ( >=dev-db/sqlite-3.6.12[unlock-notify] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ if [[ $(gcc-version) < 4.1 ]];then
+ myconf="${myconf} --disable-protected"
+ else
+ myconf="${myconf} --enable-protected"
+ fi
+
+ if ( use sqlite ); then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/"
+ if has_version 'dev-db/sqlite[unlock-notify]'; then
+ myconf="${myconf} --enable-sqliteunlock"
+ fi
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default_src_compile
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ dohtml -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}
diff --git a/dev-db/libzdb/metadata.xml b/dev-db/libzdb/metadata.xml
new file mode 100644
index 000000000000..9588cabe3a5e
--- /dev/null
+++ b/dev-db/libzdb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+<maintainer>
+ <email>lordvan@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="sqliteunlock">Enable SQLite unlock notification api</flag>
+</use>
+</pkgmetadata>