summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-03-22 06:38:48 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-03-22 06:38:48 +0000
commitfcb45bce66b763663b8a9f1f3b4cc7007dc343dd (patch)
tree62623e1822c41787642c01a32cc718d164fdf048
parent- few more updates to this cross compile profile as we dont inherit from base (diff)
downloadgentoo-2-fcb45bce66b763663b8a9f1f3b4cc7007dc343dd.tar.gz
gentoo-2-fcb45bce66b763663b8a9f1f3b4cc7007dc343dd.tar.bz2
gentoo-2-fcb45bce66b763663b8a9f1f3b4cc7007dc343dd.zip
Version bumped. Fixed java-pkg_newjar.
(Portage version: 2.1.6.8/cvs/Linux x86_64)
-rw-r--r--net-dns/libidn/ChangeLog9
-rw-r--r--net-dns/libidn/libidn-1.13.ebuild80
2 files changed, 87 insertions, 2 deletions
diff --git a/net-dns/libidn/ChangeLog b/net-dns/libidn/ChangeLog
index 0ca09000ef46..8df29091ceb1 100644
--- a/net-dns/libidn/ChangeLog
+++ b/net-dns/libidn/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/libidn
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.89 2008/11/27 21:33:35 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/ChangeLog,v 1.90 2009/03/22 06:38:48 matsuu Exp $
+
+*libidn-1.13 (22 Mar 2009)
+
+ 22 Mar 2009; MATSUU Takuto <matsuu@gentoo.org> +libidn-1.13.ebuild:
+ Version bumped. Fixed java-pkg_newjar.
*libidn-1.11 (27 Nov 2008)
diff --git a/net-dns/libidn/libidn-1.13.ebuild b/net-dns/libidn/libidn-1.13.ebuild
new file mode 100644
index 000000000000..115a3e182276
--- /dev/null
+++ b/net-dns/libidn/libidn-1.13.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/libidn/libidn-1.13.ebuild,v 1.1 2009/03/22 06:38:48 matsuu Exp $
+
+inherit java-pkg-opt-2 mono elisp-common
+
+DESCRIPTION="Internationalized Domain Names (IDN) implementation"
+HOMEPAGE="http://www.gnu.org/software/libidn/"
+SRC_URI="mirror://gnu/libidn/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc emacs java mono nls"
+
+COMMON_DEPEND="emacs? ( virtual/emacs )
+ mono? ( >=dev-lang/mono-0.95 )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( >=sys-devel/gettext-0.17 )
+ java? ( >=virtual/jdk-1.4 dev-java/gjdoc )"
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )
+ java? ( >=virtual/jre-1.4 )"
+
+SITEFILE=50${PN}-gentoo.pl
+
+src_unpack() {
+ unpack ${A}
+ # bundled, with wrong bytecode
+ rm "${S}/java/${P}.jar" || die
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable java) \
+ $(use_enable mono csharp mono) \
+ --with-lispdir="${SITELISP}/${PN}" \
+ || die
+
+ emake || die
+
+ if use emacs; then
+ elisp-compile src/*.el || die
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO || die
+
+ if use emacs; then
+ # *.el are installed by the build system
+ elisp-install ${PN} src/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ else
+ rm -rf "${D}/usr/share/emacs"
+ fi
+
+ if use doc ; then
+ dohtml -r doc/reference/html/* || die
+ fi
+
+ if use java ; then
+ java-pkg_newjar java/${P}.jar ${PN}.jar || die
+ rm -rf "${D}"/usr/share/java || die
+
+ if use doc ; then
+ java-pkg_dojavadoc doc/java
+ fi
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}