summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-10-07 07:11:39 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-10-07 07:11:39 +0000
commitfdbfbb1845f254081d6eefd2d551609d12f92c7f (patch)
treed98855a3b658fdc04c61cdb7b3aaf7851838db04
parentInitial import. New dependency for forthcoming Rails 3.1 (via sprockets). (diff)
downloadgentoo-2-fdbfbb1845f254081d6eefd2d551609d12f92c7f.tar.gz
gentoo-2-fdbfbb1845f254081d6eefd2d551609d12f92c7f.tar.bz2
gentoo-2-fdbfbb1845f254081d6eefd2d551609d12f92c7f.zip
Version bump
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
-rw-r--r--x11-misc/lightdm/ChangeLog7
-rw-r--r--x11-misc/lightdm/lightdm-1.0.2.ebuild108
2 files changed, 114 insertions, 1 deletions
diff --git a/x11-misc/lightdm/ChangeLog b/x11-misc/lightdm/ChangeLog
index 1f50a46df08b..40acac64c24d 100644
--- a/x11-misc/lightdm/ChangeLog
+++ b/x11-misc/lightdm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/lightdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.9 2011/09/25 17:29:18 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/ChangeLog,v 1.10 2011/10/07 07:11:39 hwoarang Exp $
+
+*lightdm-1.0.2 (07 Oct 2011)
+
+ 07 Oct 2011; Markos Chandras <hwoarang@gentoo.org> +lightdm-1.0.2.ebuild:
+ Version bump
*lightdm-0.9.8 (25 Sep 2011)
diff --git a/x11-misc/lightdm/lightdm-1.0.2.ebuild b/x11-misc/lightdm/lightdm-1.0.2.ebuild
new file mode 100644
index 000000000000..1d038c766676
--- /dev/null
+++ b/x11-misc/lightdm/lightdm-1.0.2.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/lightdm/lightdm-1.0.2.ebuild,v 1.1 2011/10/07 07:11:39 hwoarang Exp $
+
+EAPI=4
+inherit autotools eutils pam
+
+DESCRIPTION="A lightweight display manager"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/LightDM"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ gtk? ( http://dev.gentoo.org/~hwoarang/distfiles/${PN}-gentoo-patch.tar.gz )"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="branding +gtk +introspection qt4"
+
+RDEPEND="dev-libs/glib:2
+ virtual/pam
+ x11-libs/libxklavier
+ x11-libs/libX11
+ dev-libs/libxml2
+ gtk? ( x11-libs/gtk+:3
+ x11-themes/gnome-themes-standard
+ x11-themes/gnome-icon-theme )
+ qt4? ( x11-libs/qt-core:4
+ x11-libs/qt-dbus:4 )
+ sys-apps/accountsservice"
+DEPEND="${RDEPEND}
+ dev-lang/vala:0.12
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext
+ introspection? ( dev-libs/gobject-introspection )"
+
+REQUIRED_USE="branding? ( gtk ) || ( gtk qt4 )"
+DOCS=( NEWS )
+
+src_prepare() {
+ # remove GNOME_COMPILE_WARNING reference which requires
+ # gnome-base/gnome-common dependency.
+ sed -i -e "/GNOME_COMPILE_WARNING/d" "${S}"/configure.ac || die
+ # Hide users with uid < 1000
+ sed -i -e "/minimum-uid/s:500:1000:" "${S}"/data/users.conf || die
+ eautoreconf
+}
+
+src_configure() {
+ # Maybe in the future, we can support some automatic session and user
+ # recognition. Until then, use default values
+ local default=gnome greeter= user=root
+
+ # gtk has higher priority because Qt4 interface sucks :)
+ use qt4 && greeter=lightdm-qt-greeter
+ use gtk && greeter=lightdm-gtk-greeter
+
+ # Let user know how lightdm is configured
+ einfo "Gentoo configuration"
+ einfo "Default greeter: ${greeter}"
+ einfo "Default session: ${default}"
+ einfo "Greeter user: ${user}"
+
+ # do the actual configuration
+ econf --localstatedir=/var \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable qt4 liblightdm-qt) \
+ $(use_enable qt4 qt-greeter) \
+ $(use_enable gtk gtk-greeter) \
+ --with-user-session=${default} \
+ --with-greeter-session=${greeter} \
+ --with-greeter-user=${user} \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ # Install missing files
+ insinto /etc/${PN}/
+ doins "${S}"/data/{users,keys}.conf
+ # remove .la files
+ find "${ED}" -name "*.la" -exec rm -rf {} +
+ rm -Rf "${ED}"/etc/init || die
+
+ if use gtk; then
+ insinto /etc/${PN}/
+ doins "${WORKDIR}"/${PN}-gtk-greeter.conf
+ if use branding; then
+ insinto /usr/share/${PN}/backgrounds/
+ doins "${WORKDIR}"/gentoo1024x768.png
+ sed -i -e "/background/s:=.*:=/usr/share/${PN}/backgrounds/gentoo1024x768.png:" \
+ "${D}"/etc/${PN}/${PN}-gtk-greeter.conf || die
+ fi
+ fi
+ pamd_mimic system-local-login lightdm auth account session
+}
+
+pkg_postinst() {
+ elog
+ elog "Even though the default /etc/${PN}/${PN}.conf will work for"
+ elog "most users, make sure you configure it to suit your needs"
+ elog "before using ${PN} for the first time."
+ elog "You can test the configuration file using the following"
+ elog "command: ${PN} --test-mode -c /etc/${PN}/${PN}.conf. This"
+ elog "requires xorg-server to be built with the 'kdrive' useflag."
+ elog
+}