summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-12-18 09:08:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-12-18 09:08:11 +0000
commitfe34f0470d05bf3eb959c59761b1225a31a5160d (patch)
treefcbab4af0f1dbc56a7587870bc21951f40eaaeef
parentVersion bump to 4.0.10 ; dropping old versions (diff)
downloadgentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.tar.gz
gentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.tar.bz2
gentoo-2-fe34f0470d05bf3eb959c59761b1225a31a5160d.zip
Version bump
(Portage version: 2.2_rc17/cvs/Linux 2.6.27.9 i686)
-rw-r--r--dev-games/irrlicht/ChangeLog9
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.5-config.patch26
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch20
-rw-r--r--dev-games/irrlicht/irrlicht-1.5.ebuild59
4 files changed, 113 insertions, 1 deletions
diff --git a/dev-games/irrlicht/ChangeLog b/dev-games/irrlicht/ChangeLog
index 4fe6ee232753..0f8f55461ef7 100644
--- a/dev-games/irrlicht/ChangeLog
+++ b/dev-games/irrlicht/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-games/irrlicht
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.28 2008/10/09 06:25:50 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.29 2008/12/18 09:08:11 nyhm Exp $
+
+*irrlicht-1.5 (18 Dec 2008)
+
+ 18 Dec 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/irrlicht-1.5-config.patch, +files/irrlicht-1.5-demoMake.patch,
+ +irrlicht-1.5.ebuild:
+ Version bump
*irrlicht-1.4.2 (09 Oct 2008)
diff --git a/dev-games/irrlicht/files/irrlicht-1.5-config.patch b/dev-games/irrlicht/files/irrlicht-1.5-config.patch
new file mode 100644
index 000000000000..fbb1cab1ac7b
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.5-config.patch
@@ -0,0 +1,26 @@
+--- include/IrrCompileConfig.h
++++ include/IrrCompileConfig.h
+@@ -113,7 +113,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_ZLIB_ to let irrlicht use the zlib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the zlib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_ZLIB_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
+
+
+ //! Define _IRR_COMPILE_WITH_JPEGLIB_ to enable compiling the engine using libjpeg.
+@@ -124,7 +123,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+
+
+ //! Define _IRR_COMPILE_WITH_LIBPNG_ to enable compiling the engine using libpng.
+@@ -135,7 +133,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+
+
+ //! Define _IRR_D3D_NO_SHADER_DEBUGGING to disable shader debugging in D3D9
diff --git a/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch b/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch
new file mode 100644
index 000000000000..ba8a3e2495fb
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.5-demoMake.patch
@@ -0,0 +1,20 @@
+--- examples/Demo/Makefile
++++ examples/Demo/Makefile
+@@ -2,7 +2,7 @@
+ Target = Demo
+ Sources = CDemo.cpp CMainMenu.cpp main.cpp
+
+-CPPFLAGS = -I../../include -I/usr/X11R6/include
++CPPFLAGS = -I/usr/include/irrlicht
+ CXXFLAGS = -Wall -O3 -ffast-math
+
+ ifeq ($(HOSTTYPE), x86_64)
+@@ -13,7 +13,7 @@
+
+ # target specific settings
+ all_linux: SYSTEM=Linux
+-all_linux: LDFLAGS = -L/usr/X11R6/lib$(LIBSELECT) -L../../lib/$(SYSTEM) -lIrrlicht -lGL -lXxf86vm -lXext -lX11
++all_linux: LDFLAGS = -lIrrlicht -lGL -lXxf86vm -lXext -lX11 -lpng -ljpeg
+
+ all_win32 clean_win32: SYSTEM=Win32-gcc
+ all_win32: LDFLAGS = -L../../lib/$(SYSTEM) -lIrrlicht -lopengl32 -lglu32 -lm
diff --git a/dev-games/irrlicht/irrlicht-1.5.ebuild b/dev-games/irrlicht/irrlicht-1.5.ebuild
new file mode 100644
index 000000000000..8923ac2210a3
--- /dev/null
+++ b/dev-games/irrlicht/irrlicht-1.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.5.ebuild,v 1.1 2008/12/18 09:08:11 nyhm Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="open source high performance realtime 3D engine written in C++"
+HOMEPAGE="http://irrlicht.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-proto/xproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${P}/source/Irrlicht
+
+src_unpack() {
+ unpack ${A}
+ cd ${P}
+ epatch \
+ "${FILESDIR}"/${P}-config.patch \
+ "${FILESDIR}"/${P}-demoMake.patch
+
+ cd "${S}"
+ sed -i \
+ -e '/^CXXFLAGS/s:=:+=:' \
+ -e '/^CXXINCS/s:-Izlib -Ijpeglib -Ilibpng::' \
+ -e '/^ZLIBOBJ/d' \
+ -e '/^JPEGLIBOBJ/d' \
+ -e '/^LIBPNGOBJ/d' \
+ Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ cd ../..
+ dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
+ insinto /usr/include/${PN}
+ doins include/* || die "doins failed"
+ dodoc changes.txt readme.txt
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples media || die "doins failed"
+ fi
+}