summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-20 08:29:47 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-05-20 08:29:47 +0000
commit47ef90290bfe215e4b16b50db7e59fa2a3894db7 (patch)
tree3572d7d91908a3658e6ecc47a24cad866a02dd60 /app-accessibility/at-spi2-core
parentVersion bump for gnome-3.4; seed-based games were ported to vala. (diff)
downloadgentoo-2-47ef90290bfe215e4b16b50db7e59fa2a3894db7.tar.gz
gentoo-2-47ef90290bfe215e4b16b50db7e59fa2a3894db7.tar.bz2
gentoo-2-47ef90290bfe215e4b16b50db7e59fa2a3894db7.zip
Version bump with bug fixes.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility/at-spi2-core')
-rw-r--r--app-accessibility/at-spi2-core/ChangeLog8
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/app-accessibility/at-spi2-core/ChangeLog b/app-accessibility/at-spi2-core/ChangeLog
index 133dec92ae11..c72a3660f042 100644
--- a/app-accessibility/at-spi2-core/ChangeLog
+++ b/app-accessibility/at-spi2-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/at-spi2-core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.7 2012/05/14 00:08:46 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/ChangeLog,v 1.8 2012/05/20 08:29:47 tetromino Exp $
+
+*at-spi2-core-2.4.2 (20 May 2012)
+
+ 20 May 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +at-spi2-core-2.4.2.ebuild:
+ Version bump with bug fixes.
*at-spi2-core-2.4.1 (14 May 2012)
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild
new file mode 100644
index 000000000000..8adf2c4a74ee
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-spi2-core/at-spi2-core-2.4.2.ebuild,v 1.1 2012/05/20 08:29:47 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="http://live.gnome.org/Accessibility"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~hppa ~x86"
+IUSE="doc +introspection"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=sys-apps/dbus-1
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # xevie is deprecated/broken since xorg-1.6/1.7
+ G2CONF="${G2CONF} --disable-xevie"
+}
+
+src_prepare() {
+ # disable teamspaces test since that requires Novell.ICEDesktop.Daemon
+ epatch "${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ gnome2_src_prepare
+}