summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-07-15 18:06:32 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-07-15 18:06:32 +0000
commit38356f578f1309da18f00f17149d3528097665be (patch)
treee5353ee3c9ddf9b26c3f70cb4a917294822e3f81 /app-accessibility/speakup
parentversion bump (diff)
downloadgentoo-2-38356f578f1309da18f00f17149d3528097665be.tar.gz
gentoo-2-38356f578f1309da18f00f17149d3528097665be.tar.bz2
gentoo-2-38356f578f1309da18f00f17149d3528097665be.zip
added live ebuild
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/speakup')
-rw-r--r--app-accessibility/speakup/ChangeLog7
-rw-r--r--app-accessibility/speakup/speakup-9999.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index c035b5d10e1b..03d6f59d5c98 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.26 2009/07/15 17:55:06 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.27 2009/07/15 18:06:32 williamh Exp $
+
+*speakup-9999 (15 Jul 2009)
+
+ 15 Jul 2009; William Hubbs <williamh@gentoo.org> +speakup-9999.ebuild:
+ added live ebuild.
*speakup-3.1.2 (15 Jul 2009)
diff --git a/app-accessibility/speakup/speakup-9999.ebuild b/app-accessibility/speakup/speakup-9999.ebuild
new file mode 100644
index 000000000000..a08b612192ee
--- /dev/null
+++ b/app-accessibility/speakup/speakup-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-9999.ebuild,v 1.1 2009/07/15 18:06:32 williamh Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="http://linux-speakup.org/speakup.git"
+inherit git linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_prepare() {
+ case ${KV_EXTRA} in
+ *gentoo)
+ if kernel_is lt 2 6 25; then
+ die "Speakup requires at least gentoo-sources-2.6.25"
+ fi
+ ;;
+ *)
+ if kernel_is lt 2 6 26; then
+ die "Speakup requires at least kernel version2.6.26"
+ fi
+ ;;
+ esac
+}
+
+src_compile() {
+ MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+ BUILD_TARGETS="clean all"
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+ dobin tools/speakupconf
+ dosbin tools/talkwith
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ newdoc tools/README README.tools
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}