summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2006-07-20 03:51:27 +0000
committerWilliam Hubbs <williamh@gentoo.org>2006-07-20 03:51:27 +0000
commit21a5c96a11a48a240765924932b6eb6c2eb8dd1f (patch)
tree56ecbce14f122a9c336c8bf8053483d33f60ed4b /app-accessibility
parentstable on mips (diff)
downloadgentoo-2-21a5c96a11a48a240765924932b6eb6c2eb8dd1f.tar.gz
gentoo-2-21a5c96a11a48a240765924932b6eb6c2eb8dd1f.tar.bz2
gentoo-2-21a5c96a11a48a240765924932b6eb6c2eb8dd1f.zip
Added patches from Ed Catmur for gcc 4.1 compatability.
(Portage version: 2.1.1_pre3-r1)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/festival/ChangeLog8
-rw-r--r--app-accessibility/festival/festival-1.95_beta.ebuild6
-rw-r--r--app-accessibility/festival/files/festival-1.95_beta-gcc41-amd64.patch11
-rw-r--r--app-accessibility/festival/files/festival-1.95_beta-gcc41.patch77
4 files changed, 100 insertions, 2 deletions
diff --git a/app-accessibility/festival/ChangeLog b/app-accessibility/festival/ChangeLog
index 328b3b86b700..163e7a6953b1 100644
--- a/app-accessibility/festival/ChangeLog
+++ b/app-accessibility/festival/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/festival
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.41 2006/07/20 03:24:26 psi29a Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.42 2006/07/20 03:51:27 williamh Exp $
+
+ 20 Jul 2006; William Hubbs <williamh@gentoo.org>
+ +files/festival-1.95_beta-gcc41-amd64.patch,
+ +files/festival-1.95_beta-gcc41.patch, festival-1.95_beta.ebuild:
+ Added Ed Catmur's patches so this will compile under gcc 4.1.
+ This is for bug #116030.
19 Jul 2006; <psi29a@gentoo.org> festival-1.4.3-r3.ebuild,
festival-1.4.3-r4.ebuild:
diff --git a/app-accessibility/festival/festival-1.95_beta.ebuild b/app-accessibility/festival/festival-1.95_beta.ebuild
index 0cb0b58aec70..6d7ede031cff 100644
--- a/app-accessibility/festival/festival-1.95_beta.ebuild
+++ b/app-accessibility/festival/festival-1.95_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta.ebuild,v 1.2 2006/06/16 13:04:19 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.95_beta.ebuild,v 1.3 2006/07/20 03:51:27 williamh Exp $
inherit eutils toolchain-funcs
@@ -55,6 +55,10 @@ src_unpack() {
# Fix hardcoded path for examples that will be finally installed in /usr/$(get_libdir)/festival/examples
sed -i -e "s:\.\./examples/:/usr/share/doc/${PF}/examples/:" ${S}/festival/lib/festival.scm
+
+ # gcc 4.1 compatibility patches
+ epatch ${FILESDIR}/${P}-gcc41.patch
+ use amd64 && epatch ${FILESDIR}/${P}-gcc41-amd64.patch
}
src_compile() {
diff --git a/app-accessibility/festival/files/festival-1.95_beta-gcc41-amd64.patch b/app-accessibility/festival/files/festival-1.95_beta-gcc41-amd64.patch
new file mode 100644
index 000000000000..d6ab0749ae45
--- /dev/null
+++ b/app-accessibility/festival/files/festival-1.95_beta-gcc41-amd64.patch
@@ -0,0 +1,11 @@
+--- speech_tools/ling_class/item_feats.cc 2006/06/27 11:43:49 1.1
++++ speech_tools/ling_class/item_feats.cc 2006/06/27 11:44:25
+@@ -78,7 +78,7 @@ EST_String get_featname(const EST_Item_f
+ EST_String name = EST_FeatureFunctionContext::global->get_featfunc_name(func, found);
+
+ if (!found)
+- EST_error("featfunc 0x%x has no name", (int)func);
++ EST_error("featfunc 0x%p has no name", func);
+
+ return name;
+ }
diff --git a/app-accessibility/festival/files/festival-1.95_beta-gcc41.patch b/app-accessibility/festival/files/festival-1.95_beta-gcc41.patch
new file mode 100644
index 000000000000..72da4177bf2f
--- /dev/null
+++ b/app-accessibility/festival/files/festival-1.95_beta-gcc41.patch
@@ -0,0 +1,77 @@
+--- speech_tools/include/EST_Chunk.h 2006/06/05 00:32:45 1.1
++++ speech_tools/include/EST_Chunk.h 2006/06/05 01:41:28
+@@ -103,6 +103,8 @@
+ /* */
+ /************************************************************************/
+
++class EST_ChunkPtr;
++
+ class EST_Chunk {
+ public:
+ typedef unsigned short use_counter;
+@@ -152,6 +154,13 @@ class EST_Chunk {
+ /* */
+ /************************************************************************/
+
++EST_ChunkPtr chunk_allocate(int bytes);
++EST_ChunkPtr chunk_allocate(int bytes, const char *initial, int initial_len);
++EST_ChunkPtr chunk_allocate(int bytes, const EST_ChunkPtr &initial, int initial_start, int initial_len);
++
++void make_updatable(EST_ChunkPtr &shared, EST_Chunk::EST_chunk_size inuse);
++void make_updatable(EST_ChunkPtr &shared);
++
+ class EST_ChunkPtr {
+ private:
+ EST_Chunk *ptr;
+--- speech_tools/include/ling_class/EST_Item.h 2006/06/05 00:39:43 1.1
++++ speech_tools/include/ling_class/EST_Item.h 2006/06/05 00:40:02
+@@ -79,6 +79,9 @@ use we envisage. Traversal of the items
+
+ */
+
++class EST_Item;
++int same_item(const EST_Item *l1,const EST_Item *l2);
++
+ class EST_Item
+ {
+ private:
+--- ./speech_tools/base_class/EST_Pathname_unix.cc 2006/06/05 00:59:34 1.1
++++ ./speech_tools/base_class/EST_Pathname_unix.cc 2006/06/05 01:19:16
+@@ -89,7 +89,7 @@ EST_Pathname EST_Pathname::as_directory(
+ return *this;
+
+ if (length() > 0)
+- return ::operator +(EST_String(*this), "/");
++ return EST_String(*this) + "/";
+
+ return "./";
+ }
+--- festival/src/modules/clunits/clunits.h 2006/06/05 01:58:30 1.1
++++ festival/src/modules/clunits/clunits.h 2006/06/05 01:58:47
+@@ -83,9 +83,9 @@ class CLDB {
+ CLfile *get_fileitem(const EST_String &name)
+ { return (CLfile *)fileindex.lookup(name); }
+ void load_coefs_sig(EST_Item *unit);
+- CLfile *CLDB::get_file_coefs_sig(const EST_String &fileid);
++ CLfile *get_file_coefs_sig(const EST_String &fileid);
+ void load_join_coefs(CLunit *unit);
+- CLfile *CLDB::get_file_join_coefs(const EST_String &fileid);
++ CLfile *get_file_join_coefs(const EST_String &fileid);
+ };
+
+
+--- festival/src/modules/MultiSyn/EST_JoinCostCache.h 2006/06/05 02:00:28 1.1
++++ festival/src/modules/MultiSyn/EST_JoinCostCache.h 2006/06/05 02:00:57
+@@ -56,11 +56,11 @@
+ /** Object oriented approach for better and for worse...
+ */
+
++#include <ostream>
+ #include "EST_TList.h"
+ #include "ling_class/EST_Item.h"
+
+ class EST_JoinCost;
+-class ostream;
+
+ class EST_JoinCostCache {
+ public: