summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-08-06 11:27:36 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-08-06 11:27:36 +0000
commit40f41f122e690ae428332dd715e72c9dca65ffd7 (patch)
tree3b056ab5334003f7c7f849a0e6446f6e7e24f9a2 /app-accessibility
parentversion bump, fixes bugs 138629, 140555, 142469, 142503 and 141818 (diff)
downloadgentoo-2-40f41f122e690ae428332dd715e72c9dca65ffd7.tar.gz
gentoo-2-40f41f122e690ae428332dd715e72c9dca65ffd7.tar.bz2
gentoo-2-40f41f122e690ae428332dd715e72c9dca65ffd7.zip
Added upstream patch to fix compilation with GCC 4 (bug #142932).
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-poke/ChangeLog6
-rw-r--r--app-accessibility/at-poke/at-poke-0.2.2.ebuild21
-rw-r--r--app-accessibility/at-poke/files/at-poke-0.2.2-gcc4.patch20
3 files changed, 41 insertions, 6 deletions
diff --git a/app-accessibility/at-poke/ChangeLog b/app-accessibility/at-poke/ChangeLog
index 467aee8e9331..bb3c1471a302 100644
--- a/app-accessibility/at-poke/ChangeLog
+++ b/app-accessibility/at-poke/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/at-poke
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-poke/ChangeLog,v 1.8 2006/07/25 00:14:12 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-poke/ChangeLog,v 1.9 2006/08/06 11:27:36 leonardop Exp $
+
+ 06 Aug 2006; Leonardo Boshell <leonardop@gentoo.org>
+ +files/at-poke-0.2.2-gcc4.patch, at-poke-0.2.2.ebuild:
+ Added upstream patch to fix compilation with GCC 4 (bug #142932).
*at-poke-0.2.3 (25 Jul 2006)
diff --git a/app-accessibility/at-poke/at-poke-0.2.2.ebuild b/app-accessibility/at-poke/at-poke-0.2.2.ebuild
index 9426c55a191e..ce6753444737 100644
--- a/app-accessibility/at-poke/at-poke-0.2.2.ebuild
+++ b/app-accessibility/at-poke/at-poke-0.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-poke/at-poke-0.2.2.ebuild,v 1.7 2005/07/22 09:00:08 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/at-poke/at-poke-0.2.2.ebuild,v 1.8 2006/08/06 11:27:36 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="The accessibility poking tool"
HOMEPAGE="http://www.gnome.org/"
@@ -18,9 +18,20 @@ RDEPEND=">=gnome-extra/at-spi-1.3.12
>=gnome-base/libgnomeui-2
gnome-extra/libgail-gnome
>=dev-libs/popt-1.5"
+
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0"
+ >=dev-util/pkgconfig-0.9"
-G2CONF="${G2CONF} --enable-platform-gnome-2"
DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+
+pkg_setup() {
+ G2CONF="--enable-platform-gnome-2"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
diff --git a/app-accessibility/at-poke/files/at-poke-0.2.2-gcc4.patch b/app-accessibility/at-poke/files/at-poke-0.2.2-gcc4.patch
new file mode 100644
index 000000000000..498c3828ab91
--- /dev/null
+++ b/app-accessibility/at-poke/files/at-poke-0.2.2-gcc4.patch
@@ -0,0 +1,20 @@
+diff -NurdB at-poke-0.2.2/src/accessible-tree-model.c at-poke-0.2.2-patched/src/accessible-tree-model.c
+--- at-poke-0.2.2/src/accessible-tree-model.c 2003-05-28 07:36:43.000000000 -0500
++++ at-poke-0.2.2-patched/src/accessible-tree-model.c 2006-08-06 06:10:10.000000000 -0500
+@@ -93,6 +93,7 @@
+ static GObjectClass *parent_class;
+
+ #define ITER_NODE(i) ((GNode *)((i)->user_data))
++#define ITER_NODE_L(i) ((i)->user_data)
+ #define MODEL_NODE(n) ((ModelNode *)(n)->data)
+
+ static gboolean
+@@ -113,7 +114,7 @@
+ return make_iter_invalid (iter);
+
+ iter->stamp = ACCESSIBLE_TREE_MODEL (model)->stamp;
+- ITER_NODE (iter) = node;
++ ITER_NODE_L (iter) = node;
+ iter->user_data2 = NULL;
+ iter->user_data3 = NULL;
+