summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-02-02 21:35:18 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-02-02 21:35:18 +0000
commit4326e5515369f055a8b37e949db6e9c8da42beb7 (patch)
tree84b1d10226e3aeb69272c02e42d91dae80bc13e4 /app-accessibility
parentclean out older ebuilds with missing local use flag (diff)
downloadgentoo-2-4326e5515369f055a8b37e949db6e9c8da42beb7.tar.gz
gentoo-2-4326e5515369f055a8b37e949db6e9c8da42beb7.tar.bz2
gentoo-2-4326e5515369f055a8b37e949db6e9c8da42beb7.zip
Bug 208538 -- fixed java and ocaml support, thanks to Betelgeuse and Caster.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog5
-rw-r--r--app-accessibility/brltty/brltty-3.9.ebuild57
2 files changed, 26 insertions, 36 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index 9d122171a2bb..82c31e58604b 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-accessibility/brltty
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.70 2008/02/02 14:10:44 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.71 2008/02/02 21:35:18 williamh Exp $
+
+ 02 Feb 2008; William Hubbs <williamh@gentoo.org> brltty-3.9.ebuild:
+ Bug #208538 -- fixed java and ocaml support, thanks to Betelgeuse and Caster
02 Feb 2008; Brent Baude <ranger@gentoo.org> brltty-3.9.ebuild:
Marking brltty-3.9 ppc64 for bug 208536
diff --git a/app-accessibility/brltty/brltty-3.9.ebuild b/app-accessibility/brltty/brltty-3.9.ebuild
index 26c656272c4e..13af64bf99ee 100644
--- a/app-accessibility/brltty/brltty-3.9.ebuild
+++ b/app-accessibility/brltty/brltty-3.9.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.9.ebuild,v 1.5 2008/02/02 14:10:44 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-3.9.ebuild,v 1.6 2008/02/02 21:35:18 williamh Exp $
-inherit eutils multilib toolchain-funcs
+FINDLIB_USE="ocaml"
+
+inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic
DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
HOMEPAGE="http://mielke.cc/brltty/"
@@ -13,18 +15,25 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ppc64 x86"
IUSE="bluetooth doc gpm iconv java nls ocaml python usb tcl X"
-DEPEND="bluetooth? ( net-wireless/bluez-libs )
+COMMON_DEP="bluetooth? ( net-wireless/bluez-libs )
gpm? ( >=sys-libs/gpm-1.20 )
iconv? ( virtual/libiconv )
- java? ( virtual/jdk )
nls? ( virtual/libintl )
- ocaml? ( >=dev-ml/findlib-1.0.4-r1 )
python? ( >=dev-python/pyrex-0.9.4.1 )
tcl? ( >=dev-lang/tcl-8.4.15 )
usb? ( >=dev-libs/libusb-0.1.12-r1 )
X? ( x11-libs/libXaw )"
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${COMMON_DEP}"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ ${COMMON_DEP}"
src_compile() {
+ local JAVAC_CONF=""
+ if use java; then
+ append-flags "$(java-pkg_get-jni-cflags)"
+ JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
econf --prefix=/ \
$(use_enable bluetooth) \
$(use_enable gpm) \
@@ -37,36 +46,7 @@ src_compile() {
$(use_enable tcl tcl-bindings) \
$(use_with X x) \
--includedir=/usr/include || die
- emake || die
-}
-
-# The following was copied from findlib.eclass so that we don't force a
-# dependency on dev-ml/findlib unless the ml use flag is on.
-
-check_ocamlfind() {
- if [ ! -x /usr/bin/ocamlfind ]
- then
- ewarn "In findlib.eclass: could not find the ocamlfind executable"
- ewarn "Please report this bug on gentoo's bugzilla, assigning to ml@gentoo.org"
- exit 1
- fi
-}
-
-# Prepare the image for a findlib installation.
-# We use the stublibs style, so no ld.conf needs to be
-# updated when a package installs C shared libraries.
-findlib_src_preinst() {
- check_ocamlfind
-
- # destdir is the ocaml sitelib
- local destdir=`ocamlfind printconf destdir`
-
- dodir ${destdir} || die "dodir failed"
- export OCAMLFIND_DESTDIR=${D}${destdir}
-
- # stublibs style
- dodir ${destdir}/stublibs || die "dodir failed"
- export OCAMLFIND_LDCONF=ignore
+ emake JAVAC="${JAVAC_CONF}" || die
}
src_install() {
@@ -75,6 +55,13 @@ src_install() {
fi
make INSTALL_PROGRAM="\${INSTALL_SCRIPT}" INSTALL_ROOT="${D}" install || die
+ if use java; then
+ # make install puts the _java.so there, and no it's not $(get_libdir)
+ rm -rf "${D}/usr/lib/java"
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
cd Documents
rm *.made
dodoc ChangeLog README* Manual.* TODO