summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-08-07 03:52:43 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-08-07 03:52:43 +0000
commit635924e5cf5a5d644dda723a29950d2631afb3a0 (patch)
tree8c59bbfd37c086c7f6701029978bf6dd4fbcdd54 /app-accessibility
parentStable for HPPA (bug #233790). (diff)
downloadgentoo-2-635924e5cf5a5d644dda723a29950d2631afb3a0.tar.gz
gentoo-2-635924e5cf5a5d644dda723a29950d2631afb3a0.tar.bz2
gentoo-2-635924e5cf5a5d644dda723a29950d2631afb3a0.zip
Version bump.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog8
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher4
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild59
3 files changed, 68 insertions, 3 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index a52a0a0b2f73..786f80becd84 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.39 2008/07/17 20:51:16 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.40 2008/08/07 03:52:42 williamh Exp $
+
+*speech-dispatcher-0.6.7 (07 Aug 2008)
+
+ 07 Aug 2008; William Hubbs <williamh@gentoo.org> files/speech-dispatcher,
+ +speech-dispatcher-0.6.7.ebuild:
+ Version bump.
17 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher b/app-accessibility/speech-dispatcher/files/speech-dispatcher
index cc8f8388b0d1..a17f2268bb7f 100644
--- a/app-accessibility/speech-dispatcher/files/speech-dispatcher
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher
@@ -1,10 +1,10 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/files/speech-dispatcher,v 1.3 2004/07/14 21:07:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/files/speech-dispatcher,v 1.4 2008/08/07 03:52:43 williamh Exp $
depend() {
- use alsasound esound festival speechd
+ use alsasound esound pulseaudio festival speechd
}
start() {
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
new file mode 100644
index 000000000000..3d8279a049f5
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.1 2008/08/07 03:52:42 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="alsa flite nas pulseaudio python"
+
+RDEPEND="dev-libs/dotconf
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( dev-lang/python )
+ app-accessibility/espeak"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' "${S}"/src/Makefile.in
+}
+
+src_compile() {
+ econf \
+ $(use_with alsa) \
+ $(use_with flite) \
+ $(use_with pulseaudio pulse) \
+ $(use_with nas) || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use python; then
+ cd "${S}"/src/python
+ ./setup.py install --root="${D}" --no-compile
+ cd "${S}"
+ fi
+
+ insinto /usr/include
+ doins "${S}"/src/c/api/libspeechd.h
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+ newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}