summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-19 04:59:19 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-19 04:59:19 +0000
commit67bc58859a3e8cf41e6903bcaa2fe002a3d24f70 (patch)
tree098469c142a4a3df8cb79b00967c1dab9a53e9b0 /app-accessibility
parentAdded ~alpha keyword wrt Bug #122204. (diff)
downloadgentoo-2-67bc58859a3e8cf41e6903bcaa2fe002a3d24f70.tar.gz
gentoo-2-67bc58859a3e8cf41e6903bcaa2fe002a3d24f70.tar.bz2
gentoo-2-67bc58859a3e8cf41e6903bcaa2fe002a3d24f70.zip
Version bump, resolves #137164 and #126619.
(Portage version: 2.1.1_pre1)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/sphinx2/ChangeLog11
-rw-r--r--app-accessibility/sphinx2/files/digest-sphinx2-0.63
-rw-r--r--app-accessibility/sphinx2/sphinx2-0.6.ebuild39
3 files changed, 51 insertions, 2 deletions
diff --git a/app-accessibility/sphinx2/ChangeLog b/app-accessibility/sphinx2/ChangeLog
index 43c86811422d..06dee3bfedf0 100644
--- a/app-accessibility/sphinx2/ChangeLog
+++ b/app-accessibility/sphinx2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/sphinx2
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/ChangeLog,v 1.11 2005/01/01 10:53:08 eradicator Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/ChangeLog,v 1.12 2006/06/19 04:59:19 squinky86 Exp $
+
+*sphinx2-0.6 (19 Jun 2006)
+
+ 19 Jun 2006; Jon Hood <squinky86@gentoo.org> +sphinx2-0.6.ebuild:
+ Version bump, #126619. Thanks to David Fannin <dfannin@sushisoft.com> for
+ the heads-up. This also resolves the gcc-4 issue #137164 reported by
+ Balint Dobai-Pataky <dpblnt@gmail.com>.
28 Nov 2004; Jeremy Huddleston <eradicator@gentoo.org> sphinx2-0.4.ebuild:
DESTDIR. Install documentation. USE=static support to toggle building static
diff --git a/app-accessibility/sphinx2/files/digest-sphinx2-0.6 b/app-accessibility/sphinx2/files/digest-sphinx2-0.6
new file mode 100644
index 000000000000..2b0c288f6bb1
--- /dev/null
+++ b/app-accessibility/sphinx2/files/digest-sphinx2-0.6
@@ -0,0 +1,3 @@
+MD5 5fcd8e3b6c21334866f07c601f36b37e sphinx2-0.6.tar.gz 6883359
+RMD160 7258a341d8ba26005a33c493bcf25b1f8dcf51ba sphinx2-0.6.tar.gz 6883359
+SHA256 af533d804906706eaeb80170b4222b293ed914b0b95b473334b5d2dba4bb0b65 sphinx2-0.6.tar.gz 6883359
diff --git a/app-accessibility/sphinx2/sphinx2-0.6.ebuild b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
new file mode 100644
index 000000000000..0786e0910b94
--- /dev/null
+++ b/app-accessibility/sphinx2/sphinx2-0.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/sphinx2/sphinx2-0.6.ebuild,v 1.1 2006/06/19 04:59:19 squinky86 Exp $
+
+IUSE="static"
+
+inherit gnuconfig
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="CMU Speech Recognition-engine"
+HOMEPAGE="http://fife.speech.cs.cmu.edu/sphinx/"
+SRC_URI="mirror://sourceforge/cmusphinx/${P}.tar.gz"
+
+LICENSE="BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use amd64 ; then
+ gnuconfig_update
+ fi
+}
+
+src_compile() {
+ econf $(use_enable static) || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README doc/README.bin doc/README.lib doc/SCHMM_format doc/filler.dict doc/phoneset doc/phoneset-old
+ dohtml doc/phoneset_s2.html doc/sphinx2.html
+}