summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-06-09 09:54:04 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2015-06-09 09:54:04 +0000
commit72eb37af41ecca852d30ccd5f19a78ae1c9a4061 (patch)
tree09d0028ad6287b63c17c36d8e185ea1c26fb28ad /app-accessibility
parentVersion bump for Gnome 3.16. (diff)
downloadgentoo-2-72eb37af41ecca852d30ccd5f19a78ae1c9a4061.tar.gz
gentoo-2-72eb37af41ecca852d30ccd5f19a78ae1c9a4061.tar.bz2
gentoo-2-72eb37af41ecca852d30ccd5f19a78ae1c9a4061.zip
Version bump for Gnome 3.16.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/ChangeLog7
-rw-r--r--app-accessibility/orca/orca-3.16.2.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index 1a86b6e38336..c6b05f64bcac 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.146 2015/03/28 10:10:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.147 2015/06/09 09:54:04 eva Exp $
+
+*orca-3.16.2 (09 Jun 2015)
+
+ 09 Jun 2015; Gilles Dartiguelongue <eva@gentoo.org> +orca-3.16.2.ebuild:
+ Version bump for Gnome 3.16.
*orca-3.14.4 (28 Mar 2015)
diff --git a/app-accessibility/orca/orca-3.16.2.ebuild b/app-accessibility/orca/orca-3.16.2.ebuild
new file mode 100644
index 000000000000..233379088a9e
--- /dev/null
+++ b/app-accessibility/orca/orca-3.16.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-3.16.2.ebuild,v 1.1 2015/06/09 09:54:04 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.10:2
+ >=app-accessibility/at-spi2-core-2.10:2[introspection]
+ >=dev-libs/atk-2.10
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ braille? (
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ dev-libs/atk[introspection]
+ dev-python/pyatspi[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_prepare() {
+ gnome2_src_prepare
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL="$(type -P true)" \
+ $(use_with braille liblouis)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ installing() {
+ gnome2_src_install
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
+ -i src/orca/orca || die
+ python_doscript src/orca/orca
+ }
+ python_foreach_impl run_in_build_dir installing
+}