summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2007-02-06 01:38:51 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2007-02-06 01:38:51 +0000
commit8160e5843c7e71bd90a4071e51fe1e2394fe65c4 (patch)
tree56476058858acd89dca215aa78ec042351b136ef /app-accessibility
parentRegenerate digest in Manifest2 format. (diff)
downloadgentoo-2-8160e5843c7e71bd90a4071e51fe1e2394fe65c4.tar.gz
gentoo-2-8160e5843c7e71bd90a4071e51fe1e2394fe65c4.tar.bz2
gentoo-2-8160e5843c7e71bd90a4071e51fe1e2394fe65c4.zip
Added patch to fix compilation if USE=-gnome and gnome-doc-utils is not installed (bug #165154)
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/dasher/ChangeLog7
-rw-r--r--app-accessibility/dasher/dasher-4.2.2.ebuild9
-rw-r--r--app-accessibility/dasher/files/dasher-4.2.2-gnome_help.patch32
3 files changed, 43 insertions, 5 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index 4dc40927566c..fae2c9ed4294 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.88 2007/02/04 09:02:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.89 2007/02/06 01:38:51 leonardop Exp $
+
+ 06 Feb 2007; Leonardo Boshell <leonardop@gentoo.org>
+ +files/dasher-4.2.2-gnome_help.patch, dasher-4.2.2.ebuild:
+ Added patch to fix compilation when USE=-gnome and gnome-doc-utils is not
+ installed in the system (bug #165154)..
04 Feb 2007; Markus Rothe <corsair@gentoo.org> dasher-4.2.2.ebuild:
Stable on ppc64; bug #164978
diff --git a/app-accessibility/dasher/dasher-4.2.2.ebuild b/app-accessibility/dasher/dasher-4.2.2.ebuild
index 1b39b3dfc5de..835a12be6a48 100644
--- a/app-accessibility/dasher/dasher-4.2.2.ebuild
+++ b/app-accessibility/dasher/dasher-4.2.2.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.2.2.ebuild,v 1.7 2007/02/04 09:02:38 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-4.2.2.ebuild,v 1.8 2007/02/06 01:38:51 leonardop Exp $
+WANT_AUTOCONF="2.5"
WANT_AUTOMAKE="1.8"
inherit autotools eutils gnome2
@@ -65,10 +66,10 @@ src_unpack() {
sed -i -e 's:gtk-update-icon-cache:true:' ./Data/Makefile.am
- epatch "${FILESDIR}"/${PN}-4.1.10-as-needed.patch
+ epatch "${FILESDIR}/${PN}-4.1.10-as-needed.patch"
- # Patch to fix compilation when USE=-gnome is used
- epatch "${FILESDIR}"/${PN}-4.2.1-sk_conditional_fix.patch
+ # Patch to fix compilation when USE=-gnome is used (bug #165154)
+ epatch "${FILESDIR}/${P}-gnome_help.patch"
eautoreconf
}
diff --git a/app-accessibility/dasher/files/dasher-4.2.2-gnome_help.patch b/app-accessibility/dasher/files/dasher-4.2.2-gnome_help.patch
new file mode 100644
index 000000000000..7be9882f5343
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-4.2.2-gnome_help.patch
@@ -0,0 +1,32 @@
+diff -NurdB dasher-4.2.2/Data/Help/Makefile.am dasher-4.2.2-patched/Data/Help/Makefile.am
+--- dasher-4.2.2/Data/Help/Makefile.am 2006-11-20 10:22:57.000000000 -0500
++++ dasher-4.2.2-patched/Data/Help/Makefile.am 2007-02-05 19:50:42.000000000 -0500
+@@ -1 +1,5 @@
+-SUBDIRS = Gnome
++SUBDIRS =
++
++if GNOME_HELP
++SUBDIRS += Gnome
++endif
+diff -NurdB dasher-4.2.2/configure.in dasher-4.2.2-patched/configure.in
+--- dasher-4.2.2/configure.in 2006-11-20 10:22:30.000000000 -0500
++++ dasher-4.2.2-patched/configure.in 2007-02-05 19:50:25.000000000 -0500
+@@ -293,6 +293,7 @@
+ AM_CONDITIONAL(DOQTE, test x$WITHQTE = xtrue)
+ AM_CONDITIONAL(GNOME_SPEECH, test x$WITHSPEECH = xtrue)
+ AM_CONDITIONAL(GNOME_A11Y, test x$WITHA11Y = xtrue)
++AM_CONDITIONAL(GNOME_HELP, test x$WITHGNOME = xtrue)
+ AM_CONDITIONAL(WITH_GPE, test x$WITHGPE = xtrue)
+ AM_CONDITIONAL(WITH_MAEMO, test x$WITHMAEMO = xtrue)
+ AM_CONDITIONAL(WITH_MAEMOFULLSCREEN, test x$WITHMAEMOFULLSCREEN = xtrue)
+@@ -325,7 +326,9 @@
+ AC_SUBST(GTK2BUILD_LIBS)
+
+ if [[ x"$WITHGNOME" = xtrue ]]; then
+-GNOME_DOC_INIT
++ GNOME_DOC_INIT
++else
++ AM_CONDITIONAL(ENABLE_SK, test "x$enable_scrollkeeper" = "xyes")
+ fi
+
+ AC_CONFIG_FILES([Makefile