summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-12-21 22:39:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-12-21 22:39:34 +0000
commita9dbe0418f10eba7317dbbee64b74211387ff1d5 (patch)
tree2790812897d881a36a3864d3ea87715a6f592ea6 /app-accessibility
parentarm stable, bug #394039 (diff)
downloadgentoo-2-a9dbe0418f10eba7317dbbee64b74211387ff1d5.tar.gz
gentoo-2-a9dbe0418f10eba7317dbbee64b74211387ff1d5.tar.bz2
gentoo-2-a9dbe0418f10eba7317dbbee64b74211387ff1d5.zip
Version bump.
(Portage version: 2.2.0_alpha80/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/ChangeLog7
-rw-r--r--app-accessibility/orca/orca-3.2.2.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index 7832d4cd8069..4890360d58e0 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.104 2011/11/05 05:14:38 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.105 2011/12/21 22:39:34 eva Exp $
+
+*orca-3.2.2 (21 Dec 2011)
+
+ 21 Dec 2011; Gilles Dartiguelongue <eva@gentoo.org> +orca-3.2.2.ebuild:
+ Version bump.
*orca-3.2.1 (05 Nov 2011)
diff --git a/app-accessibility/orca/orca-3.2.2.ebuild b/app-accessibility/orca/orca-3.2.2.ebuild
new file mode 100644
index 000000000000..05f424412c13
--- /dev/null
+++ b/app-accessibility/orca/orca-3.2.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-3.2.2.ebuild,v 1.1 2011/12/21 22:39:34 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="threads"
+# FIXME: multiple python support
+
+inherit gnome2 python
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="http://projects.gnome.org/orca/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+# XXX: Check deps for correctness
+COMMON_DEPEND=">=app-accessibility/at-spi2-core-2.1.5:2
+ >=dev-libs/glib-2.28:2
+ >=dev-python/pygobject-3.0.2:3
+ >=x11-libs/gtk+-3.1.13:3[introspection]"
+RDEPEND="${COMMON_DEPEND}
+ app-accessibility/speech-dispatcher
+ dev-libs/atk[introspection]
+ >=dev-python/dbus-python-0.83
+ dev-python/pyatspi
+ dev-python/pyxdg
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.17.3
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Workaround missing file in po files
+ echo "src/orca/scripts/toolkits/WebKitGtk/script.py" >> "${S}"/po/POTFILES.in
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize "${PN}"
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup "${PN}"
+}