summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-22 03:55:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-22 03:55:45 +0000
commit6387a2e9e68efae15e4143cb5e86a3d4f9b0b5d8 (patch)
treef16b9b20cb2950447fc9f3aa4a17143a57533bd1 /app-admin/apache-tools
parentversion bump (diff)
downloadgentoo-2-6387a2e9e68efae15e4143cb5e86a3d4f9b0b5d8.tar.gz
gentoo-2-6387a2e9e68efae15e4143cb5e86a3d4f9b0b5d8.tar.bz2
gentoo-2-6387a2e9e68efae15e4143cb5e86a3d4f9b0b5d8.zip
Bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin/apache-tools')
-rw-r--r--app-admin/apache-tools/ChangeLog7
-rw-r--r--app-admin/apache-tools/apache-tools-2.4.6.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index b55fe64d423e..be1ed0c2bf48 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.153 2013/07/18 13:26:11 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.154 2013/07/22 03:55:45 patrick Exp $
+
+*apache-tools-2.4.6 (22 Jul 2013)
+
+ 22 Jul 2013; Patrick Lauer <patrick@gentoo.org> +apache-tools-2.4.6.ebuild:
+ Bump
*apache-tools-2.2.25 (18 Jul 2013)
diff --git a/app-admin/apache-tools/apache-tools-2.4.6.ebuild b/app-admin/apache-tools/apache-tools-2.4.6.ebuild
new file mode 100644
index 000000000000..6e595c06a1e3
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.4.6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.4.6.ebuild,v 1.1 2013/07/22 03:55:45 patrick Exp $
+
+EAPI="3"
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc64-solaris ~x64-solaris"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_configure() {
+ local myconf=""
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ append-ldflags $(no-as-needed)
+
+ use ssl && myconf+=" --with-ssl=${EPREFIX}/usr --enable-ssl"
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+ econf \
+ --libexecdir=/usr/$(get_libdir)/apache2/modules \
+ --sbindir="${EPREFIX}"/usr/sbin \
+ --with-perl="${EPREFIX}"/usr/bin/perl \
+ --with-expat="${EPREFIX}"/usr \
+ --with-z="${EPREFIX}"/usr \
+ --with-apr="${EPREFIX}"/usr \
+ --with-apr-util="${EPREFIX}"/usr \
+ --with-pcre="${EPREFIX}"/usr \
+ ${myconf}
+}
+
+src_compile() {
+ cd support || die
+ emake
+}
+
+src_install () {
+ cd support || die
+
+ make DESTDIR="${D}" install
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm,ab,logresolve}.1 \
+ "${S}"/docs/man/{htcacheclean,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+ pushd "${ED}"/usr/sbin/ >/dev/null
+ for i in *; do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+ popd "${ED}"/usr/sbin/ >/dev/null
+
+ # Provide a symlink for ab-ssl
+ if use ssl; then
+ dosym /usr/bin/ab /usr/bin/ab-ssl
+ dosym /usr/bin/ab /usr/bin/ab2-ssl
+ fi
+
+ dodoc "${S}"/CHANGES
+}