summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Holland <tigger@gentoo.org>2004-07-15 20:32:50 +0000
committerRob Holland <tigger@gentoo.org>2004-07-15 20:32:50 +0000
commite6ec407d5102e656cfc5ceab9ff08e17990baa24 (patch)
treeb178a16afdc7de94b324fa30b76e134c3aa9b0b8 /app-admin/apachetop
parentRemoved old versions (Manifest recommit) (diff)
downloadgentoo-2-e6ec407d5102e656cfc5ceab9ff08e17990baa24.tar.gz
gentoo-2-e6ec407d5102e656cfc5ceab9ff08e17990baa24.tar.bz2
gentoo-2-e6ec407d5102e656cfc5ceab9ff08e17990baa24.zip
Fix DEPEND/RDEPENDs. Should close #56756. Thanks to wood-worker@gmx.net for reporting the issue.
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/ChangeLog6
-rw-r--r--app-admin/apachetop/apachetop-0.12.ebuild16
2 files changed, 14 insertions, 8 deletions
diff --git a/app-admin/apachetop/ChangeLog b/app-admin/apachetop/ChangeLog
index 15c6d2cbd888..99bc5d7f869d 100644
--- a/app-admin/apachetop/ChangeLog
+++ b/app-admin/apachetop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/apachetop
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/ChangeLog,v 1.16 2004/07/09 19:42:16 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/ChangeLog,v 1.17 2004/07/15 20:32:50 tigger Exp $
+
+ 15 Jul 2004; Rob Holland <tigger@ereet.co.uk> apachetop-0.12.ebuild:
+ Fix DEPEND/RDEPENDs. Should close #56756. Thanks to wood-worker@gmx.net for
+ reporting the issue.
09 Jul 2004; Stuart Herbert <stuart@gentoo.org> apachetop-0.11.ebuild,
apachetop-0.12.ebuild:
diff --git a/app-admin/apachetop/apachetop-0.12.ebuild b/app-admin/apachetop/apachetop-0.12.ebuild
index f058441c029b..6950db4cbc15 100644
--- a/app-admin/apachetop/apachetop-0.12.ebuild
+++ b/app-admin/apachetop/apachetop-0.12.ebuild
@@ -1,21 +1,21 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.5 2004/07/09 19:42:16 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.ebuild,v 1.6 2004/07/15 20:32:50 tigger Exp $
DESCRIPTION="A realtime Apache log analyzer"
HOMEPAGE="http://clueful.shagged.org/apachetop/"
SRC_URI="http://clueful.shagged.org/apachetop/files/${P}.tar.gz"
-IUSE="apache2"
+IUSE="apache2 fam pcre"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ~sparc ~mips"
-DEPEND="!apache2? ( >=net-www/apache-1.3.28 )
- apache2? ( >=net-www/apache-2.0.47 )
- sys-apps/sed
- sys-libs/libtermcap-compat"
+DEPEND="sys-apps/sed"
+RDEPEND="sys-libs/libtermcap-compat
+ fam? ( app-admin/fam )
+ pcre? ( dev-libs/libpcre )"
src_compile() {
if use apache2
@@ -24,7 +24,9 @@ src_compile() {
else
sed -i 's%DEFAULT_LOGFILE "/var/httpd/apache_log"%DEFAULT_LOGFILE "/var/log/apache/access_log"%' src/apachetop.h
fi
- ./configure
+ local myconf
+ myconf="${myconf} $(use_with fam) $(use_with pcre)"
+ econf ${myconf}
emake || die
}