summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-01-01 15:47:49 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-01-01 15:47:49 +0000
commitc2ffe287382ecc5ee411ac50a74457a76ae16f07 (patch)
tree51307bcb7fb3147af09ba574ab21c6ab982cfc53 /app-admin/augeas/augeas-0.7.4.ebuild
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #348269 (diff)
downloadgentoo-2-c2ffe287382ecc5ee411ac50a74457a76ae16f07.tar.gz
gentoo-2-c2ffe287382ecc5ee411ac50a74457a76ae16f07.tar.bz2
gentoo-2-c2ffe287382ecc5ee411ac50a74457a76ae16f07.zip
Version bumped, bug #346829.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/augeas/augeas-0.7.4.ebuild')
-rw-r--r--app-admin/augeas/augeas-0.7.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/augeas/augeas-0.7.4.ebuild b/app-admin/augeas/augeas-0.7.4.ebuild
new file mode 100644
index 000000000000..485b1e84f349
--- /dev/null
+++ b/app-admin/augeas/augeas-0.7.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-0.7.4.ebuild,v 1.1 2011/01/01 15:47:49 matsuu Exp $
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/readline"
+DEPEND="${RDEPEND}
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+src_compile() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog README NEWS
+}