summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 17:39:58 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 17:39:58 +0000
commitde8fb320e5d53d57a9b877be9ad81d8a46a50fcf (patch)
tree47eb149d07b7a50ad42875ef973e9a76d02609e3 /app-admin/ide-smart
parentAdded CAN-2004-0495 and CAN-2004-0535 security fixes (Manifest recommit) (diff)
downloadgentoo-2-de8fb320e5d53d57a9b877be9ad81d8a46a50fcf.tar.gz
gentoo-2-de8fb320e5d53d57a9b877be9ad81d8a46a50fcf.tar.bz2
gentoo-2-de8fb320e5d53d57a9b877be9ad81d8a46a50fcf.zip
glibc ----------------------------> libc !
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4.ebuild b/app-admin/ide-smart/ide-smart-1.4.ebuild
index 368d9c219da1..0316b9bf7a33 100644
--- a/app-admin/ide-smart/ide-smart-1.4.ebuild
+++ b/app-admin/ide-smart/ide-smart-1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ide-smart-1.4.ebuild,v 1.19 2004/06/24 21:29:17 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ide-smart/ide-smart-1.4.ebuild,v 1.20 2004/06/25 17:39:58 vapier Exp $
+
+inherit gcc
DESCRIPTION="A tool to read SMART information from harddiscs"
HOMEPAGE="http://lightside.eresmas.com/"
@@ -11,18 +13,12 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/glibc"
-
-src_unpack() {
- unpack ${A} ; cd ${S}
- rm ide-smart ide-smart.o
- sed -i -e "s:^CFLAGS.*:CFLAGS = ${CFLAGS}:" \
- -e "s:^#CC.*:CC = gcc:" \
- Makefile
-}
+DEPEND="virtual/libc"
src_compile() {
- emake || die
+ emake \
+ CC="$(gcc-getCC)" PROF="${CFLAGS}" \
+ clean all || die
}
src_install() {