summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2015-03-14 18:57:43 +0000
committerJeff Horelick <jdhore@gentoo.org>2015-03-14 18:57:43 +0000
commit2d7c544a28d4ca05c173cc4374cbd356b08fb100 (patch)
tree3dd78c37d5e7bf3ee14ccb1141e7e6fce1f212ed /app-admin/lastpass-cli
parentamd64 stable, bug 534012 (diff)
downloadgentoo-2-2d7c544a28d4ca05c173cc4374cbd356b08fb100.tar.gz
gentoo-2-2d7c544a28d4ca05c173cc4374cbd356b08fb100.tar.bz2
gentoo-2-2d7c544a28d4ca05c173cc4374cbd356b08fb100.zip
Version bump
(Portage version: 2.2.18/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'app-admin/lastpass-cli')
-rw-r--r--app-admin/lastpass-cli/ChangeLog9
-rw-r--r--app-admin/lastpass-cli/lastpass-cli-0.5.0.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-admin/lastpass-cli/ChangeLog b/app-admin/lastpass-cli/ChangeLog
index 0da800c5c501..69f77ac998cd 100644
--- a/app-admin/lastpass-cli/ChangeLog
+++ b/app-admin/lastpass-cli/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/lastpass-cli
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/lastpass-cli/ChangeLog,v 1.4 2014/10/23 18:10:37 zx2c4 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lastpass-cli/ChangeLog,v 1.5 2015/03/14 18:57:43 jdhore Exp $
+
+*lastpass-cli-0.5.0 (14 Mar 2015)
+
+ 14 Mar 2015; Jeff Horelick <jdhore@gentoo.org> +lastpass-cli-0.5.0.ebuild:
+ Version bump
23 Oct 2014; Jason A. Donenfeld <zx2c4@gentoo.org> metadata.xml:
Pass maintainership onto Jeff
diff --git a/app-admin/lastpass-cli/lastpass-cli-0.5.0.ebuild b/app-admin/lastpass-cli/lastpass-cli-0.5.0.ebuild
new file mode 100644
index 000000000000..737f7091a8d8
--- /dev/null
+++ b/app-admin/lastpass-cli/lastpass-cli-0.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lastpass-cli/lastpass-cli-0.5.0.ebuild,v 1.1 2015/03/14 18:57:43 jdhore Exp $
+
+EAPI=5
+
+DESCRIPTION="Interfaces with LastPass.com from the command line."
+SRC_URI="https://github.com/lastpass/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/lastpass/lastpass-cli"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +pinentry"
+
+RDEPEND="
+ X? ( || ( x11-misc/xclip x11-misc/xsel ) )
+ dev-libs/openssl:0
+ net-misc/curl
+ dev-libs/libxml2
+ pinentry? ( app-crypt/pinentry )
+"
+DEPEND="${RDEPEND} app-text/asciidoc"
+
+src_prepare() {
+ sed -i 's/install -s/install/' Makefile || die "Could not remove stripping"
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}/usr"
+ emake PREFIX="${EPREFIX}/usr" doc-man
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install-doc
+}