summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-22 18:43:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-22 18:43:47 +0000
commit013dce10a417e3b51533298c358a8e504a028e13 (patch)
treebfabf9760223465db073c27c5a538b2258234d4f /app-admin/packagekit-base
parentold (diff)
downloadgentoo-2-013dce10a417e3b51533298c358a8e504a028e13.tar.gz
gentoo-2-013dce10a417e3b51533298c358a8e504a028e13.tar.bz2
gentoo-2-013dce10a417e3b51533298c358a8e504a028e13.zip
old
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/packagekit-base')
-rw-r--r--app-admin/packagekit-base/ChangeLog9
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-0.6.17-entropy-extra-downloads-support.patch41
-rw-r--r--app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch94
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.6.16.ebuild173
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.6.17-r1.ebuild177
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild180
-rw-r--r--app-admin/packagekit-base/packagekit-base-0.6.19.ebuild182
7 files changed, 8 insertions, 848 deletions
diff --git a/app-admin/packagekit-base/ChangeLog b/app-admin/packagekit-base/ChangeLog
index 5ad3bfafa479..44ea38ed6844 100644
--- a/app-admin/packagekit-base/ChangeLog
+++ b/app-admin/packagekit-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/packagekit-base
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/ChangeLog,v 1.15 2012/03/14 23:43:58 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/ChangeLog,v 1.16 2012/04/22 18:43:47 ssuominen Exp $
+
+ 22 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ -packagekit-base-0.6.16.ebuild, -packagekit-base-0.6.17-r1.ebuild,
+ -files/packagekit-base-0.6.17-entropy-extra-downloads-support.patch,
+ -packagekit-base-0.6.18-r1.ebuild, -packagekit-base-0.6.19.ebuild,
+ -files/packagekit-base-entropy-add-forward-compatibility.patch:
+ old
14 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
Punt useless USE description(s) for USE="static-libs" and USE="udev"
diff --git a/app-admin/packagekit-base/files/packagekit-base-0.6.17-entropy-extra-downloads-support.patch b/app-admin/packagekit-base/files/packagekit-base-0.6.17-entropy-extra-downloads-support.patch
deleted file mode 100644
index 2b4030602f6e..000000000000
--- a/app-admin/packagekit-base/files/packagekit-base-0.6.17-entropy-extra-downloads-support.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-commit 5d6419ac83883e4d2161032f65d565df8eb007ac
-Author: Fabio Erculiani <lxnay@sabayon.org>
-Date: Tue Aug 9 12:48:16 2011 +0200
-
- entropy: properly account package size when "extra" downloads are available
-
-diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
-index 02b83a7..fe8c609 100755
---- a/backends/entropy/entropyBackend.py
-+++ b/backends/entropy/entropyBackend.py
-@@ -244,10 +244,28 @@ class PackageKitEntropyMixin(object):
- packages, the on-disk size is returned instead.
- """
- pkg_id, c_repo = pkg_match
-+ size = 0
- if c_repo is self._entropy.installed_repository():
-- return c_repo.retrieveOnDiskSize(pkg_id)
-+ size += c_repo.retrieveOnDiskSize(pkg_id)
- else:
-- return c_repo.retrieveSize(pkg_id)
-+ size += c_repo.retrieveSize(pkg_id)
-+
-+ supports_extra_download = hasattr(c_repo, "retrieveExtraDownload")
-+ if not supports_extra_download:
-+ return size
-+
-+ cl_id = etpConst['system_settings_plugins_ids']['client_plugin']
-+ debug = self._settings[cl_id]['misc']['splitdebug']
-+ extra_downloads = c_repo.retrieveExtraDownload(pkg_id)
-+ for extra_download in extra_downloads:
-+ if (not debug) and (extra_download['type'] == "debug") and \
-+ (c_repo is not self._entropy.installed_repository()):
-+ continue
-+ if c_repo is self._entropy.installed_repository():
-+ size += extra_download['disksize']
-+ else:
-+ size += extra_download['size']
-+ return size
-
- def _pk_feed_sorted_pkgs(self, pkgs):
- """
diff --git a/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch b/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch
deleted file mode 100644
index 354fca6fbcbc..000000000000
--- a/app-admin/packagekit-base/files/packagekit-base-entropy-add-forward-compatibility.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-commit d8c13d8c3e875bf1d87650646cb960a87468ba87
-Author: Fabio Erculiani <lxnay@sabayon.org>
-Date: Wed Oct 5 22:39:30 2011 +0200
-
- entropy: add forward compatibility with upcoming API changes
-
-diff --git a/backends/entropy/entropyBackend.py b/backends/entropy/entropyBackend.py
-index fe8c609..0c82039 100755
---- a/backends/entropy/entropyBackend.py
-+++ b/backends/entropy/entropyBackend.py
-@@ -64,7 +64,8 @@ from entropy.client.interfaces import Client
- from entropy.core.settings.base import SystemSettings
- from entropy.misc import LogFile
- from entropy.cache import EntropyCacher
--from entropy.exceptions import SystemDatabaseError
-+from entropy.exceptions import SystemDatabaseError, DependenciesNotFound, \
-+ DependenciesCollision
- from entropy.db.exceptions import Error as EntropyRepositoryError
- try:
- from entropy.exceptions import DependenciesNotRemovable
-@@ -589,18 +590,32 @@ class PackageKitEntropyMixin(object):
- if calculate_deps:
- self.status(STATUS_DEP_RESOLVE)
- empty_deps, deep_deps = False, False
-- run_queue, removal_queue, status = self._entropy.get_install_queue(
-- matches, empty_deps, deep_deps)
-+ try:
-+ queue_obj = self._entropy.get_install_queue(
-+ matches, empty_deps, deep_deps)
-+ if len(queue_obj) == 2:
-+ # new api
-+ run_queue, removal_queue = queue_obj
-+ else:
-+ # old api
-+ run_queue, removal_queue, status = queue_obj
-+ if status == -2:
-+ raise DependenciesNotFound(run_queue)
-+ elif status == -3:
-+ raise DependenciesCollision(run_queue)
-+ except DependenciesNotFound as exc:
-+ self.error(ERROR_DEP_RESOLUTION_FAILED,
-+ "Cannot find the following dependencies: %s" % (
-+ ', '.join(sorted(exc.value)),))
-+ return
-+ except DependenciesCollision:
-+ self.error(ERROR_DEP_RESOLUTION_FAILED,
-+ "Dependencies collisions, cannot continue")
-+ return
-+
- else:
- run_queue = matches
- removal_queue = []
-- status = 0
--
-- if status == -2:
-- self.error(ERROR_DEP_RESOLUTION_FAILED,
-- "Cannot find the following dependencies: %s" % (
-- ', '.join(run_queue),))
-- return
-
- self.percentage(0)
- self.status(STATUS_DOWNLOAD)
-@@ -934,12 +949,26 @@ class PackageKitEntropyBackend(PackageKitBaseBackend, PackageKitEntropyMixin):
-
- empty = False
- deep = False
-- install, removal, deps_not_f = self._entropy.get_install_queue(matches,
-- empty, deep, recursive = recursive)
--
-- if deps_not_f == -2:
-+ try:
-+ queue_obj = self._entropy.get_install_queue(matches,
-+ empty, deep, recursive = recursive)
-+ if len(queue_obj) == 2:
-+ # new api
-+ install, removal = queue_obj
-+ else:
-+ # old api
-+ install, removal, status = queue_obj
-+ if status == -2:
-+ raise DependenciesNotFound(install)
-+ elif status == -3:
-+ raise DependenciesCollision(install)
-+ except DependenciesNotFound as exc:
-+ self.error(ERROR_DEP_RESOLUTION_FAILED,
-+ "Dependencies not found: %s" % (sorted(exc.value),))
-+ return
-+ except DependenciesCollision:
- self.error(ERROR_DEP_RESOLUTION_FAILED,
-- "Dependencies not found: %s" % (sorted(install),))
-+ "Dependencies collisions, cannot continue")
- return
-
- # transform install into (repo, pkg_id, c_repo) list
diff --git a/app-admin/packagekit-base/packagekit-base-0.6.16.ebuild b/app-admin/packagekit-base/packagekit-base-0.6.16.ebuild
deleted file mode 100644
index 8c12cf3c0349..000000000000
--- a/app-admin/packagekit-base/packagekit-base-0.6.16.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.16.ebuild,v 1.1 2011/07/19 19:12:59 lxnay Exp $
-
-EAPI="3"
-
-inherit eutils multilib python nsplugins bash-completion
-
-MY_PN="PackageKit"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
-HOMEPAGE="http://www.packagekit.org/"
-SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="connman cron doc +introspection networkmanager nsplugin pm-utils +policykit entropy static-libs test udev"
-
-CDEPEND="connman? ( net-misc/connman )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- networkmanager? ( >=net-misc/networkmanager-0.6.4 )
- nsplugin? (
- dev-libs/nspr
- x11-libs/cairo
- >=x11-libs/gtk+-2.14.0:2
- x11-libs/pango
- )
- policykit? ( >=sys-auth/polkit-0.94 )
- udev? ( || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
- dev-db/sqlite:3
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.16.1:2
- >=sys-apps/dbus-1.3.0"
-DEPEND="${CDEPEND}
- doc? ( dev-util/gtk-doc )
- nsplugin? ( >=net-libs/xulrunner-1.9.1 )
- dev-libs/libxslt
- >=dev-util/intltool-0.35.0
- dev-util/pkgconfig
- sys-devel/gettext"
-
-RDEPEND="${CDEPEND}
- entropy? ( >=sys-apps/entropy-1.0_rc27 )
- pm-utils? ( sys-power/pm-utils )
- >=app-portage/layman-1.2.3
- >=sys-apps/portage-2.1.9
- sys-auth/consolekit"
-
-APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
-ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
-for X in ${APP_LINGUAS}; do
- IUSE=" ${IUSE} linguas_${X}"
-done
-
-S="${WORKDIR}/${MY_P}"
-RESTRICT="test" # tests are failing atm
-
-# NOTES:
-# do not use a specific user, useless and not more secure according to upstream
-# doc is in the tarball and always installed
-# mono doesn't install anything (RDEPEND dev-dotnet/gtk-sharp-gapi:2
-# (R)DEPEND dev-dotnet/glib-sharp:2 dev-lang/mono), upstream bug 23247
-
-# UPSTREAM:
-# documentation/website with --enable-doc-install
-# failing tests
-
-src_configure() {
- local myconf=""
-
- if use policykit; then
- myconf+=" --with-security-framework=polkit"
- else
- myconf+=" --with-security-framework=dummy"
- fi
-
- if [[ -z "${LINGUAS}" ]]; then
- myconf+=" --disable-nls"
- else
- myconf+=" --enable-nls"
- fi
-
- # localstatedir: for gentoo it's /var/lib but for $PN it's /var
- # dep-tracking,option-check,libtool-lock,strict,local: obvious reasons
- # command,debuginfo,gstreamer,service-packs: not supported by backend
-
- # NOTE: default backend is autodetected at runtime, also
- if use entropy; then
- myconf+=" --with-default-backend=entropy"
- else
- myconf+=" --with-default-backend=portage"
- fi
- econf \
- ${myconf} \
- --enable-introspection=no \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --enable-option-checking \
- --enable-libtool-lock \
- --disable-strict \
- --disable-local \
- $(use_enable doc gtk-doc) \
- $(use_enable bash-completion command-not-found) \
- --disable-debuginfo-install \
- --disable-gstreamer-plugin \
- --disable-service-packs \
- --enable-man-pages \
- --enable-portage \
- $(use_enable entropy) \
- $(use_enable cron) \
- --disable-gtk-module \
- $(use_enable introspection) \
- $(use_enable networkmanager) \
- $(use_enable nsplugin browser-plugin) \
- $(use_enable pm-utils) \
- --disable-qt \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
- $(use_enable udev device-rebind)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
- dodoc ChangeLog || die "dodoc failed"
-
- if use nsplugin; then
- src_mv_plugins /usr/$(get_libdir)/mozilla/plugins
- fi
-
- if ! use static-libs; then
- find "${D}" -name *.la | xargs rm || die "removing .la files failed"
- fi
-
- # Remove precompiled python modules, we handle byte compiling
- rm -f "${D}/$(python_get_sitedir)"/${PN}*.py[co]
-
- dobashcompletion "${S}/contrib/pk-completion.bash" ${PN}
- # Remove bashcomp file installed by build-system
- rm -f "${D}/bash_completion.d/pk-completion.bash"
-
- # Remove unwanted PackageKit website stuff
- rm -rf "${D}/usr/share/PackageKit/website"
-
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN/-base}
-
- if ! use policykit; then
- ewarn "You are not using policykit, the daemon can't be considered as secure."
- ewarn "All users will be able to do anything through ${MY_PN}."
- ewarn "Please, consider rebuilding ${MY_PN} with policykit USE flag."
- ewarn "THIS IS A SECURITY ISSUE."
- echo
- ebeep
- epause 5
- fi
- bash-completion_pkg_postinst
-}
-
-pkg_prerm() {
- einfo "Removing downloaded files with ${MY_PN}..."
- [[ -d "${ROOT}"/var/cache/${MY_PN}/downloads/ ]] && \
- rm -rf /var/cache/PackageKit/downloads/*
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN/-base}
-}
diff --git a/app-admin/packagekit-base/packagekit-base-0.6.17-r1.ebuild b/app-admin/packagekit-base/packagekit-base-0.6.17-r1.ebuild
deleted file mode 100644
index 535577796257..000000000000
--- a/app-admin/packagekit-base/packagekit-base-0.6.17-r1.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.17-r1.ebuild,v 1.2 2011/09/05 19:45:38 maekke Exp $
-
-EAPI="3"
-
-inherit eutils multilib python nsplugins bash-completion
-
-MY_PN="PackageKit"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
-HOMEPAGE="http://www.packagekit.org/"
-SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="connman cron doc +introspection networkmanager nsplugin pm-utils +policykit entropy static-libs test udev"
-
-CDEPEND="connman? ( net-misc/connman )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- networkmanager? ( >=net-misc/networkmanager-0.6.4 )
- nsplugin? (
- dev-libs/nspr
- x11-libs/cairo
- >=x11-libs/gtk+-2.14.0:2
- x11-libs/pango
- )
- policykit? ( >=sys-auth/polkit-0.94 )
- udev? ( || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
- dev-db/sqlite:3
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.16.1:2
- >=sys-apps/dbus-1.3.0"
-DEPEND="${CDEPEND}
- doc? ( dev-util/gtk-doc )
- nsplugin? ( >=net-libs/xulrunner-1.9.1 )
- dev-libs/libxslt
- >=dev-util/intltool-0.35.0
- dev-util/pkgconfig
- sys-devel/gettext"
-
-RDEPEND="${CDEPEND}
- entropy? ( >=sys-apps/entropy-1.0_rc27 )
- pm-utils? ( sys-power/pm-utils )
- >=app-portage/layman-1.2.3
- >=sys-apps/portage-2.1.9
- sys-auth/consolekit"
-
-APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
-ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
-for X in ${APP_LINGUAS}; do
- IUSE=" ${IUSE} linguas_${X}"
-done
-
-S="${WORKDIR}/${MY_P}"
-RESTRICT="test" # tests are failing atm
-
-# NOTES:
-# do not use a specific user, useless and not more secure according to upstream
-# doc is in the tarball and always installed
-# mono doesn't install anything (RDEPEND dev-dotnet/gtk-sharp-gapi:2
-# (R)DEPEND dev-dotnet/glib-sharp:2 dev-lang/mono), upstream bug 23247
-
-# UPSTREAM:
-# documentation/website with --enable-doc-install
-# failing tests
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-entropy-extra-downloads-support.patch"
-}
-
-src_configure() {
- local myconf=""
-
- if use policykit; then
- myconf+=" --with-security-framework=polkit"
- else
- myconf+=" --with-security-framework=dummy"
- fi
-
- if [[ -z "${LINGUAS}" ]]; then
- myconf+=" --disable-nls"
- else
- myconf+=" --enable-nls"
- fi
-
- # localstatedir: for gentoo it's /var/lib but for $PN it's /var
- # dep-tracking,option-check,libtool-lock,strict,local: obvious reasons
- # command,debuginfo,gstreamer,service-packs: not supported by backend
-
- # NOTE: default backend is autodetected at runtime, also
- if use entropy; then
- myconf+=" --with-default-backend=entropy"
- else
- myconf+=" --with-default-backend=portage"
- fi
- econf \
- ${myconf} \
- --enable-introspection=no \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --enable-option-checking \
- --enable-libtool-lock \
- --disable-strict \
- --disable-local \
- $(use_enable doc gtk-doc) \
- $(use_enable bash-completion command-not-found) \
- --disable-debuginfo-install \
- --disable-gstreamer-plugin \
- --disable-service-packs \
- --enable-man-pages \
- --enable-portage \
- $(use_enable entropy) \
- $(use_enable cron) \
- --disable-gtk-module \
- $(use_enable introspection) \
- $(use_enable networkmanager) \
- $(use_enable nsplugin browser-plugin) \
- $(use_enable pm-utils) \
- --disable-qt \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
- $(use_enable udev device-rebind)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
- dodoc ChangeLog || die "dodoc failed"
-
- if use nsplugin; then
- src_mv_plugins /usr/$(get_libdir)/mozilla/plugins
- fi
-
- if ! use static-libs; then
- find "${D}" -name *.la | xargs rm || die "removing .la files failed"
- fi
-
- # Remove precompiled python modules, we handle byte compiling
- rm -f "${D}/$(python_get_sitedir)"/${PN}*.py[co]
-
- dobashcompletion "${S}/contrib/pk-completion.bash" ${PN}
- # Remove bashcomp file installed by build-system
- rm -f "${D}/bash_completion.d/pk-completion.bash"
-
- # Remove unwanted PackageKit website stuff
- rm -rf "${D}/usr/share/PackageKit/website"
-
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN/-base}
-
- if ! use policykit; then
- ewarn "You are not using policykit, the daemon can't be considered as secure."
- ewarn "All users will be able to do anything through ${MY_PN}."
- ewarn "Please, consider rebuilding ${MY_PN} with policykit USE flag."
- ewarn "THIS IS A SECURITY ISSUE."
- echo
- ebeep
- epause 5
- fi
- bash-completion_pkg_postinst
-}
-
-pkg_prerm() {
- einfo "Removing downloaded files with ${MY_PN}..."
- [[ -d "${ROOT}"/var/cache/${MY_PN}/downloads/ ]] && \
- rm -rf /var/cache/PackageKit/downloads/*
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN/-base}
-}
diff --git a/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild b/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild
deleted file mode 100644
index 0f6f223b58cc..000000000000
--- a/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild
+++ /dev/null
@@ -1,180 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.18-r1.ebuild,v 1.1 2011/10/05 20:41:49 lxnay Exp $
-
-EAPI="3"
-
-inherit eutils multilib python nsplugins bash-completion
-
-MY_PN="PackageKit"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
-HOMEPAGE="http://www.packagekit.org/"
-SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="connman cron doc +introspection networkmanager nsplugin pm-utils +policykit entropy static-libs test udev"
-
-CDEPEND="connman? ( net-misc/connman )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- networkmanager? ( >=net-misc/networkmanager-0.6.4 )
- nsplugin? (
- dev-libs/nspr
- x11-libs/cairo
- >=x11-libs/gtk+-2.14.0:2
- x11-libs/pango
- )
- policykit? ( >=sys-auth/polkit-0.94 )
- udev? ( || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
- dev-db/sqlite:3
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.16.1:2
- >=sys-apps/dbus-1.3.0"
-DEPEND="${CDEPEND}
- doc? ( dev-util/gtk-doc )
- nsplugin? ( >=net-libs/xulrunner-1.9.1 )
- dev-libs/libxslt
- >=dev-util/intltool-0.35.0
- dev-util/pkgconfig
- sys-devel/gettext"
-
-RDEPEND="${CDEPEND}
- entropy? ( >=sys-apps/entropy-1.0_rc27 )
- pm-utils? ( sys-power/pm-utils )
- >=app-portage/layman-1.2.3
- >=sys-apps/portage-2.1.9
- sys-auth/consolekit"
-
-APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
-ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
-for X in ${APP_LINGUAS}; do
- IUSE=" ${IUSE} linguas_${X}"
-done
-
-S="${WORKDIR}/${MY_P}"
-RESTRICT="test" # tests are failing atm
-
-# NOTES:
-# do not use a specific user, useless and not more secure according to upstream
-# doc is in the tarball and always installed
-# mono doesn't install anything (RDEPEND dev-dotnet/gtk-sharp-gapi:2
-# (R)DEPEND dev-dotnet/glib-sharp:2 dev-lang/mono), upstream bug 23247
-
-# UPSTREAM:
-# documentation/website with --enable-doc-install
-# failing tests
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.6.17-entropy-extra-downloads-support.patch"
- epatch "${FILESDIR}/${PN}-entropy-add-forward-compatibility.patch"
-}
-
-src_configure() {
- local myconf=""
-
- if use policykit; then
- myconf+=" --with-security-framework=polkit"
- else
- myconf+=" --with-security-framework=dummy"
- fi
-
- if [[ -z "${LINGUAS}" ]]; then
- myconf+=" --disable-nls"
- else
- myconf+=" --enable-nls"
- fi
-
- # localstatedir: for gentoo it's /var/lib but for $PN it's /var
- # dep-tracking,option-check,libtool-lock,strict,local: obvious reasons
- # command,debuginfo,gstreamer,service-packs: not supported by backend
-
- # NOTE: default backend is autodetected at runtime, also
- if use entropy; then
- myconf+=" --with-default-backend=entropy"
- else
- myconf+=" --with-default-backend=portage"
- fi
- econf \
- ${myconf} \
- --enable-introspection=no \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --enable-option-checking \
- --enable-libtool-lock \
- --disable-strict \
- --disable-local \
- $(use_enable doc gtk-doc) \
- $(use_enable bash-completion command-not-found) \
- --disable-debuginfo-install \
- --disable-gstreamer-plugin \
- --disable-service-packs \
- --enable-man-pages \
- --enable-portage \
- $(use_enable entropy) \
- $(use_enable cron) \
- --disable-gtk-module \
- $(use_enable introspection) \
- $(use_enable networkmanager) \
- $(use_enable nsplugin browser-plugin) \
- $(use_enable pm-utils) \
- --disable-qt \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
- $(use_enable udev device-rebind)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
- dodoc ChangeLog || die "dodoc failed"
-
- if use nsplugin; then
- dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
- mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
- "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
- fi
-
- if ! use static-libs; then
- find "${D}" -name *.la | xargs rm || die "removing .la files failed"
- fi
-
- # Remove precompiled python modules, we handle byte compiling
- rm -f "${D}/$(python_get_sitedir)"/${PN}*.py[co]
-
- dobashcompletion "${S}/contrib/pk-completion.bash" ${PN}
- # Remove bashcomp file installed by build-system
- rm -f "${D}/bash_completion.d/pk-completion.bash"
-
- # Remove unwanted PackageKit website stuff
- rm -rf "${D}/usr/share/PackageKit/website"
-
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN/-base}
-
- if ! use policykit; then
- ewarn "You are not using policykit, the daemon can't be considered as secure."
- ewarn "All users will be able to do anything through ${MY_PN}."
- ewarn "Please, consider rebuilding ${MY_PN} with policykit USE flag."
- ewarn "THIS IS A SECURITY ISSUE."
- echo
- ebeep
- epause 5
- fi
- bash-completion_pkg_postinst
-}
-
-pkg_prerm() {
- einfo "Removing downloaded files with ${MY_PN}..."
- [[ -d "${ROOT}"/var/cache/${MY_PN}/downloads/ ]] && \
- rm -rf /var/cache/PackageKit/downloads/*
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN/-base}
-}
diff --git a/app-admin/packagekit-base/packagekit-base-0.6.19.ebuild b/app-admin/packagekit-base/packagekit-base-0.6.19.ebuild
deleted file mode 100644
index 41365f8ec60a..000000000000
--- a/app-admin/packagekit-base/packagekit-base-0.6.19.ebuild
+++ /dev/null
@@ -1,182 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/packagekit-base/packagekit-base-0.6.19.ebuild,v 1.2 2011/10/25 15:09:06 jer Exp $
-
-EAPI="3"
-
-# 0.6.x doesn't work with Python 3.x
-PYTHON_DEPEND="2"
-
-inherit eutils multilib python nsplugins bash-completion
-
-MY_PN="PackageKit"
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Manage packages in a secure way using a cross-distro and cross-architecture API"
-HOMEPAGE="http://www.packagekit.org/"
-SRC_URI="http://www.packagekit.org/releases/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~x86"
-IUSE="connman cron doc +introspection networkmanager nsplugin pm-utils +policykit entropy static-libs test udev"
-
-CDEPEND="connman? ( net-misc/connman )
- introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
- networkmanager? ( >=net-misc/networkmanager-0.6.4 )
- nsplugin? (
- dev-libs/nspr
- x11-libs/cairo
- >=x11-libs/gtk+-2.14.0:2
- x11-libs/pango
- )
- policykit? ( >=sys-auth/polkit-0.94 )
- udev? ( || ( >=sys-fs/udev-171[gudev] >=sys-fs/udev-145[extras] ) )
- dev-db/sqlite:3
- >=dev-libs/dbus-glib-0.74
- >=dev-libs/glib-2.16.1:2
- >=sys-apps/dbus-1.3.0"
-DEPEND="${CDEPEND}
- doc? ( dev-util/gtk-doc )
- nsplugin? ( >=net-libs/xulrunner-1.9.1 )
- dev-libs/libxslt
- >=dev-util/intltool-0.35.0
- dev-util/pkgconfig
- sys-devel/gettext"
-
-RDEPEND="${CDEPEND}
- entropy? ( >=sys-apps/entropy-1.0_rc27 )
- pm-utils? ( sys-power/pm-utils )
- >=app-portage/layman-1.2.3
- >=sys-apps/portage-2.1.9
- sys-auth/consolekit"
-
-APP_LINGUAS="as bg bn ca cs da de el en_GB es fi fr gu he hi hu it ja kn ko ml mr
-ms nb nl or pa pl pt pt_BR ro ru sk sr sr@latin sv ta te th tr uk zh_CN zh_TW"
-for X in ${APP_LINGUAS}; do
- IUSE=" ${IUSE} linguas_${X}"
-done
-
-S="${WORKDIR}/${MY_P}"
-RESTRICT="test" # tests are failing atm
-
-# NOTES:
-# do not use a specific user, useless and not more secure according to upstream
-# doc is in the tarball and always installed
-# mono doesn't install anything (RDEPEND dev-dotnet/gtk-sharp-gapi:2
-# (R)DEPEND dev-dotnet/glib-sharp:2 dev-lang/mono), upstream bug 23247
-
-# UPSTREAM:
-# documentation/website with --enable-doc-install
-# failing tests
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-entropy-add-forward-compatibility.patch"
-}
-
-src_configure() {
- local myconf=""
-
- if use policykit; then
- myconf+=" --with-security-framework=polkit"
- else
- myconf+=" --with-security-framework=dummy"
- fi
-
- if [[ -z "${LINGUAS}" ]]; then
- myconf+=" --disable-nls"
- else
- myconf+=" --enable-nls"
- fi
-
- # localstatedir: for gentoo it's /var/lib but for $PN it's /var
- # dep-tracking,option-check,libtool-lock,strict,local: obvious reasons
- # command,debuginfo,gstreamer,service-packs: not supported by backend
-
- # NOTE: default backend is autodetected at runtime, also
- if use entropy; then
- myconf+=" --with-default-backend=entropy"
- else
- myconf+=" --with-default-backend=portage"
- fi
- econf \
- ${myconf} \
- --enable-introspection=no \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --enable-option-checking \
- --enable-libtool-lock \
- --disable-strict \
- --disable-local \
- $(use_enable doc gtk-doc) \
- $(use_enable bash-completion command-not-found) \
- --disable-debuginfo-install \
- --disable-gstreamer-plugin \
- --disable-service-packs \
- --enable-man-pages \
- --enable-portage \
- $(use_enable entropy) \
- $(use_enable cron) \
- --disable-gtk-module \
- $(use_enable introspection) \
- $(use_enable networkmanager) \
- $(use_enable nsplugin browser-plugin) \
- $(use_enable pm-utils) \
- --disable-qt \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
- $(use_enable udev device-rebind)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- dodoc AUTHORS MAINTAINERS NEWS README TODO || die "dodoc failed"
- dodoc ChangeLog || die "dodoc failed"
-
- if use nsplugin; then
- dodir "/usr/$(get_libdir)/${PLUGINS_DIR}"
- mv "${D}"/usr/$(get_libdir)/mozilla/plugins/* \
- "${D}/usr/$(get_libdir)/${PLUGINS_DIR}/"
- fi
-
- if ! use static-libs; then
- find "${D}" -name *.la | xargs rm || die "removing .la files failed"
- fi
-
- # Remove precompiled python modules, we handle byte compiling
- rm -f "${D}/$(python_get_sitedir)"/${PN}*.py[co]
-
- dobashcompletion "${S}/contrib/pk-completion.bash" ${PN}
- # Remove bashcomp file installed by build-system
- rm -f "${D}/bash_completion.d/pk-completion.bash"
-
- # Remove unwanted PackageKit website stuff
- rm -rf "${D}/usr/share/PackageKit/website"
-
-}
-
-pkg_postinst() {
- python_mod_optimize ${PN/-base}
-
- if ! use policykit; then
- ewarn "You are not using policykit, the daemon can't be considered as secure."
- ewarn "All users will be able to do anything through ${MY_PN}."
- ewarn "Please, consider rebuilding ${MY_PN} with policykit USE flag."
- ewarn "THIS IS A SECURITY ISSUE."
- echo
- ebeep
- epause 5
- fi
- bash-completion_pkg_postinst
-}
-
-pkg_prerm() {
- einfo "Removing downloaded files with ${MY_PN}..."
- [[ -d "${ROOT}"/var/cache/${MY_PN}/downloads/ ]] && \
- rm -rf /var/cache/PackageKit/downloads/*
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN/-base}
-}