summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-01-26 15:58:13 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-01-26 15:58:13 +0000
commitde8d96b222f766ab16cc094ce16ea7c792cb74c9 (patch)
tree182b250a59370bcee94e9896595ab89c16566048 /app-admin/puppet
parentVersion bumped. (diff)
downloadgentoo-2-de8d96b222f766ab16cc094ce16ea7c792cb74c9.tar.gz
gentoo-2-de8d96b222f766ab16cc094ce16ea7c792cb74c9.tar.bz2
gentoo-2-de8d96b222f766ab16cc094ce16ea7c792cb74c9.zip
Version bumped.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/ChangeLog10
-rw-r--r--app-admin/puppet/puppet-0.25.0-r1.ebuild134
-rw-r--r--app-admin/puppet/puppet-0.25.3.ebuild (renamed from app-admin/puppet/puppet-0.25.1.ebuild)45
3 files changed, 29 insertions, 160 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index c897b0569ab6..72f116d7d413 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/puppet
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.50 2009/11/22 17:38:35 hollow Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.51 2010/01/26 15:58:13 matsuu Exp $
+
+*puppet-0.25.3 (26 Jan 2010)
+
+ 26 Jan 2010; MATSUU Takuto <matsuu@gentoo.org> -puppet-0.25.0-r1.ebuild,
+ -puppet-0.25.1.ebuild, +puppet-0.25.3.ebuild:
+ Version bumped.
*puppet-0.25.1-r1 (22 Nov 2009)
diff --git a/app-admin/puppet/puppet-0.25.0-r1.ebuild b/app-admin/puppet/puppet-0.25.0-r1.ebuild
deleted file mode 100644
index 2251b3c17bf1..000000000000
--- a/app-admin/puppet/puppet-0.25.0-r1.ebuild
+++ /dev/null
@@ -1,134 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.25.0-r1.ebuild,v 1.2 2009/11/16 20:18:49 hollow Exp $
-
-EAPI="2"
-inherit elisp-common eutils ruby
-
-MY_P="${P/_}"
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://reductivelabs.com/projects/puppet"
-SRC_URI="http://reductivelabs.com/downloads/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="augeas emacs ldap rrdtool shadow vim-syntax"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="dev-lang/ruby[ssl]
- emacs? ( virtual/emacs )
- >=dev-ruby/facter-1.5.0"
-RDEPEND="${DEPEND}
- >=app-portage/eix-0.9.4
- <app-portage/eix-0.18
- augeas? ( dev-ruby/ruby-augeas )
- ldap? ( dev-ruby/ruby-ldap )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- shadow? ( dev-ruby/ruby-shadow )"
-# || (
-# www-servers/webrick
-# www-servers/mongrel
-# )
-# dev-ruby/diff-lcs
-# dev-ruby/rails
-
-S="${WORKDIR}/${MY_P}"
-USE_RUBY="ruby18"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.24.6-eix.patch"
- epatch "${FILESDIR}/${PN}-0.25.0-cert-names.patch"
-}
-
-src_compile() {
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- DESTDIR="${D}" ruby_einstall "$@" || die
- DESTDIR="${D}" erubydoc
-
- #
- # bug #237071
- #
- #doinitd conf/gentoo/init.d/puppetmaster
- newinitd "${FILESDIR}"/puppetmaster-0.25.init puppetmaster
- #doconfd conf/gentoo/conf.d/puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
- #doinitd conf/gentoo/init.d/puppet
- newinitd "${FILESDIR}"/puppet-0.25.init puppet
- doconfd conf/gentoo/conf.d/puppet
-
- # Initial configuration files
- keepdir /etc/puppet/manifests
- insinto /etc/puppet
- doins conf/gentoo/puppet/*
-
- # Location of log and data files
- keepdir /var/run/puppet
- keepdir /var/log/puppet
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
- done
- docinto conf; dodoc conf/namespaceauth.conf
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${ROOT}/etc/puppet/puppetd.conf" -o \
- -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
- -f "${ROOT}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
- use emacs && elisp-site-regen
-}
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-0.25.1.ebuild b/app-admin/puppet/puppet-0.25.3.ebuild
index 3b7c7b348b0e..a2e81819447e 100644
--- a/app-admin/puppet/puppet-0.25.1.ebuild
+++ b/app-admin/puppet/puppet-0.25.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.25.1.ebuild,v 1.1 2009/11/16 20:18:49 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.25.3.ebuild,v 1.1 2010/01/26 15:58:13 matsuu Exp $
EAPI="2"
inherit elisp-common eutils ruby
@@ -35,10 +35,6 @@ pkg_setup() {
enewuser puppet -1 -1 /var/lib/puppet puppet
}
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.25.1-eix-0.18.patch"
-}
-
src_compile() {
if use emacs ; then
elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
@@ -47,44 +43,45 @@ src_compile() {
src_install() {
DESTDIR="${D}" ruby_einstall "$@" || die
- DESTDIR="${D}" erubydoc
+ DESTDIR="${D}" erubydoc || die
- newinitd "${FILESDIR}"/puppetmaster-0.25.init puppetmaster
- newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
- newinitd "${FILESDIR}"/puppet-0.25.init puppet
- doconfd conf/gentoo/conf.d/puppet
+ newinitd "${FILESDIR}"/puppetmaster-0.25.init puppetmaster || die
+ doconfd conf/gentoo/conf.d/puppetmaster || die
+ newinitd "${FILESDIR}"/puppet-0.25.init puppet || die
+ doconfd conf/gentoo/conf.d/puppet || die
# Initial configuration files
- keepdir /etc/puppet/manifests
+ keepdir /etc/puppet/manifests || die
insinto /etc/puppet
- doins conf/gentoo/puppet/*
+ doins conf/gentoo/puppet/* || die
+ doins conf/auth.conf || die
# Location of log and data files
- keepdir /var/run/puppet
- keepdir /var/log/puppet
- keepdir /var/lib/puppet/ssl
- keepdir /var/lib/puppet/files
- fowners -R puppet:puppet /var/{run,log,lib}/puppet
+ keepdir /var/run/puppet || die
+ keepdir /var/log/puppet || die
+ keepdir /var/lib/puppet/ssl || die
+ keepdir /var/lib/puppet/files || die
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet || die
if use emacs ; then
elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
fi
if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema || die
fi
if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim || die
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim || die
fi
# ext and examples files
for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
+ docinto "$(dirname ${f})"; dodoc "${f}" || die
done
- docinto conf; dodoc conf/namespaceauth.conf
+ docinto conf; dodoc conf/namespaceauth.conf || die
}
pkg_postinst() {