summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-02-16 00:09:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-02-16 00:09:43 +0000
commit5a0bbb91b2c7ecf42ac0d3cf49b25b397a153c00 (patch)
tree1874ba2e6e29e7c913ed93936776484d1e01537b /app-admin/testdisk
parentVersion bump. (diff)
downloadgentoo-2-5a0bbb91b2c7ecf42ac0d3cf49b25b397a153c00.tar.gz
gentoo-2-5a0bbb91b2c7ecf42ac0d3cf49b25b397a153c00.tar.bz2
gentoo-2-5a0bbb91b2c7ecf42ac0d3cf49b25b397a153c00.zip
Bug #355131: version bump, bugfixes only.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/ChangeLog9
-rw-r--r--app-admin/testdisk/testdisk-6.11.3.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index 2ba1c995e764..26bba343c1e6 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/testdisk
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.38 2010/01/22 16:39:07 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.39 2011/02/16 00:09:43 robbat2 Exp $
+
+*testdisk-6.11.3 (16 Feb 2011)
+
+ 16 Feb 2011; Robin H. Johnson <robbat2@gentoo.org> +testdisk-6.11.3.ebuild:
+ Bug #355131: version bump, bugfixes only.
22 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
testdisk-6.11-r1.ebuild:
diff --git a/app-admin/testdisk/testdisk-6.11.3.ebuild b/app-admin/testdisk/testdisk-6.11.3.ebuild
new file mode 100644
index 000000000000..c956b9f3d75a
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.11.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.11.3.ebuild,v 1.1 2011/02/16 00:09:43 robbat2 Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg:0 )
+ ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35
+ sys-libs/zlib"
+RDEPEND="!static? ( ${DEPEND} )"
+
+#S=${WORKDIR}/${P}-WIP
+
+# merged upstream
+#src_prepare() {
+# epatch "${FILESDIR}"/${P}-exif_bound_checking-v2.patch
+#}
+
+src_configure() {
+ local myconf="--without-ewf --enable-sudo"
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+}