summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:48:41 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-06-15 03:48:41 +0000
commit1e0f348888a35946cff7a1bd953a67b87a0d3e18 (patch)
treee7a4f34b375105212c1dcd621a328c16cddb23a1 /app-admin
parentfixes for CVE-2014-3248 and bug 513290 (diff)
downloadgentoo-2-1e0f348888a35946cff7a1bd953a67b87a0d3e18.tar.gz
gentoo-2-1e0f348888a35946cff7a1bd953a67b87a0d3e18.tar.bz2
gentoo-2-1e0f348888a35946cff7a1bd953a67b87a0d3e18.zip
fixing bug 513292 CVE-2014-3248
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mcollective/ChangeLog8
-rw-r--r--app-admin/mcollective/mcollective-2.5.2.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index bc08c507ed08..adcb13ef2d46 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.22 2014/03/02 22:42:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.23 2014/06/15 03:48:41 prometheanfire Exp $
+
+*mcollective-2.5.2 (15 Jun 2014)
+
+ 15 Jun 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +mcollective-2.5.2.ebuild:
+ fixing bug 513292 CVE-2014-3248
02 Mar 2014; Matthew Thode <prometheanfire@gentoo.org>
-mcollective-2.2.0-r1.ebuild, -mcollective-2.2.0.ebuild,
diff --git a/app-admin/mcollective/mcollective-2.5.2.ebuild b/app-admin/mcollective/mcollective-2.5.2.ebuild
new file mode 100644
index 000000000000..ad791e7150dd
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.5.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.5.2.ebuild,v 1.1 2014/06/15 03:48:41 prometheanfire Exp $
+
+EAPI="4"
+
+#upstream is adding ruby20 support soonish, keep an eye out
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}