summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-06-30 13:50:58 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-06-30 13:50:58 +0000
commit5e340eca3a735a2d0002659ba82904bc12648b31 (patch)
treee982cd59425865db3a156ba9d603f4f7f1dc3604 /app-admin
parentStable on sparc (diff)
downloadgentoo-2-5e340eca3a735a2d0002659ba82904bc12648b31.tar.gz
gentoo-2-5e340eca3a735a2d0002659ba82904bc12648b31.tar.bz2
gentoo-2-5e340eca3a735a2d0002659ba82904bc12648b31.zip
added desktop as per bug #137939.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/kedpm/ChangeLog9
-rw-r--r--app-admin/kedpm/files/digest-kedpm-0.4.02
-rw-r--r--app-admin/kedpm/files/digest-kedpm-0.4.0-r13
-rw-r--r--app-admin/kedpm/files/kedpm.desktop17
-rw-r--r--app-admin/kedpm/kedpm-0.4.0-r1.ebuild60
5 files changed, 90 insertions, 1 deletions
diff --git a/app-admin/kedpm/ChangeLog b/app-admin/kedpm/ChangeLog
index 368e278e7193..b82f1fafcfba 100644
--- a/app-admin/kedpm/ChangeLog
+++ b/app-admin/kedpm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/kedpm
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/kedpm/ChangeLog,v 1.13 2006/01/07 19:33:11 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/kedpm/ChangeLog,v 1.14 2006/06/30 13:50:58 dragonheart Exp $
+
+*kedpm-0.4.0-r1 (30 Jun 2006)
+
+ 30 Jun 2006; Daniel Black <dragonheart@gentoo.org> +files/kedpm.desktop,
+ +kedpm-0.4.0-r1.ebuild:
+ added desktop as per bug #137939. Thanks Carles Escrig for the bug and
+ desktop entry
07 Jan 2006; Daniel Black <dragonheart@gentoo.org> kedpm-0.4.0.ebuild:
condition around built_with_use as per compneds request
diff --git a/app-admin/kedpm/files/digest-kedpm-0.4.0 b/app-admin/kedpm/files/digest-kedpm-0.4.0
index 2c2daab725c0..0c79c75f7577 100644
--- a/app-admin/kedpm/files/digest-kedpm-0.4.0
+++ b/app-admin/kedpm/files/digest-kedpm-0.4.0
@@ -1 +1,3 @@
MD5 6b83a646873f8ea00af9c6403aa259bc kedpm-0.4.0.tar.gz 61636
+RMD160 7b37c06c93151a7177505c4dd796c33d5d1c77bb kedpm-0.4.0.tar.gz 61636
+SHA256 f1dfb44a990110fddf132c9841f40aa2b9848ade4be56957a8a572574dc2fc28 kedpm-0.4.0.tar.gz 61636
diff --git a/app-admin/kedpm/files/digest-kedpm-0.4.0-r1 b/app-admin/kedpm/files/digest-kedpm-0.4.0-r1
new file mode 100644
index 000000000000..0c79c75f7577
--- /dev/null
+++ b/app-admin/kedpm/files/digest-kedpm-0.4.0-r1
@@ -0,0 +1,3 @@
+MD5 6b83a646873f8ea00af9c6403aa259bc kedpm-0.4.0.tar.gz 61636
+RMD160 7b37c06c93151a7177505c4dd796c33d5d1c77bb kedpm-0.4.0.tar.gz 61636
+SHA256 f1dfb44a990110fddf132c9841f40aa2b9848ade4be56957a8a572574dc2fc28 kedpm-0.4.0.tar.gz 61636
diff --git a/app-admin/kedpm/files/kedpm.desktop b/app-admin/kedpm/files/kedpm.desktop
new file mode 100644
index 000000000000..f75a7eae5be9
--- /dev/null
+++ b/app-admin/kedpm/files/kedpm.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Version=0.4.0
+Encoding=UTF-8
+Name=Ked Password Manager
+GenericName=Password Manager
+GenericName[ca]=Gestor de contrasenyes
+GenericName[es]=Gestor de contraseñas
+Comment=Manage passwords and related information
+Comment[ca]=Gestioneu contrasenyes i informació relacionada
+Comment[es]=Gestiona contraseñas e información relacionada
+Exec=kedpm
+Icon=/usr/share/kedpm/glade/logo.png
+Terminal=false
+Type=Application
+Categories=GNOME;Application;Utility;
+StartupNotify=true
+MimeType=application/xml;
diff --git a/app-admin/kedpm/kedpm-0.4.0-r1.ebuild b/app-admin/kedpm/kedpm-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..5869e98e0962
--- /dev/null
+++ b/app-admin/kedpm/kedpm-0.4.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/kedpm/kedpm-0.4.0-r1.ebuild,v 1.1 2006/06/30 13:50:58 dragonheart Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Ked Password Manager helps to manage large amounts of passwords and related information"
+HOMEPAGE="http://kedpm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc amd64"
+IUSE="gtk"
+
+DEPEND="virtual/python
+ >=sys-apps/sed-4"
+RDEPEND="dev-python/pycrypto
+ gtk? ( >=dev-python/pygtk-2 )"
+
+pkg_setup() {
+ if use gtk
+ then
+ if has_version '<dev-python/pygtk-2.8.0-r2' ; then
+ if ! built_with_use dev-python/pygtk gnome
+ then
+ die "You need to compile dev-python/pygtk with gnome USE flag!"
+ fi
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We want documentation to install in /usr/share/doc/kedpm
+ # not in /usr/share/kedpm as in original setup.py.
+ epatch "${FILESDIR}/setup-doc.patch"
+
+ # If we don't compiling with GTK support, let's change default
+ # frontend for kedpm to CLI.
+ use gtk || sed -i -e 's/"gtk" # default/"cli" # default/' scripts/kedpm
+}
+
+src_install() {
+ distutils_src_install
+ dodoc AUTHORS CHANGES ChangeLog NEWS PKG-INFO README
+ cp -r test run_tests "${D}/usr/share/${PN}"
+ # menu item
+ domenu "${FILESDIR}/${PN}.desktop"
+
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can test your kedpm installation running"
+ einfo "cd /usr/share/${PN}/ && ./run_tests"
+ einfo
+}