summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-28 16:03:22 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-28 16:03:22 +0000
commitc7afc933d00c134879e305923fae3e590f8c6f11 (patch)
treef3c2c51a3b143bf25a784d151a17bc7b68399d4f /app-admin
parentalpha/ia64/s390/sparc stable wrt #377341 (diff)
downloadgentoo-2-c7afc933d00c134879e305923fae3e590f8c6f11.tar.gz
gentoo-2-c7afc933d00c134879e305923fae3e590f8c6f11.tar.bz2
gentoo-2-c7afc933d00c134879e305923fae3e590f8c6f11.zip
Version bump.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sysstat/ChangeLog7
-rw-r--r--app-admin/sysstat/sysstat-10.0.2.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/app-admin/sysstat/ChangeLog b/app-admin/sysstat/ChangeLog
index 41f22a2e33e5..599c7fb0279b 100644
--- a/app-admin/sysstat/ChangeLog
+++ b/app-admin/sysstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sysstat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.204 2011/08/09 13:27:39 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.205 2011/08/28 16:03:22 jer Exp $
+
+*sysstat-10.0.2 (28 Aug 2011)
+
+ 28 Aug 2011; Jeroen Roovers <jer@gentoo.org> +sysstat-10.0.2.ebuild:
+ Version bump.
09 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> sysstat-10.0.1.ebuild:
ppc/ppc64 stable wrt #377433
diff --git a/app-admin/sysstat/sysstat-10.0.2.ebuild b/app-admin/sysstat/sysstat-10.0.2.ebuild
new file mode 100644
index 000000000000..e465cd2f44df
--- /dev/null
+++ b/app-admin/sysstat/sysstat-10.0.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-10.0.2.ebuild,v 1.1 2011/08/28 16:03:22 jer Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cron debug +doc isag nls lm_sensors"
+
+SYSSTAT_LINGUAS="
+ af cs da de eo es eu fi fr id it ja ky lv mt nb nl nn pl pt pt_BR ro ru sk
+ sv uk vi zh_CN zh_TW
+"
+
+for SYSSTAT_LINGUA in ${SYSSTAT_LINGUAS}; do
+ IUSE="${IUSE} linguas_${SYSSTAT_LINGUA}"
+done
+
+RDEPEND="
+ cron? ( sys-process/cronbase )
+ isag? (
+ dev-lang/tk
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ local po_count li_count lingua NLSDIR="${S}/nls"
+
+ count() { echo ${#}; }
+ po_count=$(count ${NLSDIR}/*.po)
+ li_count=$(count ${SYSSTAT_LINGUAS})
+ [[ ${po_count} = ${li_count} ]] \
+ || die "Number of LINGUAS does not match number of .po files"
+ unset count
+
+ einfo "Keeping these locales: ${LINGUAS}."
+ for lingua in ${SYSSTAT_LINGUAS}; do
+ if ! use linguas_${lingua}; then
+ rm -f "${NLSDIR}/${lingua}.po" || die
+ fi
+ done
+ epatch "${FILESDIR}"/${PN}-10.0.0-flags.patch
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-documentation"
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ econf ${myconf} \
+ rcdir="Gentoo-does-not-use-rc.d" \
+ $(use_enable cron install-cron) \
+ $(use_enable debug debuginfo) \
+ $(use_enable isag install-isag) \
+ $(use_enable nls) \
+ $(use_enable lm_sensors sensors) \
+ conf_dir=/etc
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ use cron && dodir /etc/cron.{daily,hourly}
+
+ emake \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ newinitd "${FILESDIR}"/sysstat.init.d sysstat
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}