summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-25 09:50:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-25 09:50:42 +0000
commitfef6962b9d2ac1aac8de8a09ea4eb87dc9b7b462 (patch)
tree225f4d82f1acb5f748f2a5c49a5afbc1e95b7100 /app-admin
parentPunt my old pmask entries. (diff)
downloadgentoo-2-fef6962b9d2ac1aac8de8a09ea4eb87dc9b7b462.tar.gz
gentoo-2-fef6962b9d2ac1aac8de8a09ea4eb87dc9b7b462.tar.bz2
gentoo-2-fef6962b9d2ac1aac8de8a09ea4eb87dc9b7b462.zip
Version bump. Bug #379907. Thanks to Dan Weeks <dan@danweeks.net>. Assigned to proxy-maintainers
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/conserver/ChangeLog11
-rw-r--r--app-admin/conserver/conserver-8.1.18.ebuild87
-rw-r--r--app-admin/conserver/files/conserver-8.1.18-dmalloc.patch100
-rw-r--r--app-admin/conserver/metadata.xml11
4 files changed, 205 insertions, 4 deletions
diff --git a/app-admin/conserver/ChangeLog b/app-admin/conserver/ChangeLog
index c2af338b4f32..1c97786a395e 100644
--- a/app-admin/conserver/ChangeLog
+++ b/app-admin/conserver/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/conserver
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conserver/ChangeLog,v 1.75 2009/02/23 14:57:29 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conserver/ChangeLog,v 1.76 2011/08/25 09:50:42 hwoarang Exp $
+
+*conserver-8.1.18 (24 Aug 2011)
+
+ 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> +conserver-8.1.18.ebuild,
+ +files/conserver-8.1.18-dmalloc.patch, metadata.xml:
+ Version bump. Bug #379907. Thanks to Dan Weeks <dan@danweeks.net>. Assigned
+ to proxy-maintainers
23 Feb 2009; Joseph Jezak <josejx@gentoo.org> conserver-8.1.16-r1.ebuild:
Marked ~ppc/~ppc64 for bug #210799.
diff --git a/app-admin/conserver/conserver-8.1.18.ebuild b/app-admin/conserver/conserver-8.1.18.ebuild
new file mode 100644
index 000000000000..04d262649e26
--- /dev/null
+++ b/app-admin/conserver/conserver-8.1.18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conserver/conserver-8.1.18.ebuild,v 1.1 2011/08/25 09:50:42 hwoarang Exp $
+
+EAPI="4"
+
+inherit ssl-cert eutils pam autotools
+
+DESCRIPTION="Serial Console Manager"
+HOMEPAGE="http://www.conserver.com/"
+SRC_URI="http://www.conserver.com/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kerberos pam ssl tcpd debug"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ debug? ( dev-libs/dmalloc )
+ kerberos? (
+ virtual/krb5
+ net-libs/libgssglue
+ )"
+RDEPEND="${DEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+src_prepare() {
+ # Apply patch to prevent package from stripping binaries
+ epatch "${FILESDIR}"/${PN}-prestrip.patch
+
+ # Apply patch to use custom dmalloc macro
+ epatch "${FILESDIR}"/${P}-dmalloc.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with tcpd libwrap) \
+ $(use_with debug dmalloc) \
+ $(use_with kerberos gssapi) \
+ --with-logfile=/var/log/conserver.log \
+ --with-pidfile=/var/run/conserver.pid \
+ --with-cffile=conserver/conserver.cf \
+ --with-pwdfile=conserver/conserver.passwd \
+ --with-master=localhost \
+ --with-port=7782
+}
+
+src_install() {
+ emake DESTDIR="${D}" exampledir="/usr/share/doc/${PF}/examples" install
+
+ ## create data directory
+ dodir /var/consoles
+ fowners daemon:daemon /var/consoles
+ fperms 700 /var/consoles
+
+ ## add startup and sample config
+ newinitd "${FILESDIR}"/conserver.initd conserver
+ newconfd "${FILESDIR}"/conserver.confd conserver
+
+ dodir /etc/conserver
+ fperms 700 /etc/conserver
+ insinto /etc/conserver
+ newins "${S}"/conserver.cf/conserver.cf conserver.cf.sample
+ newins "${S}"/conserver.cf/conserver.passwd conserver.passwd.sample
+
+ ## add docs
+ dohtml conserver.html
+ dodoc CHANGES FAQ PROTOCOL README TODO
+ dodoc conserver/Sun-serial contrib/maketestcerts
+ newdoc conserver.cf/conserver.cf conserver.cf.sample
+
+ # Add pam config
+ newpamd "${FILESDIR}"/conserver.pam-pambase conserver
+}
+
+pkg_postinst() {
+ # Add certs if SSL use flag is enabled
+ if use ssl && [ ! -f "${ROOT}"/etc/ssl/conserver/conserver.key ]; then
+ install_cert /etc/ssl/conserver/conserver
+ fi
+}
diff --git a/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
new file mode 100644
index 000000000000..ff82f74b261c
--- /dev/null
+++ b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
@@ -0,0 +1,100 @@
+--- configure.in 2011-08-19 01:11:06.000000000 -0400
++++ configure.in 2011-08-19 02:06:50.000000000 -0400
+@@ -320,6 +320,8 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
++AM_WITH_DMALLOC([cons_with_dmalloc="YES"],[cons_with_dmalloc="NO"])
++
+ dnl ### Compiler characteristics. ##################################
+ AC_AIX
+ AC_C_CONST
+@@ -578,51 +580,6 @@
+ fi]
+ )
+
+-cons_with_dmalloc="NO"
+-AC_ARG_WITH(dmalloc,
+- AS_HELP_STRING([--with-dmalloc@<:@=PATH@:>@],
+- [Compile in dmalloc support]),
+- [if test "$withval" != "no"; then
+- if test "$withval" != "yes"; then
+- DMALLOCCPPFLAGS="-I$withval/include"
+- if test "$use_dash_r" != "yes"; then
+- DMALLOCLDFLAGS="-L$withval/lib"
+- else
+- DMALLOCLDFLAGS="-L$withval/lib -R$withval/lib"
+- fi
+- else
+- DMALLOCCPPFLAGS=""
+- DMALLOCLDFLAGS=""
+- fi
+-
+- oCPPFLAGS="$CPPFLAGS"
+- oLDFLAGS="$LDFLAGS"
+- oLIBS="$LIBS"
+- have_dmalloc=no
+-
+- CPPFLAGS="$CPPFLAGS $DMALLOCCPPFLAGS"
+- LDFLAGS="$LDFLAGS $DMALLOCLDFLAGS"
+-
+- AC_CHECK_HEADER([dmalloc.h],
+- [LIBS="$LIBS -ldmalloc"
+- AC_MSG_CHECKING(for dmalloc libraries -ldmalloc)
+- AC_TRY_LINK([#include <dmalloc.h>
+- ],[dmalloc_debug(0)],
+- [AC_MSG_RESULT(yes)
+- cons_with_dmalloc="YES"
+- AC_DEFINE(HAVE_DMALLOC)
+- have_dmalloc=yes],
+- [AC_MSG_RESULT(no)])],)
+-
+- if test $have_dmalloc = no; then
+- LIBS="$oLIBS"
+- CPPFLAGS="$oCPPFLAGS"
+- LDFLAGS="$oLDFLAGS"
+- fi
+- fi]
+-)
+-
+-
+ dnl ### Check for needed functions. ################################
+
+ dnl dnl The following basically stollen from the less-358 distribution, but
+--- /dev/null 2011-08-07 13:18:05.535976733 -0400
++++ m4/dmalloc.m4 2011-08-19 03:49:03.755073497 -0400
+@@ -0,0 +1,34 @@
++## ----------------------------------- ## -*- Autoconf -*-
++## Check if --with-dmalloc was given. ##
++## From Franc,ois Pinard ##
++## ----------------------------------- ##
++
++# Copyright (C) 1996, 1998, 1999, 2000, 2001, 2002, 2003, 2005, 2010,
++# 2011 Free Software Foundation, Inc.
++#
++# This file is free software; the Free Software Foundation
++# gives unlimited permission to copy and/or distribute it,
++# with or without modifications, as long as this notice is preserved.
++
++# serial 7
++
++dnl AM_WITH_DMALLOC([ACTION-IF-FOUND],[ACTION-IF-NOT])
++AC_DEFUN([AM_WITH_DMALLOC],
++[AC_MSG_CHECKING([if malloc debugging is wanted])
++AC_ARG_WITH([dmalloc],
++[AS_HELP_STRING([--with-dmalloc],
++ [use dmalloc, as in http://www.dmalloc.com])],
++[if test "$withval" = yes; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE([WITH_DMALLOC], [1],
++ [Define if using the dmalloc debugging malloc package])
++ LIBS="$LIBS -ldmalloc"
++ LDFLAGS="$LDFLAGS -g"
++ [$1]
++else
++ AC_MSG_RESULT([no])
++ [$2]
++fi], [AC_MSG_RESULT([no])])
++])
++
++AU_DEFUN([fp_WITH_DMALLOC], [AM_WITH_DMALLOC])
diff --git a/app-admin/conserver/metadata.xml b/app-admin/conserver/metadata.xml
index 0756987f0d1f..831ceb9cc06f 100644
--- a/app-admin/conserver/metadata.xml
+++ b/app-admin/conserver/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
+ <herd>proxy-maintainers</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>hwoarang@gentoo.org</email>
+ <name>Markos Chandras</name>
+ <description>Proxy maintainers. CC him on bugs</description>
+ </maintainer>
+ <maintainer>
+ <email>dan@danweeks.net</email>
+ <name>Dan Weeks</name>
+ <description>Maintainer. Assign bugs to him</description>
</maintainer>
<longdescription>
Conserver is an application that allows multiple users to watch a serial