summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-02-25 11:27:25 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-02-25 11:27:25 +0000
commit176d9fa505275113fe6e7e6ee296780f5b683355 (patch)
tree0078deb6e4901607b0afea5f6b5aa3819d128e00 /app-antivirus
parentPatch from upstream for a bug with the bcmxcp driver. (diff)
downloadgentoo-2-176d9fa505275113fe6e7e6ee296780f5b683355.tar.gz
gentoo-2-176d9fa505275113fe6e7e6ee296780f5b683355.tar.bz2
gentoo-2-176d9fa505275113fe6e7e6ee296780f5b683355.zip
Added a patch to include cl_loaddbdir() in clamav.h to prevent other apps using this function from dying during compile-time. Other API incompatibilities will be dealt with as they come (patch if it's trivial, suggest users to whine upstream if it's not). Oh, and marked 0.90 stable on x86, as per security bug #167201.
(Portage version: 2.1.2-r11)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog10
-rw-r--r--app-antivirus/clamav/clamav-0.90.ebuild10
-rw-r--r--app-antivirus/clamav/files/clamav-0.90-compat.patch11
3 files changed, 28 insertions, 3 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index eb8a6b2dde9a..21dbec6eead4 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.205 2007/02/22 13:22:04 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.206 2007/02/25 11:27:25 ticho Exp $
+
+ 25 Feb 2007; Andrej Kacian <ticho@gentoo.org>
+ +files/clamav-0.90-compat.patch, clamav-0.90.ebuild:
+ Added a patch to include cl_loaddbdir() in clamav.h to prevent other apps
+ using this function from dying during compile-time. Other API
+ incompatibilities will be dealt with as they come (patch if it's trivial,
+ suggest users to whine upstream if it's not). Oh, and marked 0.90 stable on
+ x86, as per security bug #167201.
22 Feb 2007; Patrick McLean <chutzpah@gentoo.org> clamav-0.90.ebuild:
Stable on amd64 (bug #167201).
diff --git a/app-antivirus/clamav/clamav-0.90.ebuild b/app-antivirus/clamav/clamav-0.90.ebuild
index 588899b4fd58..8866603e526b 100644
--- a/app-antivirus/clamav/clamav-0.90.ebuild
+++ b/app-antivirus/clamav/clamav-0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.90.ebuild,v 1.8 2007/02/22 13:22:04 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.90.ebuild,v 1.9 2007/02/25 11:27:25 ticho Exp $
inherit eutils flag-o-matic fixheadtails
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc ~x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="bzip2 crypt curl gmp logrotate mailwrapper milter selinux"
DEPEND="virtual/libc
@@ -40,6 +40,12 @@ pkg_setup() {
enewuser clamav -1 -1 /dev/null clamav
}
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-compat.patch
+}
+
src_compile() {
has_version =sys-libs/glibc-2.2* && filter-lfs-flags
diff --git a/app-antivirus/clamav/files/clamav-0.90-compat.patch b/app-antivirus/clamav/files/clamav-0.90-compat.patch
new file mode 100644
index 000000000000..601e2df9a169
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.90-compat.patch
@@ -0,0 +1,11 @@
+diff -bur clamav-0.90.orig/libclamav/clamav.h clamav-0.90/libclamav/clamav.h
+--- clamav-0.90.orig/libclamav/clamav.h 2007-02-25 11:56:29.000000000 +0100
++++ clamav-0.90/libclamav/clamav.h 2007-02-25 11:57:42.000000000 +0100
+@@ -234,6 +234,7 @@
+ /* database handling */
+ extern int cl_load(const char *path, struct cl_engine **engine, unsigned int *signo, unsigned int options);
+ extern const char *cl_retdbdir(void);
++extern int cl_loaddbdir(const char *dirname, struct cl_engine **engine, unsigned int *signo);
+
+ /* engine handling */
+ extern int cl_build(struct cl_engine *engine);