summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-17 22:59:43 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-17 22:59:43 +0000
commit4f965c29df3d3568f2cb8c8b5db5b931b5272c78 (patch)
tree7f3f95440708f51bb537de377dfe9acf3a021ef5 /app-antivirus
parentVersion bump (bug #341033 by Pun) and remove old. Reformat ebuild, update lic... (diff)
downloadgentoo-2-4f965c29df3d3568f2cb8c8b5db5b931b5272c78.tar.gz
gentoo-2-4f965c29df3d3568f2cb8c8b5db5b931b5272c78.tar.bz2
gentoo-2-4f965c29df3d3568f2cb8c8b5db5b931b5272c78.zip
Version bump (bug #345189 by Deniss Gaplevsky).
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.96.4.ebuild139
2 files changed, 145 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 7819bce3ee2f..02d0c0510e22 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.362 2010/09/20 21:52:02 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.363 2010/11/17 22:59:43 radhermit Exp $
+
+*clamav-0.96.4 (17 Nov 2010)
+
+ 17 Nov 2010; Tim Harder <radhermit@gentoo.org> +clamav-0.96.4.ebuild:
+ Version bump (bug #345189 by Deniss Gaplevsky).
*clamav-0.96.3 (20 Sep 2010)
diff --git a/app-antivirus/clamav/clamav-0.96.4.ebuild b/app-antivirus/clamav/clamav-0.96.4.ebuild
new file mode 100644
index 000000000000..06442e141e1a
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.96.4.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.96.4.ebuild,v 1.1 2010/11/17 22:59:43 radhermit Exp $
+
+EAPI=2
+
+inherit eutils flag-o-matic fixheadtails multilib versionator
+
+# for when rc1 is appended to release candidates:
+MY_PV=$(replace_version_separator 3 '');
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 clamdtop iconv milter selinux ipv6"
+
+COMMON_DEPEND="bzip2? ( app-arch/bzip2 )
+ milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ iconv? ( virtual/libiconv )
+ clamdtop? ( sys-libs/ncurses )
+ >=sys-libs/zlib-1.2.1-r3
+ >=sys-apps/sed-4"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.20"
+
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+
+PROVIDE="virtual/antivirus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.95.1-nls.patch"
+}
+
+src_configure() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ ht_fix_file configure
+ econf \
+ $(use_enable bzip2) \
+ $(use_enable ipv6) \
+ $(use_enable clamdtop) \
+ $(use_enable milter) \
+ $(use_with iconv) \
+ --disable-experimental \
+ --enable-id-check \
+ --disable-zlib-vcheck \
+ --with-dbdir=/var/lib/clamav || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ
+ newconfd "${FILESDIR}/clamd.conf" clamd
+ newinitd "${FILESDIR}/clamd.rc" clamd
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Modify /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${D}"/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(UpdateLogFile\) .*:\1 /var/log/clamav/freshclam.log:" \
+ -e "s:^\#\(NotifyClamd\).*:\1 /etc/clamd.conf:" \
+ -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${D}"/etc/freshclam.conf
+
+ if use milter; then
+ # And again same for /etc/clamav-milter.conf
+ # MilterSocket one to include ' /' because there is a 2nd line for
+ # inet: which we want to leave
+ dodoc "${FILESDIR}/clamav-milter.README.gentoo"
+
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamav-milter.pid:" \
+ -e "s+^\#\(ClamdSocket\) .*+\1 unix:/var/run/clamav/clamd.sock+" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s+^\#\(MilterSocket\) /.*+\1 unix:/var/run/clamav/clamav-milter.sock+" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamav-milter.log:" \
+ "${D}"/etc/clamav-milter.conf
+ fi
+
+ if use milter ; then
+ cat << EOF >> "${D}"/etc/conf.d/clamd
+MILTER_NICELEVEL=19
+START_MILTER=no
+EOF
+ fi
+
+ diropts ""
+ dodir /etc/logrotate.d
+ insopts -m0644
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+}
+
+pkg_postinst() {
+ if use milter ; then
+ elog "For simple instructions how to setup the clamav-milter"
+ elog "read the clamav-milter.README.gentoo in /usr/share/doc/${PF}"
+ elog
+ fi
+ ewarn "The soname for libclamav has changed in clamav-0.95."
+ ewarn "If you have upgraded from that or earlier version, it is"
+ ewarn "recommended to run revdep-rebuild, in order to fix anything"
+ ewarn "that links against libclamav.so library."
+}