summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-02-12 15:51:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-02-12 15:51:49 +0000
commit7e6846a9d2c4463f30ef4c7dad6a9052d5b427ef (patch)
treeb613ff7633a1a0537f6305667ad75c18c2de8835 /app-arch/file-roller
parentalpha/arm/ia64/m68k/s390/sh/sparc stable wrt #401109 (diff)
downloadgentoo-2-7e6846a9d2c4463f30ef4c7dad6a9052d5b427ef.tar.gz
gentoo-2-7e6846a9d2c4463f30ef4c7dad6a9052d5b427ef.tar.bz2
gentoo-2-7e6846a9d2c4463f30ef4c7dad6a9052d5b427ef.zip
Version bump. Translation updates.
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-arch/file-roller')
-rw-r--r--app-arch/file-roller/ChangeLog10
-rw-r--r--app-arch/file-roller/file-roller-3.2.2.ebuild87
2 files changed, 95 insertions, 2 deletions
diff --git a/app-arch/file-roller/ChangeLog b/app-arch/file-roller/ChangeLog
index 5338f7c7a8a8..89c2d6b3df6f 100644
--- a/app-arch/file-roller/ChangeLog
+++ b/app-arch/file-roller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/file-roller
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.303 2011/11/06 03:28:11 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/ChangeLog,v 1.304 2012/02/12 15:51:49 eva Exp $
+
+*file-roller-3.2.2 (12 Feb 2012)
+
+ 12 Feb 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +file-roller-3.2.2.ebuild:
+ Version bump. Translation updates.
*file-roller-3.2.1 (06 Nov 2011)
diff --git a/app-arch/file-roller/file-roller-3.2.2.ebuild b/app-arch/file-roller/file-roller-3.2.2.ebuild
new file mode 100644
index 000000000000..14a34cb15444
--- /dev/null
+++ b/app-arch/file-roller/file-roller-3.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/file-roller/file-roller-3.2.2.ebuild,v 1.1 2012/02/12 15:51:49 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Archive manager for GNOME"
+HOMEPAGE="http://fileroller.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nautilus packagekit"
+KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# gdk-pixbuf used extensively in the source
+# cairo used in eggtreemultidnd.c
+# pango used in fr-window
+RDEPEND=">=dev-libs/glib-2.29.14:2
+ sys-apps/file
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.2:3
+ x11-libs/pango
+ nautilus? ( >=gnome-base/nautilus-3 )
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+# eautoreconf needs:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ # --disable-debug because enabling it adds -O0 to CFLAGS
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ --disable-scrollkeeper
+ --disable-run-in-place
+ --disable-static
+ --disable-schemas-compile
+ --disable-debug
+ --enable-magic
+ $(use_enable nautilus nautilus-actions)
+ $(use_enable packagekit)"
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Use absolute path to GNU tar since star doesn't have the same
+ # options. On Gentoo, star is /usr/bin/tar, GNU tar is /bin/tar
+ epatch "${FILESDIR}"/${PN}-2.10.3-use_bin_tar.patch
+
+ # File providing Gentoo package names for various archivers
+ cp -f "${FILESDIR}/3.1.2-packages.match" data/packages.match || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "${PN} is a frontend for several archiving utilities. If you want a"
+ elog "particular achive format support, see ${HOMEPAGE}"
+ elog "and install the relevant package."
+ elog
+ elog "for example:"
+ elog " 7-zip - app-arch/p7zip"
+ elog " ace - app-arch/unace"
+ elog " arj - app-arch/arj"
+ elog " cpio - app-arch/cpio"
+ elog " deb - app-arch/dpkg"
+ elog " iso - app-cdr/cdrtools"
+ elog " jar,zip - app-arch/zip and app-arch/unzip"
+ elog " lha - app-arch/lha"
+ elog " lzma - app-arch/xz-utils"
+ elog " lzop - app-arch/lzop"
+ elog " rar - app-arch/unrar"
+ elog " rpm - app-arch/rpm"
+ elog " unstuff - app-arch/stuffit"
+ elog " zoo - app-arch/zoo"
+}