summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-23 00:16:23 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-23 00:16:23 +0000
commit0b3d4836eb233e0781e5e17a44274e7e0b6a2f7b (patch)
tree4e0d5e1805ff6b55bc215099c7bf065e6c5059bd /app-arch/pigz
parentAdded proxy maintainers herd. (diff)
downloadgentoo-2-0b3d4836eb233e0781e5e17a44274e7e0b6a2f7b.tar.gz
gentoo-2-0b3d4836eb233e0781e5e17a44274e7e0b6a2f7b.tar.bz2
gentoo-2-0b3d4836eb233e0781e5e17a44274e7e0b6a2f7b.zip
Don't return an error exit status when decompressing zero-padded files (bug #417657).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-arch/pigz')
-rw-r--r--app-arch/pigz/ChangeLog9
-rw-r--r--app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch47
-rw-r--r--app-arch/pigz/pigz-2.3.1-r1.ebuild43
3 files changed, 98 insertions, 1 deletions
diff --git a/app-arch/pigz/ChangeLog b/app-arch/pigz/ChangeLog
index 717a152c16bc..37253f0d96ff 100644
--- a/app-arch/pigz/ChangeLog
+++ b/app-arch/pigz/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/pigz
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/ChangeLog,v 1.36 2014/01/18 01:43:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/ChangeLog,v 1.37 2014/01/23 00:16:23 radhermit Exp $
+
+*pigz-2.3.1-r1 (23 Jan 2014)
+
+ 23 Jan 2014; Tim Harder <radhermit@gentoo.org> +pigz-2.3.1-r1.ebuild,
+ +files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch:
+ Don't return an error exit status when decompressing zero-padded files (bug
+ #417657).
18 Jan 2014; Mike Frysinger <vapier@gentoo.org> pigz-2.3.1.ebuild:
Add arm64 love.
diff --git a/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch b/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch
new file mode 100644
index 000000000000..9d2512e055a4
--- /dev/null
+++ b/app-arch/pigz/files/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch
@@ -0,0 +1,47 @@
+From 0c967f989d2f1afe1829cf7cf2f6d36846a625ec Mon Sep 17 00:00:00 2001
+From: Mark Adler <madler@alumni.caltech.edu>
+Date: Sun, 19 Jan 2014 23:21:58 -0800
+Subject: [PATCH] Do not return non-zero exit code when warnings issued.
+
+---
+ pigz.c | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/pigz.c b/pigz.c
+index 4fefe40..4a16799 100644
+--- a/pigz.c
++++ b/pigz.c
+@@ -478,7 +478,6 @@ local struct {
+ int procs; /* maximum number of compression threads (>= 1) */
+ int setdict; /* true to initialize dictionary in each thread */
+ size_t block; /* uncompressed input size per thread (>= 32K) */
+- int warned; /* true if a warning has been given */
+
+ /* saved gzip/zip header data for decompression, testing, and listing */
+ time_t stamp; /* time stamp from gzip header */
+@@ -519,7 +518,6 @@ local int complain(char *fmt, ...)
+ va_end(ap);
+ putc('\n', stderr);
+ fflush(stderr);
+- g.warned = 1;
+ }
+ return 0;
+ }
+@@ -3929,7 +3927,6 @@ int main(int argc, char **argv)
+ /* initialize globals */
+ g.outf = NULL;
+ g.first = 1;
+- g.warned = 0;
+ g.hname = NULL;
+
+ /* save pointer to program name for error messages */
+@@ -4020,5 +4017,5 @@ int main(int argc, char **argv)
+ /* done -- release resources, show log */
+ new_opts();
+ log_dump();
+- return g.warned ? 2 : 0;
++ return 0;
+ }
+--
+1.8.5.3
+
diff --git a/app-arch/pigz/pigz-2.3.1-r1.ebuild b/app-arch/pigz/pigz-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..e383b59e281c
--- /dev/null
+++ b/app-arch/pigz/pigz-2.3.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.3.1-r1.ebuild,v 1.1 2014/01/23 00:16:23 radhermit Exp $
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="A parallel implementation of gzip"
+HOMEPAGE="http://www.zlib.net/pigz/"
+SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86 ~amd64-linux ~sparc64-solaris"
+IUSE="static symlink test"
+
+LIB_DEPEND="sys-libs/zlib[static-libs(+)]"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+ test? ( app-arch/ncompress )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Do-not-return-non-zero-exit-code-when-warnings-issue.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dosym ${PN} /usr/bin/un${PN}
+ dodoc README
+ doman ${PN}.1
+
+ if use symlink; then
+ dosym ${PN} /usr/bin/gzip
+ dosym un${PN} /usr/bin/gunzip
+ fi
+}