summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-02-27 10:55:49 +0000
committerMichał Górny <mgorny@gentoo.org>2014-02-27 10:55:49 +0000
commit058b024808aa8d1e6327940654d0d1f083840311 (patch)
treeab8f91944717a928b7317ded40acbfa2182b28cd /app-arch/plzip
parentIntroduce the library necessary for app-arch/plzip. (diff)
downloadgentoo-2-058b024808aa8d1e6327940654d0d1f083840311.tar.gz
gentoo-2-058b024808aa8d1e6327940654d0d1f083840311.tar.bz2
gentoo-2-058b024808aa8d1e6327940654d0d1f083840311.zip
Introduce the parallel variant of app-arch/lzip.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'app-arch/plzip')
-rw-r--r--app-arch/plzip/ChangeLog9
-rw-r--r--app-arch/plzip/metadata.xml8
-rw-r--r--app-arch/plzip/plzip-1.1.ebuild28
3 files changed, 45 insertions, 0 deletions
diff --git a/app-arch/plzip/ChangeLog b/app-arch/plzip/ChangeLog
new file mode 100644
index 000000000000..777ff63b5918
--- /dev/null
+++ b/app-arch/plzip/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-arch/plzip
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/plzip/ChangeLog,v 1.1 2014/02/27 10:55:49 mgorny Exp $
+
+*plzip-1.1 (27 Feb 2014)
+
+ 27 Feb 2014; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +plzip-1.1.ebuild:
+ Introduce the parallel variant of app-arch/lzip.
diff --git a/app-arch/plzip/metadata.xml b/app-arch/plzip/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/app-arch/plzip/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-arch/plzip/plzip-1.1.ebuild b/app-arch/plzip/plzip-1.1.ebuild
new file mode 100644
index 000000000000..b8e45411350e
--- /dev/null
+++ b/app-arch/plzip/plzip-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/plzip/plzip-1.1.ebuild,v 1.1 2014/02/27 10:55:49 mgorny Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/plzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}