summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-10-24 06:45:16 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-10-24 06:45:16 +0000
commit12bbdef43d73945aee9ee7af112da658cfb6304c (patch)
tree68b0726303e3ab676a649d8e5182a4b7474195b2 /app-arch/tar/tar-1.27-r2.ebuild
parentVersion bump for nginx mainline/development version branch (bug #472524, than... (diff)
downloadgentoo-2-12bbdef43d73945aee9ee7af112da658cfb6304c.tar.gz
gentoo-2-12bbdef43d73945aee9ee7af112da658cfb6304c.tar.bz2
gentoo-2-12bbdef43d73945aee9ee7af112da658cfb6304c.zip
Fixed bug #489106. Moved dependency on sys-apps/attr from RDEPEND to DEPEND (bug #489170)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'app-arch/tar/tar-1.27-r2.ebuild')
-rw-r--r--app-arch/tar/tar-1.27-r2.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/app-arch/tar/tar-1.27-r2.ebuild b/app-arch/tar/tar-1.27-r2.ebuild
new file mode 100644
index 000000000000..c98b258e39c8
--- /dev/null
+++ b/app-arch/tar/tar-1.27-r2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.27-r2.ebuild,v 1.1 2013/10/24 06:45:16 polynomial-c Exp $
+
+EAPI="3"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Use this to make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="mirror://gnu/tar/${P}.tar.bz2
+ mirror://gnu-alpha/tar/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="acl minimal nls selinux static userland_GNU xattr"
+
+RDEPEND="acl? ( virtual/acl )
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.35 )
+ xattr? ( sys-apps/attr )"
+
+src_prepare() {
+ EPATCH_OPTS="-Z" \
+ epatch "${FILESDIR}"/${P}-acl_configure_fix.patch
+
+ if ! use userland_GNU ; then
+ sed -i \
+ -e 's:/backup\.sh:/gbackup.sh:' \
+ scripts/{backup,dump-remind,restore}.in \
+ || die "sed non-GNU"
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ FORCE_UNSAFE_CONFIGURE=1 \
+ econf \
+ --enable-backup-scripts \
+ --bindir="${EPREFIX}"/bin \
+ --libexecdir="${EPREFIX}"/usr/sbin \
+ $(usex userland_GNU "" "--program-prefix=g") \
+ $(use_with acl posix-acls) \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(use_with xattr xattrs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ local p=$(usex userland_GNU "" "g")
+ if [[ -z ${p} ]] ; then
+ # a nasty yet required piece of baggage
+ exeinto /etc
+ doexe "${FILESDIR}"/rmt || die
+ fi
+
+ # autoconf looks for gtar before tar (in configure scripts), hence
+ # in Prefix it is important that it is there, otherwise, a gtar from
+ # the host system (FreeBSD, Solaris, Darwin) will be found instead
+ # of the Prefix provided (GNU) tar
+ if use prefix ; then
+ dosym tar /bin/gtar
+ fi
+
+ dodoc AUTHORS ChangeLog* NEWS README* THANKS
+ newman "${FILESDIR}"/tar.1-${PV} ${p}tar.1
+ mv "${ED}"/usr/sbin/${p}backup{,-tar}
+ mv "${ED}"/usr/sbin/${p}restore{,-tar}
+
+ if use minimal ; then
+ find "${ED}"/etc "${ED}"/*bin/ "${ED}"/usr/*bin/ \
+ -type f -a '!' '(' -name tar -o -name ${p}tar ')' \
+ -delete
+ fi
+}