summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-12-29 10:02:14 +0000
committerMike Frysinger <vapier@gentoo.org>2008-12-29 10:02:14 +0000
commitda90dee62759ccef0280cad5b4bdf1ae3d1f9875 (patch)
treebf7fac9ebd14cc0c3eeab5834a7fc9efa9070ce6 /app-arch/tar
parentAdd gcc-4.3.{0,1}* to package.mask (diff)
downloadgentoo-2-da90dee62759ccef0280cad5b4bdf1ae3d1f9875.tar.gz
gentoo-2-da90dee62759ccef0280cad5b4bdf1ae3d1f9875.tar.bz2
gentoo-2-da90dee62759ccef0280cad5b4bdf1ae3d1f9875.zip
broken #252680
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/tar-1.21.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/app-arch/tar/tar-1.21.ebuild b/app-arch/tar/tar-1.21.ebuild
deleted file mode 100644
index 5ec753a0f01d..000000000000
--- a/app-arch/tar/tar-1.21.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.21.ebuild,v 1.1 2008/12/27 03:24:11 vapier Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="Use this to make tarballs :)"
-HOMEPAGE="http://www.gnu.org/software/tar/"
-SRC_URI="http://ftp.gnu.org/gnu/tar/${P}.tar.bz2
- ftp://alpha.gnu.org/gnu/tar/${P}.tar.bz2
- mirror://gnu/tar/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls static userland_GNU"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- nls? ( >=sys-devel/gettext-0.10.35 )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if ! use userland_GNU ; then
- sed -i \
- -e 's:/backup\.sh:/gbackup.sh:' \
- scripts/{backup,dump-remind,restore}.in \
- || die "sed non-GNU"
- fi
-}
-
-src_compile() {
- local myconf
- use static && append-ldflags -static
- use userland_GNU || myconf="--program-prefix=g"
- # Work around bug in sandbox #67051
- gl_cv_func_chown_follows_symlink=yes \
- econf \
- --enable-backup-scripts \
- --bindir=/bin \
- --libexecdir=/usr/sbin \
- $(use_enable nls) \
- ${myconf} || die
- emake || die "emake failed"
-}
-
-src_install() {
- local p=""
- use userland_GNU || p=g
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- if [[ -z ${p} ]] ; then
- # a nasty yet required piece of baggage
- exeinto /etc
- doexe "${FILESDIR}"/rmt || die
- fi
-
- dodoc AUTHORS ChangeLog* NEWS README* PORTS THANKS
- newman "${FILESDIR}"/tar.1 ${p}tar.1
- mv "${D}"/usr/sbin/${p}backup{,-tar}
- mv "${D}"/usr/sbin/${p}restore{,-tar}
-
- rm -f "${D}"/usr/$(get_libdir)/charset.alias
-}